Astrolux FT03 SST40 problem with decreasing power after few seconds

6 posts / 0 new
Last post
Last seen: 13 hours 12 min ago
Joined: 11/08/2019 - 09:02
Posts: 3
Location: Poland
Astrolux FT03 SST40 problem with decreasing power after few seconds


I have big problem with my new Astrolux. It doesnt work properly. If I turn it on TURBO mode, by doubleclick or in “momentary” mode it decreases power after 5-10 second. It does the same even from HIGH mode using ramping… I tested flashlight with 2 different good quality and fully charged batterys. Flashlight was not overheating, it was very cold even, because I tested it outside at only 5 degres Ceclcius…

I know the flashlight normally decrease power because of the heat, but it does after about 5 minutes, not 5 seconds… (regarding this )

And more, for just simple HIGH mode it decrease power steadily, not suddenly like mine…

And more, what says that something is wrong, after like 5 times it decreased power after few second, it started to working properly with full power for about a minute (and I just turned it off). And later, about 15 minutes, it started working badly one more time…

I recorded a video to show the problem:

What is wrong? Is this the driver problem?

Edited by: Vendeur on 11/08/2019 - 09:11
Last seen: 5 hours 32 min ago
Joined: 06/16/2019 - 06:31
Posts: 28
Location: Belgium

I would guess the temperature isn’t calibrated right… you can re-calibrate it in the settings. Its written in the user manual how to do it, but basically goes like this:

-press and hold the button for +-16s till a double flash followed by a single blink is seen.
-wait till it double flashes again but blinks twice this time.
-wait till it double flashes again but blinks three times.
-press twice
- the light will go in turbo, and will warm up, click once to set that temperature to the desired cut-off temperature. (use full batteries)
-click and hold till it blinks 4 times to exit the settings

!!!! ^this way only works if your light is in RAMPING UI !!!!

If this doesn’t help I have no idea what the problem could be and you should probably ask for a replacement Smile

Last seen: 17 hours 43 min ago
Joined: 11/03/2019 - 10:10
Posts: 40
Location: 3rd Stone From The Sun

Dzien Dobry!

This is in the manual.

OR you can disable the step down and use your hand as a judge like I do.

Hold button down for 16+ Seconds This is more like 5 seconds for my light and my buddies.

-DO NOT release until the First “Double Flash” AND Single blink.

-WAIT for “Double Flash” AND 3 Blinks.

-Then Click ONE time.

-NO More clicks, WAIT until it blinks for setting #4.

-Shortly after that it will blink 4 times to indicate the END of Configuration mode.

Good luck,,I hope that will resolve your issue. I have a feeling it will.

Last seen: 13 hours 12 min ago
Joined: 11/08/2019 - 09:02
Posts: 3
Location: Poland

Guys, I think this is not the problem of temperature, because as I said, flashlight decreased power when it was very cold. And started working well when heated a bit…

And after 15 minutes it decreased again.

What is weird, from yesterday when I tried it at home, and it worked well, today it works well as well. I just tested it and worked on TURBO more than 6 mins before I just turned it off. Even not decreased power itself…

So. This is really weird. It tells that flashlight not work well if it’s cold. But this is literally stupid and not possible. Maybe battery is not working well when cold? But 5-10 Celcius is nothing wrong/cold for Panasonic/Samsung batterys…

Last seen: 13 hours 12 min ago
Joined: 11/08/2019 - 09:02
Posts: 3
Location: Poland

Ok, I did another test …

Flashlight with battery cooled in the fridge for over an hour. It had about 5-7 degrees. Turn it on, after 8 seconds it reduced the brightness … Well, I think battery too cold. I replace it with a charged one and at room temperature. The flashlight after 8 seconds reduces the brightness again…

I put the cold battery back in and turn on the flashlight. Guess how much time it worked in turbo mode … 25 minutes! Finally, I got bored and turned it off. It warmed up just to warm the hand well, but not to burn. And here I am very surprised. Battery already had 3.1V, so I puted a new one and there was no brightness difference. During these 25 minutes flashlight reduced the brightness just a little, if any…

And now I completely understand nothing. Because this length of time contradicts everything. Like if it did not work on real TURBO mode. But it’s impossible. It has an incomparably greater range than the Convoy C8 XPL HI.

Last seen: 5 hours 31 min ago
Joined: 08/04/2017 - 23:58
Posts: 1458
Location: Manila, Philippines

Have you tried disabling the thermal stepdown mentioned by BaronVonEissler? I suggest to set that first, just to rule out other issues..

Then also check the contact points (battery tube, the springs). See if anything is loose.