Convoy S3 triple won't turn on...

14 posts / 0 new
Last post
crz6662
Offline
Last seen: 1 day 9 hours ago
Joined: 06/13/2016 - 11:11
Posts: 222
Location: PGH,PA.
Convoy S3 triple won't turn on...

For the life of me I can’t figure out what I’m doing wrong. Reassembled 3 times but my new triple won’t fire up. XPL-Hi triple, H17F Dr Jones driver. Arctic Silver 5 under the star and between the home made heat sink and shelf. Maybe the drivers not fully seated and grounded ?
I repair phones, tablets and some computer parts so I should be able to do this but need some help as to what to look for.
Suggestions?

Bc412
Offline
Last seen: 1 month 2 weeks ago
Joined: 10/15/2015 - 23:06
Posts: 315
Location: United States

Quite a few of my builds I had to put a dab of solder on the ground ring of the driver so it made good contact with the retaining rings.

crz6662
Offline
Last seen: 1 day 9 hours ago
Joined: 06/13/2016 - 11:11
Posts: 222
Location: PGH,PA.

Ok. Will do. I was thinking the ground. This S3 is a pain to work.
Thanks

crz6662
Offline
Last seen: 1 day 9 hours ago
Joined: 06/13/2016 - 11:11
Posts: 222
Location: PGH,PA.

On top or underneath?

mattlward
mattlward's picture
Offline
Last seen: 2 hours 39 min ago
Joined: 06/19/2015 - 09:20
Posts: 2241
Location: Illinois, USA

Mount up the driver and then put a touch of solder from the ground ring on the driver to the pill. But first, have you fired it up outside of the light to make sure the driver and the LED do work? I would really suggest that you do that first. It is always a good plan to do that first with any light to eliminate this kind of hair pulling problem.

EDC rotation:
Convoy S2+, 6*7135, XM-L2 3D, 10 degree TIR, PilotDog lighted tailcap.
Convoy S2+, H17F, XM-L2 4C, lighted tailcap
Zebralight SC52w-L2
Olight S1A
Olight S1R

crz6662
Offline
Last seen: 1 day 9 hours ago
Joined: 06/13/2016 - 11:11
Posts: 222
Location: PGH,PA.

I did think of that but didn’t. Not sure how I need to check the driver though. Help me out ?

mattlward
mattlward's picture
Offline
Last seen: 2 hours 39 min ago
Joined: 06/19/2015 - 09:20
Posts: 2241
Location: Illinois, USA

You would either use clip leads to go from the driver wires to the led or really you should solder it up on the bench first and the power it with either a bench supply or a battery with magnets holding the wires on. Just tap the spring with one wire while holding the other in place, no switch needed.

Word of warning… Do not power up the driver without an LED attached! That will kill the FET in many drivers.

This is my “bench power supply”

20160405_202035

EDC rotation:
Convoy S2+, 6*7135, XM-L2 3D, 10 degree TIR, PilotDog lighted tailcap.
Convoy S2+, H17F, XM-L2 4C, lighted tailcap
Zebralight SC52w-L2
Olight S1A
Olight S1R

crz6662
Offline
Last seen: 1 day 9 hours ago
Joined: 06/13/2016 - 11:11
Posts: 222
Location: PGH,PA.

Nice set up. Since its already together, again, I’ll try the ground 1st and if that doesn’t work, tear it apart and test.
I mistakenly ordered the S3. I wanted the S2+. Working in that little ass tube, sucks.

mattlward
mattlward's picture
Offline
Last seen: 2 hours 39 min ago
Joined: 06/19/2015 - 09:20
Posts: 2241
Location: Illinois, USA

That little power supply can be built for less than about 10 bux and it is so useful. I have killed a couple of old XM-L’s hauling it around, but then again I have pulled a dozen or more out so have spares. I power it with a 4 amp 5 volt supply, good enough for single cell voltage lights and drivers.

EDC rotation:
Convoy S2+, 6*7135, XM-L2 3D, 10 degree TIR, PilotDog lighted tailcap.
Convoy S2+, H17F, XM-L2 4C, lighted tailcap
Zebralight SC52w-L2
Olight S1A
Olight S1R

EasyB
Offline
Last seen: 4 hours 45 min ago
Joined: 03/09/2016 - 15:24
Posts: 1192
Location: Ohio

I had a confusing problem the last time I built an S2+. There was a problem in the tailcap. When the retaining ring was tightened the switch would be slightly compressed, preventing electrical contact. Have you tried bypassing the tailcap with a wire?

crz6662
Offline
Last seen: 1 day 9 hours ago
Joined: 06/13/2016 - 11:11
Posts: 222
Location: PGH,PA.

Not yet but it’s in the plans…

SIGShooter
Offline
Last seen: 2 hours 59 min ago
Joined: 07/14/2013 - 02:10
Posts: 1007
Location: northern california

That’s always the first thing I do when lights don’t come on since it’s simple and quick.

crz6662
Offline
Last seen: 1 day 9 hours ago
Joined: 06/13/2016 - 11:11
Posts: 222
Location: PGH,PA.

@Bc412 The ground was the problem. Up and running. Appreciate your suggestion.
lf I could figure out how to post a pic, I’d show you.
The integrated shelf does seem to help a bit on heat dissipation compared to my Astrolux S1.
Thanks for the help guys.

crz6662
Offline
Last seen: 1 day 9 hours ago
Joined: 06/13/2016 - 11:11
Posts: 222
Location: PGH,PA.

 Displaying IMG_0806.JPG

 Displaying IMG_0795.JPG
 
Displaying IMG_0794.JPG
 

My Convoy S3 Triple. 1/2 inch solid brass plug worked great for my homemade heat sink. Had to cut it in half but the base sat on the integrated shelf perfectly. Handles the heat well. Never to hot to hold.

(On second thought, Damn, it does get very warm)....

17mm DrJones H17F Driver w/ lucidrv2 - 7135 + FET  The firefly mode is excellent. Never realized how bright moonlight mode was until I saw firefly. 

(3) CREE XP-L High-Intensity V2 1A LEDs on NOCTIGON 3XP MCPCB + PRE-BRIDGED

10507 Carclo Lens - 3-UP Narrow Spot Optic

Ordered these on a Friday and had them on Monday. Even though the site said it wouldn't ship until they got back, from what I assume was vacation. Absolutely great service from MtnElectronics. 

18650 is a bit big for EDC but the 18350 is perfect. With this driver in it, I can go days without recharging it but still have the wow factor when needed. 

Hate to say, but my Astrolux S1 might be next, less the driver of course. 

My ol' lady just rolls her eyes and shakes her head. LOL

I'm curious as to what this is putting out though. You guys/gals got me hooked.