RC-G2 III

12 posts / 0 new
Last post
RAW74
RAW74's picture
Offline
Last seen: 10 months 4 weeks ago
Joined: 07/23/2012 - 16:01
Posts: 813
Location: east coast USA
RC-G2 III
I have a Romisen RC-G2 III from Shiningbeam.I was wondering if it is safe to use with a 14500, or would it fry the driver?I don’t see it saying NOT to use a 14500 on the website, but lists input voltage at 1.2/1.5.Thanks-Rick.
scaru
scaru's picture
Offline
Last seen: 3 years 2 months ago
Joined: 03/22/2012 - 13:36
Posts: 6946
Location: Virginia

If it says the input voltage is 1.2-1.5 then don't try it unless you're willing to replace the driver. 

SashiX
SashiX's picture
Offline
Last seen: 5 years 10 months ago
Joined: 10/07/2010 - 15:46
Posts: 2045
Location: Spain

Dunno, but ask Brian anyway :bigsmile:

AlexGT
AlexGT's picture
Offline
Last seen: 1 day 20 hours ago
Joined: 06/07/2012 - 17:39
Posts: 4400
Location: Texas

driver will fry, dont try it!

Match
Match's picture
Offline
Last seen: 3 years 10 months ago
Joined: 11/14/2010 - 11:57
Posts: 1488
Location: South Carolina, USA

Let's find out!

(goes into his misc. box of flashlights and finds an RC-G2 II)

Now for an IMR 14500 - gotta do it right...

Just a sec...brb....

 

OUCH! Sonofa....

 

Ok...I know it's not a III, only a II but I'm pretty sure it's the same driver.

DEFINATLY NO 14500!

I hit 11.5 amps before I dropped the leads....

Looks like I have something to fix now, hope your happy...Tongue Out

scaru
scaru's picture
Offline
Last seen: 3 years 2 months ago
Joined: 03/22/2012 - 13:36
Posts: 6946
Location: Virginia

Match wrote:

Let's find out!

(goes into his misc. box of flashlights and finds an RC-G2 II)

Now for an IMR 14500 - gotta do it right...

Just a sec...brb....

 

OUCH! Sonofa....

 

Ok...I know it's not a III, only a II but I'm pretty sure it's the same driver.

DEFINATLY NO 14500!

I hit 11.5 amps before I dropped the leads....

Looks like I have something to fix now, hope your happy...Tongue Out

Nice! Big Smile

Match
Match's picture
Offline
Last seen: 3 years 10 months ago
Joined: 11/14/2010 - 11:57
Posts: 1488
Location: South Carolina, USA

Follow up:

Ok...it's cooled down enough for me to pick it up and do a quick inspection. 

- Yes it did light up on the imr14500

- No, it wasn't crazy bright

- Yes it did hit 11.5 amps

- No it didn't explode

- Yes....it still works... So slap my arse and call me Sally - I'm truly surprised!

scaru
scaru's picture
Offline
Last seen: 3 years 2 months ago
Joined: 03/22/2012 - 13:36
Posts: 6946
Location: Virginia

RAW74
RAW74's picture
Offline
Last seen: 10 months 4 weeks ago
Joined: 07/23/2012 - 16:01
Posts: 813
Location: east coast USA
Thanks Match…guess I won’t try the 14500 afterall!I hope your burns heal quickly!So I called you Sally…now what?Do we need to start the lube thread again?-Rick
AlexGT
AlexGT's picture
Offline
Last seen: 1 day 20 hours ago
Joined: 06/07/2012 - 17:39
Posts: 4400
Location: Texas
Match wrote:
… So slap my arse and call me Sally – I’m truly surprised!
Big Smile Big Smile Big Smile

Chicago X
Chicago X's picture
Offline
Last seen: 6 years 8 months ago
Joined: 07/22/2011 - 16:13
Posts: 4013
Location: See Name

That first pic makes me hungry for some reason.

http://wardogsmakingithome.org/index.html

War Dogs, Making it Home - Rescue Dogs for Returning Vets

pretzy
pretzy's picture
Offline
Last seen: 2 years 2 months ago
Joined: 04/26/2012 - 06:45
Posts: 1003
Location: Albury Australia

Mmmm mmm, that sure is a mighty tasty lookin sauce!

The light shines in the darkness, and the darkness has not overcome it.