C3 SS 1AA/14500 light troubleshooting question...

4 posts / 0 new
Last post
mattlward
mattlward's picture
Online
Last seen: 7 min 23 sec ago
Joined: 06/19/2015 - 09:20
Posts: 2760
Location: Illinois, USA
C3 SS 1AA/14500 light troubleshooting question...

I purchased one of these from DX Soul and I love the form factor of the little guy, I picked it up to drop a Nicha 219B in. But, it stopped working correctly. It will work if I back off the tailcap or the head. I am making the assumption that there is a loose component on the driver board and the flex from tightening every thing down is causing a component to lift. So, I am tempted to remove the pill, set if flat with the component side up and heat up the back side of the driver board and see if the component will settle back in. The solder connection to the pill looks good and strong and the 3 large solder connections that are visible on the backside look ok as well.

Any ideas? Of course DXSoul wants to give me 4 bux and keep the bad light… I am working on that with them.

Do we have a DXSoul rep on the site?

Thanks Matt

EDC rotation:
FW1A, LH351D 4000k (second favorite)
FW3A, LH351D 3500k
FW3A, SST20 FD2 4000k
FW3A, Nichia 4000k sw40 r9080 (favorite light!)
FW3A, Cree XP-L Hi 5A3
Emisar D4V2, SST20 4000k
S2+, XM-L2 T6 4C

MRsDNF
MRsDNF's picture
Offline
Last seen: 1 hour 1 min ago
Joined: 12/22/2011 - 21:18
Posts: 13057
Location: A light beam away from the missus in the land of Aus.

It could be that the driver board is being flexed enough from the pressure that it no longer operates. I've had this happen on more than one occasion with different lights.

 

djozz quotes, "it came with chinese lettering that is chinese to me".

                      "My man mousehole needs one too"

old4570 said "I'm not an expert , so don't suffer from any such technical restrictions".

Old-Lumens. Highly admired and cherished member of Budget Light Forum. 11.5.2011 - 20.12.16. RIP.

 

keltex78
keltex78's picture
Offline
Last seen: 1 month 5 days ago
Joined: 03/18/2011 - 10:15
Posts: 3705
Location: Texas

I had similar issues with my non-SS C3 until I completely disassembled and rebuilt it. I think it was pressure lifting the entire pill assembly? I don’t recall exactly, as I never really liked that light.


Keepin’ the “B” in BLF

Don wrote:
It sounds like the XM LEDs won’t really be suitable for flashlight use. Pity…

mattlward
mattlward's picture
Online
Last seen: 7 min 23 sec ago
Joined: 06/19/2015 - 09:20
Posts: 2760
Location: Illinois, USA

The reflector had a long straight leading edge that I was able to file down and this allowed me to seat the pill deeper and removed excess pressure from the driver. I really like the little light, but must put something in with a better tint. I am thinking it would be a good 219b candidate. Although it draws 2.1 amps at the tail with a Windy fire 14500. Maybe a good bin XP-G2 to maintain some throw.

Matt

EDC rotation:
FW1A, LH351D 4000k (second favorite)
FW3A, LH351D 3500k
FW3A, SST20 FD2 4000k
FW3A, Nichia 4000k sw40 r9080 (favorite light!)
FW3A, Cree XP-L Hi 5A3
Emisar D4V2, SST20 4000k
S2+, XM-L2 T6 4C