New Convoy 7135 driver cannot be flashed

19 posts / 0 new
Last post
zeremefico
zeremefico's picture
Offline
Last seen: 53 min 57 sec ago
Joined: 03/27/2012 - 02:44
Posts: 1356
Location: Greece
New Convoy 7135 driver cannot be flashed

Just received a couple C8s xp-l hi for BG and I noticed a Convoy branded driver, instead the classic one.

I was impressed with the new spring which seems better and was used first in the Convoy driver with biscotti firmware
Unfortunately, when I tried to flash the driver, I got error message from avrdude.

MCU:
ATMEL1638
TINY13A
SSU

₪₪₪₪ ΟΥΔΕΝ ΚΡΥΠΤΟΝ ΥΠΟ ΤΟΝ ΗΛΙΟ ₪₪₪₪

My YouTube channel

Flashlights & edc gear

K40M F16

MILSPEC
Offline
Last seen: 2 months 1 week ago
Joined: 10/12/2016 - 06:02
Posts: 555

What was the error message? Any clue whether the Attiny is locked? can you read it out?

Jerommel
Jerommel's picture
Offline
Last seen: 4 months 2 days ago
Joined: 01/04/2014 - 13:18
Posts: 6380
Location: the Hague, Netherlands

I think it’s because the top right leg of the chip is connected to ground.

giorgoskok
giorgoskok's picture
Offline
Last seen: 2 weeks 4 days ago
Joined: 11/13/2015 - 10:46
Posts: 2670
Location: Greece

Is this the old driver or the new one ?

Because new one has some issues :

They used wrong fuses :

http://budgetlightforum.com/comment/1060748#comment-1060748

Also take a look here :

http://budgetlightforum.com/comment/1052606#comment-1052606

zeremefico
zeremefico's picture
Offline
Last seen: 53 min 57 sec ago
Joined: 03/27/2012 - 02:44
Posts: 1356
Location: Greece

Very useful.
I am not at home and i cannot post the error message avrdude shows.
I believe the solution George post above, is the way to go.

₪₪₪₪ ΟΥΔΕΝ ΚΡΥΠΤΟΝ ΥΠΟ ΤΟΝ ΗΛΙΟ ₪₪₪₪

My YouTube channel

Flashlights & edc gear

K40M F16

Texas_Ace
Texas_Ace's picture
Offline
Last seen: 11 hours 7 min ago
Joined: 03/24/2016 - 07:44
Posts: 8855
Location: Everything is brighter in Texas

Interesting that there is another new driver. Is this an updated version of the “red” driver with the correct fuses I wounder?

zeremefico
zeremefico's picture
Offline
Last seen: 53 min 57 sec ago
Joined: 03/27/2012 - 02:44
Posts: 1356
Location: Greece

J-Dub74 can answer that.

₪₪₪₪ ΟΥΔΕΝ ΚΡΥΠΤΟΝ ΥΠΟ ΤΟΝ ΗΛΙΟ ₪₪₪₪

My YouTube channel

Flashlights & edc gear

K40M F16

J-Dub74
J-Dub74's picture
Offline
Last seen: 4 months 1 day ago
Joined: 03/14/2015 - 17:17
Posts: 2231
Location: Michigan

Sadly this is the first I have heard or seen of this driver. I did tell him to put his name on the driver which was supposed to be coming down the line but they’re also supposed to be red and I don’t think they have the fuse values set correctly yet. Any driver that has all the corrections I sent Simon has not even left the factory yet.

Like Jerommel said, the flashing issue is likely a grounded pin on the MCU. That is the case on the red drivers. Tom E did some troubleshooting for me and in the case of the red drivers pin #5 of the MCU was grounded and to flash the driver he took an exacto across the trace that was grounding it, then it flashed fine. I can’t see close enough from these pictures but in the case of the red drivers you have to cut where the yellow lines are shown below to break the connection and then it flashes fine.

J-Dub74
J-Dub74's picture
Offline
Last seen: 4 months 1 day ago
Joined: 03/14/2015 - 17:17
Posts: 2231
Location: Michigan

zeremefico wrote:
J-Dub74 can answer that.

Can you try to get a clear close-up picture of each side of the board, particularly, around the MCU? That would be helpful
zeremefico
zeremefico's picture
Offline
Last seen: 53 min 57 sec ago
Joined: 03/27/2012 - 02:44
Posts: 1356
Location: Greece

cannot se sck period
target doesnt answer
This is the failure message i get when try to flash it.
Macro pics soon

₪₪₪₪ ΟΥΔΕΝ ΚΡΥΠΤΟΝ ΥΠΟ ΤΟΝ ΗΛΙΟ ₪₪₪₪

My YouTube channel

Flashlights & edc gear

K40M F16

zeremefico
zeremefico's picture
Offline
Last seen: 53 min 57 sec ago
Joined: 03/27/2012 - 02:44
Posts: 1356
Location: Greece

₪₪₪₪ ΟΥΔΕΝ ΚΡΥΠΤΟΝ ΥΠΟ ΤΟΝ ΗΛΙΟ ₪₪₪₪

My YouTube channel

Flashlights & edc gear

K40M F16

Sirius9
Sirius9's picture
Offline
Last seen: 15 hours 53 min ago
Joined: 03/04/2012 - 19:23
Posts: 4618
Location: South Europe

I can confirm this, yesterday tried to reprogram one of those new red convoy drivers and got same error, but after cutting 5th mcu leg I was able to reprogram it without issues.

 

power911
power911's picture
Offline
Last seen: 5 hours 51 min ago
Joined: 05/12/2014 - 02:14
Posts: 882
Location: Malaysia

I got these new drivers on my s2+ as well.

Same layout with the red driver.

“Have you forgotten about all those who called you a Bringer of Woe and hunted you like an animal?”
“Normal humans don’t go around killing people and burning towns!”
“Don’t worry. I’ll go with you! So you just follow me and no arguing, okay?”

J-Dub74
J-Dub74's picture
Offline
Last seen: 4 months 1 day ago
Joined: 03/14/2015 - 17:17
Posts: 2231
Location: Michigan

So, I couldn’t really see much from the picture of the green driver all back-lit but if it is indeed the same layout as the red then cutting right where I showed should fix the flashing issue. I passed this along to Simon too. Of course both Simon and his driver factory are all on holiday right now for the spring festival. Several more weeks of little or no communication with China but when he gets back he’ll pass the info to the proper people and hopefully get a fix in the works for the next run of drivers.

mattlward
mattlward's picture
Offline
Last seen: 2 months 2 weeks ago
Joined: 06/19/2015 - 09:20
Posts: 2828
Location: Illinois, USA

Does that leg then need to be reconnected to ground?

EDC rotation:
FW1A, LH351D 4000k (second favorite)
FW3A, LH351D 3500k
FW3A, SST20 FD2 4000k
FW3A, Nichia 4000k sw40 r9080 (favorite light!)
FW3A, Cree XP-L Hi 5A3
Emisar D4V2, SST20 4000k
S2+, XM-L2 T6 4C

Lexel
Lexel's picture
Offline
Last seen: 1 day 18 min ago
Joined: 11/01/2016 - 08:00
Posts: 5894
Location: Germany

If this leg is connected to ground the MCU cant be reset

Sirius9
Sirius9's picture
Offline
Last seen: 15 hours 53 min ago
Joined: 03/04/2012 - 19:23
Posts: 4618
Location: South Europe

mattlward wrote:
Does that leg then need to be reconnected to ground?

No, it can be left hanging alone Smile

 

J-Dub74
J-Dub74's picture
Offline
Last seen: 4 months 1 day ago
Joined: 03/14/2015 - 17:17
Posts: 2231
Location: Michigan

For the record I was not saying to literally cut the leg but just the trace on the board as I showed with yellow lines. This could be done with an exacto blade or something like that, just be careful to just cut were indicated by the yellow lines to break connection of the trace there. There are others who could probably explain it better…

Sirius9
Sirius9's picture
Offline
Last seen: 15 hours 53 min ago
Joined: 03/04/2012 - 19:23
Posts: 4618
Location: South Europe