making a small batch of Texas Avenger "TA" Drivers fully tested running Bistro or Narsil, Clicky or E-switch, SIR800

246 posts / 0 new
Last post
Tom E
Tom E's picture
Offline
Last seen: 59 min 3 sec ago
Joined: 08/19/2012 - 08:23
Posts: 10615
Location: LI NY

Are you guys talk'n bout a tail bleeder LED (Bistro - clicky) or locator LED w/Narsil? For Narsil I use somewhere between 2K and 15K, depends on the LED(s) and visibility of the LED.

Texas_Ace
Texas_Ace's picture
Offline
Last seen: 3 hours 29 min ago
Joined: 03/24/2016 - 07:44
Posts: 4219
Location: Everything is brighter in Texas

Well, it sounds like he is talking about installing an indicator LED using the tailcap bleeder pads.

So it would remain on 24/7 and drain the battery continually. 50k ohm resistor tends to have the final output be around ~0.050ma from my testing, so a little over 1ma per day of drain.

The Second Amendment is in place in case the politicians ignore the others.

Government is the great fiction, through which everybody endeavors to live at the expense of everybody else. -- Frederic Bastiat , French economist(1801-1850)

Texas Avenger Driver Series

My LED Test series - XP-L2 V5  - Nichia 219C 90+ CRILatticebright "XM-L"XHP35 & PWM efficiency - XHP50 - XP-L V5 - XM-L2 U2 - XP-G3 S5  - XP-L HI V2 - Oslon Square & direct comparison to Djozz tests - Nichia 319A - Nichia 219B 9080 CRI - Nichia 219C D320 - Nichia 229AT

How I made a True integrating PVC sphere with no math involved

-X3-
-X3-'s picture
Offline
Last seen: 22 hours 32 min ago
Joined: 07/16/2014 - 03:28
Posts: 1576
Location: France, Angers

I want to use the Narsil option to activate/desactivate the locator LED, not simply use a bleeder resistor + LED Smile

Slowly sinking into the dark abyss of addiction...MUST buy lights !

My Flashlight public album (mods, emitter swaps, eye candy)

My reviews channel (French language, Olight, Thorfire : 30+ lights tested)

My personal channel (including Olight SR mini, S1, S2, S1A and S-mini disassembly)

M4DM4X's deals and coupons

Texas_Ace
Texas_Ace's picture
Offline
Last seen: 3 hours 29 min ago
Joined: 03/24/2016 - 07:44
Posts: 4219
Location: Everything is brighter in Texas
X3 wrote:
I want to use the Narsil option to activate/desactivate the locator LED, not simply use a bleeder resistor + LED Smile

This makes more sense and it also means you don’t need a resistor, or at least as big of one. But in this case you can’t use the bleeder resistor pads. I am not sure what pads you need to use but I think the voltage divider pads. Never used an indicator LED with narsil before myself.

The Second Amendment is in place in case the politicians ignore the others.

Government is the great fiction, through which everybody endeavors to live at the expense of everybody else. -- Frederic Bastiat , French economist(1801-1850)

Texas Avenger Driver Series

My LED Test series - XP-L2 V5  - Nichia 219C 90+ CRILatticebright "XM-L"XHP35 & PWM efficiency - XHP50 - XP-L V5 - XM-L2 U2 - XP-G3 S5  - XP-L HI V2 - Oslon Square & direct comparison to Djozz tests - Nichia 319A - Nichia 219B 9080 CRI - Nichia 219C D320 - Nichia 229AT

How I made a True integrating PVC sphere with no math involved

Tom E
Tom E's picture
Offline
Last seen: 59 min 3 sec ago
Joined: 08/19/2012 - 08:23
Posts: 10615
Location: LI NY

Ooops, removed this post. Lexel is using an older version of NarsilTriple, so not sure about the Indicator LED support.

solRNY
Offline
Last seen: 2 hours 31 min ago
Joined: 03/27/2017 - 17:24
Posts: 97
Location: Syracuse, NY

What would you recommend for a broken thorfire s70s driver?

Texas_Ace
Texas_Ace's picture
Offline
Last seen: 3 hours 29 min ago
Joined: 03/24/2016 - 07:44
Posts: 4219
Location: Everything is brighter in Texas
solRNY wrote:
What would you recommend for a broken thorfire s70s driver?

The TA30 was designed for the L6 and S70. I love it in my L6 although it can get really hot if you run it on turbo.

The Second Amendment is in place in case the politicians ignore the others.

Government is the great fiction, through which everybody endeavors to live at the expense of everybody else. -- Frederic Bastiat , French economist(1801-1850)

Texas Avenger Driver Series

My LED Test series - XP-L2 V5  - Nichia 219C 90+ CRILatticebright "XM-L"XHP35 & PWM efficiency - XHP50 - XP-L V5 - XM-L2 U2 - XP-G3 S5  - XP-L HI V2 - Oslon Square & direct comparison to Djozz tests - Nichia 319A - Nichia 219B 9080 CRI - Nichia 219C D320 - Nichia 229AT

How I made a True integrating PVC sphere with no math involved

JasonWW
JasonWW's picture
Offline
Last seen: 7 hours 20 min ago
Joined: 10/22/2016 - 11:41
Posts: 2192
Location: Houston Texas

Tom E wrote:

Are you guys talk’n bout a tail bleeder LED (Bistro – clicky) or locator LED w/Narsil? For Narsil I use somewhere between 2K and 15K, depends on the LED(s) and visibility of the LED.


I’m not sure what aplication X3 is using.

I was talking about a side switch led for the L6, not tail switch.

I don’t know much about the “indicator” or “locator” led. My plan was simply to have the side switch light up whenever the tail switch was turned on.

When not using the light I will click the tail switch off which cuts all power.

I want LVP, so I got Lexel to install Narsil v1.2.

My Convoy L6 thread with XHP70.2, Texas Avenger FET driver, Narsil v1.2 ramping firmware, lighted side switch and cut down SMO reflector. Lots of amp draws on stock driver as well.
http://budgetlightforum.com/node/54477

My Supfire L5-S thread with XHP70, Texas Avenger FET driver, NarsilM ramping firmware and lighted side switch. My mini L6! http://budgetlightforum.com/node/55746

6 NarsilM user videos https://www.youtube.com/user/JasonWW2000

JasonWW
JasonWW's picture
Offline
Last seen: 7 hours 20 min ago
Joined: 10/22/2016 - 11:41
Posts: 2192
Location: Houston Texas

BTW, I have a 1.45 milliamp drain on one of my drivers. Is that considered high? It has had zero effect on battery life so it doesn’t seem to be a big deal.

My Convoy L6 thread with XHP70.2, Texas Avenger FET driver, Narsil v1.2 ramping firmware, lighted side switch and cut down SMO reflector. Lots of amp draws on stock driver as well.
http://budgetlightforum.com/node/54477

My Supfire L5-S thread with XHP70, Texas Avenger FET driver, NarsilM ramping firmware and lighted side switch. My mini L6! http://budgetlightforum.com/node/55746

6 NarsilM user videos https://www.youtube.com/user/JasonWW2000

Tom E
Tom E's picture
Offline
Last seen: 59 min 3 sec ago
Joined: 08/19/2012 - 08:23
Posts: 10615
Location: LI NY

JasonWW wrote:
BTW, I have a 1.45 milliamp drain on one of my drivers. Is that considered high? It has had zero effect on battery life so it doesn't seem to be a big deal.

Narsil is wayyyy lower, after you wait 10 secs or so from turn OFF. Did you wait long enough? In the newer versions it's reduced to 5 seconds or so.

It should be 0.021 mA without R1/R2. If you are using R1/R2, depends on what values you use. I typically use 192K and 47K - 10X less drain for the old resistor values, so resulting drain is 0.038 mA.

1.45 mA is like 38X greater.

JasonWW
JasonWW's picture
Offline
Last seen: 7 hours 20 min ago
Joined: 10/22/2016 - 11:41
Posts: 2192
Location: Houston Texas

Tom E wrote:

JasonWW wrote:
BTW, I have a 1.45 milliamp drain on one of my drivers. Is that considered high? It has had zero effect on battery life so it doesn’t seem to be a big deal.

Narsil is wayyyy lower, after you wait 10 secs or so from turn OFF. Did you wait long enough? In the newer versions it’s reduced to 5 seconds or so.


It should be 0.021 mA without R1/R2. If you are using R1/R2, depends on what values you use. I typically use 192K and 47K – 10X less drain for the old resistor values, so resulting drain is 0.038 mA.


1.45 mA is like 38X greater.


I was asking about an FX-30 driver I’m using.

Also, what kind of drain do you get from a zener modded driver?

My Convoy L6 thread with XHP70.2, Texas Avenger FET driver, Narsil v1.2 ramping firmware, lighted side switch and cut down SMO reflector. Lots of amp draws on stock driver as well.
http://budgetlightforum.com/node/54477

My Supfire L5-S thread with XHP70, Texas Avenger FET driver, NarsilM ramping firmware and lighted side switch. My mini L6! http://budgetlightforum.com/node/55746

6 NarsilM user videos https://www.youtube.com/user/JasonWW2000

Lexel
Lexel's picture
Offline
Last seen: 4 hours 25 min ago
Joined: 11/01/2016 - 08:00
Posts: 2564
Location: Germany

the locator LED/sideswitch LED can be used with tailswitch lights without a problem, that was its main purpose

for lights with no tailswitch a locator LED should have a pretty high resistor, like Texas_Ace wrote to get low parasitic drain, you can still get brighter that trits with parasitic drain af a few 100uA

khas
Offline
Last seen: 42 min 42 sec ago
Joined: 08/08/2014 - 07:20
Posts: 766
Location: Denmark

My drivers arrived today, they look very nice.

Thank you for doing this, can’t wait to put them in to use.

EDIT : Just finished putting one of the drivers in a Skilhunt H02, re-flowed the original emitter to a Noctigon MCPCB, the UI is great with lots of options and the ramping is fast and smooth.

It get very hot very fast Big Smile

-X3-
-X3-'s picture
Offline
Last seen: 22 hours 32 min ago
Joined: 07/16/2014 - 03:28
Posts: 1576
Location: France, Angers

My driver arrived today, and is already in his pretty host : Nitecore HC30
What a wonderful UI ! I love the ramping, really intuitive, and fast at the same time !
Thank you very much once again Lexel !

Slowly sinking into the dark abyss of addiction...MUST buy lights !

My Flashlight public album (mods, emitter swaps, eye candy)

My reviews channel (French language, Olight, Thorfire : 30+ lights tested)

My personal channel (including Olight SR mini, S1, S2, S1A and S-mini disassembly)

M4DM4X's deals and coupons

Etex
Etex's picture
Offline
Last seen: 1 hour 35 min ago
Joined: 09/29/2016 - 00:57
Posts: 250
Location: East Texas

Received mine today, as well, that was quicker than expected, thanks.

lampyris
lampyris's picture
Offline
Last seen: 5 days 10 hours ago
Joined: 11/29/2015 - 12:36
Posts: 143
Location: South Downs, UK

Thank you Lexel, received the drivers Tuesday!

Excellent work Smile

Etex
Etex's picture
Offline
Last seen: 1 hour 35 min ago
Joined: 09/29/2016 - 00:57
Posts: 250
Location: East Texas

Got mine installed & working. Convoy L6, inspite of discovering my led is in backwards (reverse polarity).

Still trying to figure out how to get ramping to continue in the same direction. It seems to want to change directions.

Edit: nevermind about ramp direction, got it now.

Also, can I switch it from initially coming on at turbo with rear clicky, to the 2 blinks?

Thanks

Etex
Etex's picture
Offline
Last seen: 1 hour 35 min ago
Joined: 09/29/2016 - 00:57
Posts: 250
Location: East Texas

Is this normal?

!{width:50%}20170504_172255!

JasonWW
JasonWW's picture
Offline
Last seen: 7 hours 20 min ago
Joined: 10/22/2016 - 11:41
Posts: 2192
Location: Houston Texas

Maybe it’s on a moon setting?

How do you turn the light off with the side switch, press and hold?

My Convoy L6 thread with XHP70.2, Texas Avenger FET driver, Narsil v1.2 ramping firmware, lighted side switch and cut down SMO reflector. Lots of amp draws on stock driver as well.
http://budgetlightforum.com/node/54477

My Supfire L5-S thread with XHP70, Texas Avenger FET driver, NarsilM ramping firmware and lighted side switch. My mini L6! http://budgetlightforum.com/node/55746

6 NarsilM user videos https://www.youtube.com/user/JasonWW2000

Etex
Etex's picture
Offline
Last seen: 1 hour 35 min ago
Joined: 09/29/2016 - 00:57
Posts: 250
Location: East Texas

JasonWW wrote:
Maybe it’s on a moon setting?

How do you turn the light off with the side switch, press and hold?

The illumination is way lower than moon or firefly. If it’s normal, it’s not a bad way for me to tell if I have turned tailswitch off, since I don’t have illum switches.

Side switch functions:

Press and hold = ramping(up or dn)

Quick press = on / off (with memory)

Double click = turbo

Etex
Etex's picture
Offline
Last seen: 1 hour 35 min ago
Joined: 09/29/2016 - 00:57
Posts: 250
Location: East Texas

Here’s how mine works… your results might vary.

Convoy L6

TA Driver Infineon LDO Tactical 65° with Narsil V1.2 ?

From off…
-1/2 press of rear tail switch = momentary on (in Turbo) for signaling or instant glimpses.

From off…
-Full click on rear tail switch turns on to Turbo.

Side switch then controls:

>-Click = On / Off (with memory).

>-Double click = Turbo.

>-Click and hold = Ramping up or dn.

>-Long pause (1.5+ seconds) between Click & Holds continues ramping in the same direction.

>-Short pause between Click & Holds reverses ramping direction.

>-Short side switch click , turns off at any point in ramping and saves that level in memory, for when side switch turns it back on.

>-Tail click to off, or lockout, erases brightness level memory.

How do I program tail switch modes?…

A) Turbo (default)
B) 2 blinks
C) Nothing until side switch is pressed.

JasonWW
JasonWW's picture
Offline
Last seen: 7 hours 20 min ago
Joined: 10/22/2016 - 11:41
Posts: 2192
Location: Houston Texas

Etex wrote:

Convoy L6

TA Driver Infineon LDO Tactical 65° with Narsil V1.2 ?

How do I program tail switch modes?…

A) Turbo (default)
B) 2 blinks
C) Nothing until side switch is pressed.


v1.2 has low voltage protection, but no temp control. If you do have temp control, then you have v1.4 and no lvp.

I understood it that tail switch modes had to be programmed into the firmware. They are not user adjusted. Lexel told me it was a few lines of code that had to be altered to get the tactical setting.

My Convoy L6 thread with XHP70.2, Texas Avenger FET driver, Narsil v1.2 ramping firmware, lighted side switch and cut down SMO reflector. Lots of amp draws on stock driver as well.
http://budgetlightforum.com/node/54477

My Supfire L5-S thread with XHP70, Texas Avenger FET driver, NarsilM ramping firmware and lighted side switch. My mini L6! http://budgetlightforum.com/node/55746

6 NarsilM user videos https://www.youtube.com/user/JasonWW2000

Etex
Etex's picture
Offline
Last seen: 1 hour 35 min ago
Joined: 09/29/2016 - 00:57
Posts: 250
Location: East Texas

I specified temperature control, and they were marked as such, so I guess it is V1.4.

I misunderstood those tail switch options as being user defined. Turbo is the only way to have a momentary function, so its not bad in that respect. And a quick click of the side switch turns it off.

Looking across my acreage, I can quick scan a lot of ground in momentary mode in a second or two with it.

The ramping is awesome, and a lot more user friendly to fine tune the levels than I expected.

The faint LED could be an Infineon vs SIR800 difference, guess we’ll see.

Etex
Etex's picture
Offline
Last seen: 1 hour 35 min ago
Joined: 09/29/2016 - 00:57
Posts: 250
Location: East Texas

Lexel wrote:
I tested the drivers with a Nichia 219 triple so on LDO drivers I did not drive the driver and LEDs with 2S voltage

My guess on that glow is a faulty 7135 that causes a very low leak current

Thanks

Texas_Ace
Texas_Ace's picture
Offline
Last seen: 3 hours 29 min ago
Joined: 03/24/2016 - 07:44
Posts: 4219
Location: Everything is brighter in Texas

Etex wrote:
Lexel wrote:
I tested the drivers with a Nichia 219 triple so on LDO drivers I did not drive the driver and LEDs with 2S voltage

My guess on that glow is a faulty 7135 that causes a very low leak current

Thanks

I agree with this assessment. I have had this happen to me as well with 7135’s on 2S drivers.

The Second Amendment is in place in case the politicians ignore the others.

Government is the great fiction, through which everybody endeavors to live at the expense of everybody else. -- Frederic Bastiat , French economist(1801-1850)

Texas Avenger Driver Series

My LED Test series - XP-L2 V5  - Nichia 219C 90+ CRILatticebright "XM-L"XHP35 & PWM efficiency - XHP50 - XP-L V5 - XM-L2 U2 - XP-G3 S5  - XP-L HI V2 - Oslon Square & direct comparison to Djozz tests - Nichia 319A - Nichia 219B 9080 CRI - Nichia 219C D320 - Nichia 229AT

How I made a True integrating PVC sphere with no math involved

Lexel
Lexel's picture
Offline
Last seen: 4 hours 25 min ago
Joined: 11/01/2016 - 08:00
Posts: 2564
Location: Germany

http://budgetlightforum.com/node/54053#comment-1121216

new batch is almost ready to go I said I start ordering stuff when 30 drivers are requested and will order parts for 50

JasonWW
JasonWW's picture
Offline
Last seen: 7 hours 20 min ago
Joined: 10/22/2016 - 11:41
Posts: 2192
Location: Houston Texas

Etex wrote:
Lexel wrote:
I tested the drivers with a Nichia 219 triple so on LDO drivers I did not drive the driver and LEDs with 2S voltage

My guess on that glow is a faulty 7135 that causes a very low leak current

Thanks


There’s only one 7135 on there so it looks pretty easy to swap out. Maybe you have an old driver you don’t need that you can strip a 7135 off of. If not, MTN Electronics sells them super cheap.

My Convoy L6 thread with XHP70.2, Texas Avenger FET driver, Narsil v1.2 ramping firmware, lighted side switch and cut down SMO reflector. Lots of amp draws on stock driver as well.
http://budgetlightforum.com/node/54477

My Supfire L5-S thread with XHP70, Texas Avenger FET driver, NarsilM ramping firmware and lighted side switch. My mini L6! http://budgetlightforum.com/node/55746

6 NarsilM user videos https://www.youtube.com/user/JasonWW2000

Etex
Etex's picture
Offline
Last seen: 1 hour 35 min ago
Joined: 09/29/2016 - 00:57
Posts: 250
Location: East Texas

I actually have a stip of 7135’s, just have to get some more practice in before attempting. I think dealing with these itty bitty parts is how I messed up my original driver (resistor mod), total noob, and not steady 63 yr old hands. BTW, there’s 8 7135 on one side and the single on the other….???

JasonWW
JasonWW's picture
Offline
Last seen: 7 hours 20 min ago
Joined: 10/22/2016 - 11:41
Posts: 2192
Location: Houston Texas

Etex wrote:
I actually have a stip of 7135’s, just have to get some more practice in before attempting. I think dealing with these itty bitty parts is how I messed up my original driver (resistor mod), total noob, and not steady 63 yr old hands. BTW, there’s 8 7135 on one side and the single on the other….???

Oh yeah, post #102 shows the backside. So 9 in total. I wish I knew how to narrow it down to find the faulty one.

Removing all of them and cleaning the pads is not too hard, but soldering new ones would be a pain by hand. You’d need a hot air reflow station and solder paste to do it quick and easy.

Its some pretty bad luck. If you really want to fix it, maybe ask Richard at MTN if he could do it.

I hope it’s a rare occurrence.

My Convoy L6 thread with XHP70.2, Texas Avenger FET driver, Narsil v1.2 ramping firmware, lighted side switch and cut down SMO reflector. Lots of amp draws on stock driver as well.
http://budgetlightforum.com/node/54477

My Supfire L5-S thread with XHP70, Texas Avenger FET driver, NarsilM ramping firmware and lighted side switch. My mini L6! http://budgetlightforum.com/node/55746

6 NarsilM user videos https://www.youtube.com/user/JasonWW2000

tekwyzrd
tekwyzrd's picture
Offline
Last seen: 5 hours 24 min ago
Joined: 11/14/2015 - 01:15
Posts: 1011
Location: Northeastern Ohio

Package delivered today. I’ll force myself to wait for the solder station I ordered that’s scheduled for delivery wednesday before starting on the lvp mods for the 2s light but will install one as-is in the D01. I’ve been searching for another grey D01 but the major sources are out of stock so it will remain 1s3p until I find another, make a 2s battery tube, or cut and extend the 1s tube.

Pages