ENEDED

551 posts / 0 new
Last post
hIKARInoob
hIKARInoob's picture
Offline
Last seen: 2 days 22 hours ago
Joined: 08/28/2016 - 08:15
Posts: 3935
DENGOH wrote:
hIKARInoob wrote:
I wonder with all the single emitter flickering issues if it’s just a bad batch of drivers, or maybe Haikelite changed the design.
Too bad I was considering this light. Haikelite should respond to this issue with root cause analysis. I bet they know now.

Me too. The silver MT03 is gorgeous. Luckily the driver is easy to replace; that’s why I’m still interested in Haikelite. But now seems to be a bad time to get this light unfortunately.

WTF
Offline
Last seen: 8 hours 19 min ago
Joined: 03/05/2017 - 20:13
Posts: 230

My silver NW showed up today, charging up a fresh set of 30q’s to do a proper test. No flickering so far on two different sets of protected batteries as well as a half charged set of 30q’s. It did start to flicker on high on the one set of protected batteries after a mode change but after cycling through the modes to low it went away. There was a bit of audible driver whining too. I’m blaming that on the five amp protection circuit those batteries have. I tested it on my power supply just holding the test leads in place with my fingers, no issues running from 7.3 to 8.5 volts, it would flicker a bit if the ground wire wasn’t pressed hard enough. Amperage does increase with voltage, you can see the beam brighten a bit even on low. It draws around 8 amps/60 watts on turbo.

The level spacings are fine and the tint is nice, matches the NW MF01 when wall hunting. Smooth floody beam, wider hotspot than the MF01 and a good amount of spill. The only thing I have to gripe about is the tailcap did not thread on smoothly. No grease on the threads or behind the contact board. Also the solder joints on the guide pins were a little to big for the groove in the tailcap. Five minutes to disassemble, do a little filing, apply grease and reassemble. Works perfectly now.

Great light so far.

freeme
freeme's picture
Offline
Last seen: 1 hour 30 min ago
Joined: 11/14/2013 - 22:00
Posts: 7126

Will get them to respond on this issue soon.

DENGOH wrote:
hIKARInoob wrote:
I wonder with all the single emitter flickering issues if it's just a bad batch of drivers, or maybe Haikelite changed the design.
Too bad I was considering this light. Haikelite should respond to this issue with root cause analysis. I bet they know now.

©freemex1thedeals.com

DENGOH
DENGOH's picture
Offline
Last seen: 4 days 11 hours ago
Joined: 10/06/2012 - 05:26
Posts: 2148

Hope Haikelite takes this unfortunate issue as chance to show their strength in customer support. It could be battery quality/length or contact problem that might not be completely their fault. Those who buy this high wattage light should know it can have issue if certain things are not in good condition.

cool i'll see you when you get there

freeme
freeme's picture
Offline
Last seen: 1 hour 30 min ago
Joined: 11/14/2013 - 22:00
Posts: 7126

Who else has flickering issue apart from these owners?

  1. chakrawal
  2. BeardedRaleigh
  3. Tjhosan
  4. WTF

 

All existing stocks at BG are scheduled to return factory for inspection and repair (if required).

©freemex1thedeals.com

Tom E
Tom E's picture
Offline
Last seen: 23 hours 50 min ago
Joined: 08/19/2012 - 08:23
Posts: 12168
Location: LI NY

I could see/reproduce flickering in one LED. But again, I'm not interested in a replacement driver from Haikelite.

Tjhosan
Tjhosan's picture
Offline
Last seen: 19 hours 54 min ago
Joined: 03/29/2016 - 16:21
Posts: 110
Location: Sweden

I dont realy need a replacement either. Just wanted to report on the problem.

askj
Offline
Last seen: 7 months 4 days ago
Joined: 10/27/2017 - 21:42
Posts: 49

Can I have the code please? Thanks.

jb509
Offline
Last seen: 1 week 3 days ago
Joined: 11/11/2017 - 20:20
Posts: 7

Interested on NW silver MT03

Thinking of 1 after the factory inspection.

Thanks.

--JB

askj
Offline
Last seen: 7 months 4 days ago
Joined: 10/27/2017 - 21:42
Posts: 49

What are the benefits with this model with XHP70.2 over the XHP70 model? Is it basically the same with newer components? Thanks.

jb509
Offline
Last seen: 1 week 3 days ago
Joined: 11/11/2017 - 20:20
Posts: 7
askj wrote:
What are the benefits with this model with XHP70.2 over the XHP70 model? Is it basically the same with newer components? Thanks.

The difference http://budgetlightforum.com/node/53361

  1. Better optics
  2. Small output gain
  3. Runs cooler

--JB

jb509
Offline
Last seen: 1 week 3 days ago
Joined: 11/11/2017 - 20:20
Posts: 7

Code please for NW silver. It’s available now.

--JB

JLM86
Offline
Last seen: 1 year 6 months ago
Joined: 11/22/2017 - 02:29
Posts: 11
Location: Puerto Rico

Code Please! Thanks!

Itsme
Offline
Last seen: 9 hours 19 min ago
Joined: 07/18/2017 - 00:47
Posts: 510
Location: Canada

is there any word if there is a fix for this issue yet or when the lights will ship?

Thanks

Jbraman
Offline
Last seen: 1 month 2 weeks ago
Joined: 01/04/2017 - 08:45
Posts: 24

INTErested

freeme
freeme's picture
Offline
Last seen: 1 hour 30 min ago
Joined: 11/14/2013 - 22:00
Posts: 7126

Have to wait till Black Friday Sale is over. It is hard to get hold of people during major sale period.

Itsme wrote:
is there any word if there is a fix for this issue yet or when the lights will ship? Thanks


Replied.

Jbraman wrote:
INTErested

©freemex1thedeals.com

Itsme
Offline
Last seen: 9 hours 19 min ago
Joined: 07/18/2017 - 00:47
Posts: 510
Location: Canada

Thanks Freeme

Qwibbles
Offline
Last seen: 4 months 2 weeks ago
Joined: 11/05/2017 - 03:49
Posts: 11
Location: Wilts, England

Im interested – White NW please.

octav
Offline
Last seen: 1 month 4 days ago
Joined: 03/14/2016 - 03:43
Posts: 57

I’m interested in a black one with NW, depending on price. Thanks.

JLM86
Offline
Last seen: 1 year 6 months ago
Joined: 11/22/2017 - 02:29
Posts: 11
Location: Puerto Rico

Interested in one NW Thanks!

pirate joe 22
Offline
Last seen: 2 months 1 week ago
Joined: 08/26/2015 - 01:23
Posts: 138

im in NW

JLM86
Offline
Last seen: 1 year 6 months ago
Joined: 11/22/2017 - 02:29
Posts: 11
Location: Puerto Rico

Freeme can you send me the code please! and thanks!!

chakrawal
Offline
Last seen: 3 months 1 week ago
Joined: 10/16/2017 - 22:22
Posts: 51
Location: Bangkok

I just took batteries out of the MT03II 70.2 and found out the 2batteries were at 4.2V still full but other 2 were at 3.90V. Haikelite should look into the problem right away and I think most of the first badge are defected.

JasonWW
JasonWW's picture
Offline
Last seen: 5 hours 20 min ago
Joined: 10/22/2016 - 11:41
Posts: 10716
Location: Houston Texas

chakrawal wrote:
I just took batteries out of the MT03II 70.2 and found out the 2batteries were at 4.2V still full but other 2 were at 3.90V. Haikelite should look into the problem right away and I think most of the first badge are defected.

How is it even possible that 2 cells are not making contact?

The polarity protection rings? Are you using button top cells as recommended?

Is there a problem in the tail cap pcb? A burnt trace maybe?

chakrawal
Offline
Last seen: 3 months 1 week ago
Joined: 10/16/2017 - 22:22
Posts: 51
Location: Bangkok

JasonWW wrote:
chakrawal wrote:
I just took batteries out of the MT03II 70.2 and found out the 2batteries were at 4.2V still full but other 2 were at 3.90V. Haikelite should look into the problem right away and I think most of the first badge are defected.

How is it even possible that 2 cells are not making contact?

The polarity protection rings? Are you using button top cells as recommended?

Is there a problem in the tail cap pcb? A burnt trace maybe?

The 2 emitters were blinking like disco light since the first time I turned it on and I have already E-mail Haikelite about the problem. They promised me that they would give me a good solution but I have been waiting for about a month now and still no solution LOL. Now new problem.

JasonWW
JasonWW's picture
Offline
Last seen: 5 hours 20 min ago
Joined: 10/22/2016 - 11:41
Posts: 10716
Location: Houston Texas

What type of batteries are you using? Do they fit around the plastic polarity protection rings?

chakrawal
Offline
Last seen: 3 months 1 week ago
Joined: 10/16/2017 - 22:22
Posts: 51
Location: Bangkok

JasonWW wrote:
What type of batteries are you using? Do they fit around the plastic polarity protection rings?

I’m using Sony VTC6.
JasonWW
JasonWW's picture
Offline
Last seen: 5 hours 20 min ago
Joined: 10/22/2016 - 11:41
Posts: 10716
Location: Houston Texas

chakrawal wrote:
JasonWW wrote:
What type of batteries are you using? Do they fit around the plastic polarity protection rings?

I’m using Sony VTC6.

Button top?

If you using flat top it may not work and that is what is causing the non contact.

chakrawal
Offline
Last seen: 3 months 1 week ago
Joined: 10/16/2017 - 22:22
Posts: 51
Location: Bangkok

JasonWW wrote:
chakrawal wrote:
JasonWW wrote:
What type of batteries are you using? Do they fit around the plastic polarity protection rings?

I’m using Sony VTC6.

Button top?

If you using flat top it may not work and that is what is causing the non contact.


http://budgetlightforum.com/node/50666
They reccomended LG HG2 which are the same as Sony VTC6.
“You will need raised cells but not button tops. The button tops will not fit the light properly. It will still power on but it will not be waterproofed because the battery compartment will be open. I suggest LG HG2 or any style of battery that will work in series.”
JasonWW
JasonWW's picture
Offline
Last seen: 5 hours 20 min ago
Joined: 10/22/2016 - 11:41
Posts: 10716
Location: Houston Texas

Do button tops add so much length?

So raised flat tops?

Maybe regular flat tops, but with thin magnets added?

I guess you could solder blob them to get just a tiny bit more height so they make contact.

Pages