Haikelite headaches continue, half-dead XHP50..

4 posts / 0 new
Last post
DBSAR
DBSAR's picture
Offline
Last seen: 2 hours 59 min ago
Joined: 02/11/2013 - 23:28
Posts: 4468
Location: Ontario, Canada
Haikelite headaches continue, half-dead XHP50..

So i bought the MT01 back in August from a GB coupon post here & it arrived with flickering issues. I managed to fix that due to a bad cold-solder on the driver. it worked fine for another couple months, (very little use) and in December i noticed it was dimmer, and had a weird artifact in the hot-spot. I discovered half of the XHP50.2 LED is dead.. (two of the four dies of the XHP50.2 on one side of the emitter does not light up.) Facepalm

I checked the LED board, and everything is good there, but the emitter is just half dead. Should i try contacting Banggood or Hakilite on this?

  • Update: – Dale from Haikelite contacted me via DM, and is working to offer to fix this issue i have with my MT01. (will post updates here on it when i hear back & on what they do for me.

That Canadian flashlight guy & Lantern Guru -Den / DBSARlight

Edited by: DBSAR on 01/11/2018 - 02:45
jacktheclipper
jacktheclipper's picture
Offline
Last seen: 10 hours 36 min ago
Joined: 10/31/2010 - 21:18
Posts: 4812
Location: Florida , U.S.A.

Man , if I had your skills I woudn’t even buy any flashlights .

I do hope you get this resolved to your satisfaction .

DBSAR
DBSAR's picture
Offline
Last seen: 2 hours 59 min ago
Joined: 02/11/2013 - 23:28
Posts: 4468
Location: Ontario, Canada

jacktheclipper wrote:
Man , if I had your skills I woudn’t even buy any flashlights .

I do hope you get this resolved to your satisfaction .

I don’t expect much from Hakelite or Banggood, so either way i plan to swap in a nice tinted MT-G2 or even a XHP70.

That Canadian flashlight guy & Lantern Guru -Den / DBSARlight

DBSAR
DBSAR's picture
Offline
Last seen: 2 hours 59 min ago
Joined: 02/11/2013 - 23:28
Posts: 4468
Location: Ontario, Canada

Update: Dale from Haikelite contacted me via DM, and is working to offer to fix this issue i have with my new MT01. (will post updates here on it when i hear back.

That Canadian flashlight guy & Lantern Guru -Den / DBSARlight