Haiklite MT09R GB replacement drivers

107 posts / 0 new
Last post
BlueSwordM
BlueSwordM's picture
Offline
Last seen: 22 min 35 sec ago
Joined: 11/29/2017 - 12:34
Posts: 4738
Location: Canada

I do remember that row of resistors.

I have spoken with TA before and I had asked if the driver was FET+Nxlinear regulator for regulation.

He said no, and he said that he is instead using a resistor array for current regulation at low modes.

My very own high current Beryllium Copper springs Gen 3:
http://budgetlightforum.com/node/67401
Liitokala Aliexpress Stores Battery Fraud: http://budgetlightforum.com/node/60547

KawiBoy1428
KawiBoy1428's picture
Offline
Last seen: 2 hours 50 min ago
Joined: 04/11/2014 - 18:05
Posts: 3620
Location: The Motor City

Now that is whack…….If that spring bypass wire breaks off will it touch ground….could get interesting…

On the driver spring my by- pass wire is always inside the spring, kind of like being contained with in the spring…

KB1428 “Live Life WOT

Texas_Ace
Texas_Ace's picture
Online
Last seen: 3 min 4 sec ago
Joined: 03/24/2016 - 07:44
Posts: 8374
Location: Everything is brighter in Texas

JasonWW wrote:
Texas_Ace wrote:

JasonWW wrote:
hIKARInoob wrote:

Yeah but there’s nothing I can see on the driver that says the driver is for the 70 version.


At the expense of possibly looking like a fool, is it possible the drivers are interchangeable with the emitters determining the amp draw/load?

One is 12v, one is 6 volt and the MCU is 3v so I assume you have to use a different voltage divider between the 2 drivers.


The drivers are the same design, the only changes are some of the components to work correctly with the voltage change.

Hot damn, I’m not such a fool after all! Lol

What’s funny is I don’t think I’ve ever seen this MT09R driver until now. I don’t remember the row of resistors. TA, did you specifically not show any pictures of it in your driver replacement thread? Maybe I just forgot seeing a picture of it.

You are not a fool at all. You made a good educated guess.

You are also correct, I never posted any pictures of the drivers so it would not be stolen. It took me months and several prototypes and a ton of testing to get this design stable. In one case moving a component a few MM was enough to make it significantly more stable. Along with a few other equally minor but very important changes.

This driver really changed how I look at building drivers in general, even the smallest details start to matter when messing with these kinds of currents. I was very surprised at the effects some of the changes had but the results are worth it, I have not heard of any issues with the almost 100 final versions of this driver that are floating around.

Once I have time to put together a final version of the driver for release on oshpark I will upload it for personal use of course. Just got several other projects in the fire that are more important right now.

Texas_Ace
Texas_Ace's picture
Online
Last seen: 3 min 4 sec ago
Joined: 03/24/2016 - 07:44
Posts: 8374
Location: Everything is brighter in Texas

KawiBoy1428 wrote:

Now that is whack…….If that spring bypass wire breaks off will it touch ground….could get interesting…

On the driver spring my by- pass wire is always inside the spring, kind of like being contained with in the spring…

Yeah, I was worried about this. I even sent them some sample drivers should good bypasses but it seems that was ignored. This is the first I have seen of it. They have not sent me any samples even though I have asked.

Texas_Ace
Texas_Ace's picture
Online
Last seen: 3 min 4 sec ago
Joined: 03/24/2016 - 07:44
Posts: 8374
Location: Everything is brighter in Texas

BlueSwordM wrote:
I do remember that row of resistors.

I have spoken with TA before and I had asked if the driver was FET+Nxlinear regulator for regulation.

He said no, and he said that he is instead using a resistor array for current regulation at low modes.

Indeed, I never hid what I was doing, just exactly how I did it. The smallest details proved key to making it work stable under extreme conditions.

smokuxx1987
smokuxx1987's picture
Offline
Last seen: 6 days 23 min ago
Joined: 01/21/2017 - 18:23
Posts: 158
Location: Poland

KawiBoy1428 wrote:

Now that is whack…….If that spring bypass wire breaks off will it touch ground….could get interesting…

On the driver spring my by- pass wire is always inside the spring, kind of like being contained with in the spring…

This one is not bad, one is worst.

BlueSwordM
BlueSwordM's picture
Offline
Last seen: 22 min 35 sec ago
Joined: 11/29/2017 - 12:34
Posts: 4738
Location: Canada

I do wonder why they are still using steel springs instead of phosphor bronze or beryllium copper for the main spring, and make it even thicker since it screws down on a battery tube and not bare cells.

Would avoid such bad solder jobs.

My very own high current Beryllium Copper springs Gen 3:
http://budgetlightforum.com/node/67401
Liitokala Aliexpress Stores Battery Fraud: http://budgetlightforum.com/node/60547

leaftye
Offline
Last seen: 4 days 19 hours ago
Joined: 07/25/2012 - 17:43
Posts: 4257
Location: San Diego, CA

Unfortunately many of my spring bypasses look like that. It takes me a few tries before I get one without solder sucked all the way up the wire and making it look like those. That’s not an excuse though. They should have practiced. At least folks with patience or good soldering skills can fix that.

The low mode should be lower.

Reviews: Efan IMR18350 700mAh 10.5A, <a href="http://

Texas_Ace
Texas_Ace's picture
Online
Last seen: 3 min 4 sec ago
Joined: 03/24/2016 - 07:44
Posts: 8374
Location: Everything is brighter in Texas

Yeah, that type of bypass works, for awhile anyways. I find that wrapping the wire “around” the spring so that it does not flex as much when the spring is compressed lasts orders of magnitude longer. I have yet to have one break on me doing it that way but had most of my old ones like this break over time.

luckily they never hurt anything when they broke, they just stopped being bypasses and the output dropped.

sherman2k
Offline
Last seen: 8 months 3 days ago
Joined: 01/03/2018 - 00:46
Posts: 169
Location: California

I am still waiting for my replacement driver for almost a month now. To the member that received the replacement driver, how long did you wait for your replacement driver?

BlueSwordM
BlueSwordM's picture
Offline
Last seen: 22 min 35 sec ago
Joined: 11/29/2017 - 12:34
Posts: 4738
Location: Canada

Your driver should come very soon.

I was waiting for my Haikelite MT01 driver and reflector, and they came today!

I had emailed him, and he said the reason for the drivers taking time to be shipped, is that he was waiting to ship every spare part from almost every Haikelite light, the MT01, MT07S, MT03, etc, for lower cost shipping.

This is why it’s taking time.

My very own high current Beryllium Copper springs Gen 3:
http://budgetlightforum.com/node/67401
Liitokala Aliexpress Stores Battery Fraud: http://budgetlightforum.com/node/60547

sherman2k
Offline
Last seen: 8 months 3 days ago
Joined: 01/03/2018 - 00:46
Posts: 169
Location: California

Thank you

smokuxx1987
smokuxx1987's picture
Offline
Last seen: 6 days 23 min ago
Joined: 01/21/2017 - 18:23
Posts: 158
Location: Poland

sherman2k wrote:
I am still waiting for my replacement driver for almost a month now. To the member that received the replacement driver, how long did you wait for your replacement driver?

I was waiting since Group Buy was over.
I buy 3 pcs new MT09R and Dale send drivers with it by DHL.
Probably they will send drivers by normal shipping method registred/unregistred so to europe it takes 3-4 weeks
pooptoast
Offline
Last seen: 12 hours 27 min ago
Joined: 08/12/2015 - 23:11
Posts: 115

I’ve emailed multiple times about a replacement driver for mine but I’m not getting any response. I’ve given up on my light though at this point so if it comes, it comes, if not whatever, this thing will just sit in the bottom of a drawer somewhere.

BlueSwordM
BlueSwordM's picture
Offline
Last seen: 22 min 35 sec ago
Joined: 11/29/2017 - 12:34
Posts: 4738
Location: Canada

Don’t give up.

He is extremely busy.

He only responded to me when the drivers were in my city in tracking.

He has a lot of work on his hands, and probably 100+ emails to respond to.

My very own high current Beryllium Copper springs Gen 3:
http://budgetlightforum.com/node/67401
Liitokala Aliexpress Stores Battery Fraud: http://budgetlightforum.com/node/60547

sherman2k
Offline
Last seen: 8 months 3 days ago
Joined: 01/03/2018 - 00:46
Posts: 169
Location: California

On one post on this thread since 7/8/2018. I understand Dale is extremely busy but how about some customer service for the members that purchase the light in first GB with the trust of the company.

sherman2k
Offline
Last seen: 8 months 3 days ago
Joined: 01/03/2018 - 00:46
Posts: 169
Location: California

Bump

Nicolicous
Nicolicous's picture
Online
Last seen: 10 min 43 sec ago
Joined: 04/16/2016 - 08:28
Posts: 1411
Location: Australia

Its been two months when he emailed the driver got shipped but still no show up Sad

Nico -.-

sherman2k
Offline
Last seen: 8 months 3 days ago
Joined: 01/03/2018 - 00:46
Posts: 169
Location: California

I am going to continue bumping this thread until someone responds.

Wieselflinkpro
Wieselflinkpro's picture
Offline
Last seen: 3 days 18 hours ago
Joined: 05/21/2015 - 04:34
Posts: 853
Location: Germany - TLF

Nicolicous wrote:
Its been two months when he emailed the driver got shipped but still no show up Sad

Yes, for the GroupBuy, he told me a shipping number and said he has shipped it before CNY, but it was shipped very late after CNY. So dont trust his words at all. I think he will ship at least yours.
I have no answer depending the driver.
sherman2k
Offline
Last seen: 8 months 3 days ago
Joined: 01/03/2018 - 00:46
Posts: 169
Location: California

bump

Itsme
Offline
Last seen: 1 day 9 hours ago
Joined: 07/18/2017 - 00:47
Posts: 511
Location: Canada

I haven’t heard from Dale in a long time in regards to my replacements. Hope they show up at some point as he did originally tell me that they would be shipped

Nicolicous
Nicolicous's picture
Online
Last seen: 10 min 43 sec ago
Joined: 04/16/2016 - 08:28
Posts: 1411
Location: Australia

we want our drivers Beer

Nico -.-

sherman2k
Offline
Last seen: 8 months 3 days ago
Joined: 01/03/2018 - 00:46
Posts: 169
Location: California

bump

sherman2k
Offline
Last seen: 8 months 3 days ago
Joined: 01/03/2018 - 00:46
Posts: 169
Location: California

bump

mortuus
mortuus's picture
Offline
Last seen: 1 hour 19 min ago
Joined: 12/16/2014 - 09:33
Posts: 1889
Location: Sweden
sherman2k wrote:
bump

what will bump help `?

...where Frugal meets with Flashlight!

sherman2k
Offline
Last seen: 8 months 3 days ago
Joined: 01/03/2018 - 00:46
Posts: 169
Location: California

So this thread will not disappear. Hopefully, more people in the first GB will express their concern. I am sure I am not the only one.

vinte77
Offline
Last seen: 13 hours 17 min ago
Joined: 03/04/2014 - 18:43
Posts: 734
Location: California

Well it’s been about 2 months for me since I was told my driver was sent out. So as long as you were told that you would be receiving a driver, the only thing you can do is wait. But if you never go in touch with HL to request a new driver, you need to reach out to HL and request one… Then wait.

mortuus
mortuus's picture
Offline
Last seen: 1 hour 19 min ago
Joined: 12/16/2014 - 09:33
Posts: 1889
Location: Sweden

Ah ok, i guess the only way is to mail HL and bug them to send out the drivers, or that Dale guy but he seems to not write much here about it ?

Or they just dont care for those few that needs drivers – same i read with the BLF GT a few members are left with a broken light and the company refuses to fix the issues for a few members.. maybe its same here? who knows either way its wrong and not a way to treat customers for sure.. 2 months or more is a forever wait sorry but seems they just moved on the drivers should have long reached u all…

...where Frugal meets with Flashlight!

sherman2k
Offline
Last seen: 8 months 3 days ago
Joined: 01/03/2018 - 00:46
Posts: 169
Location: California

I did 2 months ago and during the 2 months, I only emailed them about 3 times. I was patiently waiting but when I email them again I don’t get any response anymore. I don’t think that is acceptable customer service. What is the acceptable wait time for you?

Pages