Fireflies E07 preview

2024 posts / 0 new
Last post
saypat
saypat's picture
Online
Last seen: 9 min 46 sec ago
Joined: 07/13/2011 - 20:32
Posts: 3552
Location: Calif

I have a couple of question on the UI if anyone can help please?

1. what is the ‘Goodnight’ mode???

2. while in beacon mode, can u increase or decrease the brightness?

3. while in candle mode, is the only option for 30 minutes?

thank you for any help here….

ToyKeeper
ToyKeeper's picture
Offline
Last seen: 1 hour 49 min ago
Joined: 01/12/2013 - 14:40
Posts: 10105
Location: (469219) 2016 HO3

Mike C wrote:
Interesting light. I’ve skimmed through the thread but can’t find any details on the driver board, only the aux LED board. What is the diameter of the driver board? Easy to get to and replace?

Also, from the photos of the front with aux board, it looks like the LEDs are on a normal PCB under the aux board. Is this a standard PCB or copper MCPCB? I haven’t seen any info about that either.

I haven’t attempted to open one, but it looks like the driver is glued in. It’s a FET+3 design, roughly 23mm across, and has spring-side pads for reflashing… but I think the aux LED board must be unsoldered before reflashing will work.

Pretty sure the MCPCB is a copper DTP type, because that’s what Fireflies’ other lights use, but I haven’t taken mine out to confirm.

saypat wrote:
I have a couple of question on the UI if anyone can help please?

1. what is the ‘Goodnight’ mode???

2. while in beacon mode, can u increase or decrease the brightness?

3. while in candle mode, is the only option for 30 minutes?

thank you for any help here….

  1. Goodnight/sunset mode starts at a low level, then gets dimmer for an hour, then shuts off.
  2. Beacon mode uses the last-ramped level for its brightness. So yes, but the adjustment is done outside of beacon mode.
  3. Candle mode’s timer can go for up to 4.5 hours. Each triple-click event adds 30 minutes to the timer.
maukka
maukka's picture
Offline
Last seen: 5 hours 52 min ago
Joined: 12/31/2015 - 04:15
Posts: 2020
Location: Finland

Also, candle mode doesn’t have a time limit by default.

saypat
saypat's picture
Online
Last seen: 9 min 46 sec ago
Joined: 07/13/2011 - 20:32
Posts: 3552
Location: Calif

saypat wrote:
I have a couple of question on the UI if anyone can help please?

1. what is the ‘Goodnight’ mode???

2. while in beacon mode, can u increase or decrease the brightness?

3. while in candle mode, is the only option for 30 minutes?

thank you for any help here….

  1. Goodnight/sunset mode starts at a low level, then gets dimmer for an hour, then shuts off.
  2. Beacon mode uses the last-ramped level for its brightness. So yes, but the adjustment is done outside of beacon mode.
  3. Candle mode’s timer can go for up to 4.5 hours. Each triple-click event adds 30 minutes to the timer.[/quote]

THANK YOU so much ToyKeeper! This is the first time I have seen or read about the Goodnight, Sunset mode? I was sort of wishing there were settings of less that 30 minutes for the candle.

thanks for all these wild options! The Party Strobe can get really crazy while adjusting Silly Lightning Storm is cool, Everett did that one a long time back.

thanks again!

patrick

cclight
Offline
Last seen: 1 hour 17 min ago
Joined: 12/17/2016 - 15:53
Posts: 93
Location: Brazil
maukka wrote:
Also, candle mode doesn’t have a time limit by default.

So how long does it last? If there’s no time limit it’d last forever but TK says the max is 4.5h… Is this the default?

maukka
maukka's picture
Offline
Last seen: 5 hours 52 min ago
Joined: 12/31/2015 - 04:15
Posts: 2020
Location: Finland

I’d assume it’ll run as long as the battery lasts.

default is no timer

cclight
Offline
Last seen: 1 hour 17 min ago
Joined: 12/17/2016 - 15:53
Posts: 93
Location: Brazil

This text says nothing about what is goodnight mode and much less how to configure it…

maukka
maukka's picture
Offline
Last seen: 5 hours 52 min ago
Joined: 12/31/2015 - 04:15
Posts: 2020
Location: Finland

There’s no configuration to the goodnight mode, but I agree, the documentation should at least tell the reader what it does.

Mike C
Mike C's picture
Offline
Last seen: 9 hours 38 min ago
Joined: 01/22/2014 - 08:03
Posts: 2378
Location: Sweden

ToyKeeper wrote:
I haven’t attempted to open one, but it looks like the driver is glued in. It’s a FET+3 design, roughly 23mm across, and has spring-side pads for reflashing… but I think the aux LED board must be unsoldered before reflashing will work.

Thanks. Glued in, ok, hopefully not to hard to remove. I will be replacing the driver all together. As it’s 23mm I’ll have to get new boards made. Can you see if it’s perfectly round or if there are alterations so it fits in place?

ToyKeeper wrote:
Pretty sure the MCPCB is a copper DTP type, because that’s what Fireflies’ other lights use, but I haven’t taken mine out to confirm.

Yeah, it would be weird if it wasn’t copper DTP. It was just that the little that can be seen in earlier photos looks a little funny, but come to think of it, copper DTP boards can have any color with anything on them Facepalm
ToyKeeper
ToyKeeper's picture
Offline
Last seen: 1 hour 49 min ago
Joined: 01/12/2013 - 14:40
Posts: 10105
Location: (469219) 2016 HO3
maukka wrote:
There’s no configuration to the goodnight mode, but I agree, the documentation should at least tell the reader what it does.

For that matter, there should probably be some documentation. I haven’t written any yet.

All it has now is a text file I was using as a todo list while writing the code. I sketched out the UI concept there, then checked off the items one by one as I implemented them. Sometimes this gets mistaken for a manual.

Firelight2
Firelight2's picture
Offline
Last seen: 57 min 45 sec ago
Joined: 04/08/2011 - 15:17
Posts: 3737
Location: California

Hm… Ordered an E07 with expedited shipping 5 days ago and it still hasn’t shipped from Fireflies.

Guess I shoulda saved the money and just gone with free shipping. I think I’d have gotten the light faster. Sick

wstrachan
Offline
Last seen: 1 day 4 hours ago
Joined: 02/19/2016 - 02:30
Posts: 638

Mine took a long time to arrive but worth the wait.
I opted for XP-L HI version, CW tint.
I have the same tint and LED in a Emissar D4 and D4S which I am really impressed with.
The E07 is brighter than both the Emissar lights. That was expected although not easy to accomplish. It stays brighter far longer and cooler than the D4 but again, that’s expected. I am running a Sofirn 21700 4000 mAh cell while I wait for higher amp capable cells to arrive.

I REALLY like this light. It’s a flooder but with effective throw. I like the UI. The AUX LEDs are cool. It’s extremely bright and well built!

My only complaint: 4 rapid clicks to lockout is silly. I twist the tail-cap anyway so all the AUX and switch LEDs go out.

light addict....yeah I've got the bug.

Atrolux MF02_O2S
Imalent DT70
Emissar (All Models)
Lumintop ODL20C
Wuben A21 & T70
thrunite tn32 ut
acebeam k60
many, many others...

Firemedic
Firemedic's picture
Offline
Last seen: 1 month 2 weeks ago
Joined: 01/04/2019 - 20:39
Posts: 102
Location: Alabama

Firelight2 wrote:
Hm… Ordered an E07 with expedited shipping 5 days ago and it still hasn’t shipped from Fireflies.

Guess I shoulda saved the money and just gone with free shipping. I think I’d have gotten the light faster. Sick

Ditto. Exact same situation from Nealsgadgets……….

Firelight2
Firelight2's picture
Offline
Last seen: 57 min 45 sec ago
Joined: 04/08/2011 - 15:17
Posts: 3737
Location: California

Firemedic wrote:
Firelight2 wrote:
Hm… Ordered an E07 with expedited shipping 5 days ago and it still hasn’t shipped from Fireflies.

Guess I shoulda saved the money and just gone with free shipping. I think I’d have gotten the light faster. Sick

Ditto. Exact same situation from Nealsgadgets……….

Especially considering that when I ordered my ROT66 last year with free shipping it arrived pretty fast.
klrman
klrman's picture
Offline
Last seen: 4 hours 3 min ago
Joined: 11/07/2016 - 22:44
Posts: 2350
Location: Canada

saypat wrote:
... received my E07 today. I got the SST20 10W NW 4000K CRI95 and am rather pleased with the tint! Someone mentioned it would be tad on the green side but I don't see that. What an amazing light to sit down and tinker with. I was overwhelmed at first but I received an instruction sheet as well as the flow diagram. I think I'm ok with most of it Wink Lights surely have progressed. I like lots of options, special UIs, flashes, the whole works. In this I have that. I got a black body and supposedly blue AUX LEDs but they look purple which I like better. This thing just smacks of quality, nice bezel, threads are great! WHY do I find myself wanting more of these E07s? Price is really fair IMHO. question: do I need to worry about leaving the AUX LEDs on in the blinky mode, I'm running a 30Q? GREAT JOB FIREFLIES!!!!! !{width:70%}[img]https://i.imgur.com/j7DQl2p.jpg[/img]!

 

I didn't order the black one but your one really looks nice with the purple leds.

saypat
saypat's picture
Online
Last seen: 9 min 46 sec ago
Joined: 07/13/2011 - 20:32
Posts: 3552
Location: Calif

Yea, really happy with this combination. They sure look purple to me, and you also. The order said they were blue. I think I would prefer purple. I didn’t have a choice but if I did I think mine would have been the clear body. Waiting to see pictures…..

Flash-O-Maniac
Offline
Last seen: 18 min 42 sec ago
Joined: 03/09/2016 - 17:41
Posts: 26

I received my E07 today, ordered with Nichia B emitters. I put a Samsung 40T 21700 battery in it (positive towards head) and the only sign of life I can see is 2 of the LEDs on the switch are on. Same goes for using a Sony VTC5A in the 18650 adapter. No function at all when pressing the switch. Or press and holding the switch. Thinking that maybe the light comes in lockout mode I tried 4 presses with no difference. Unless there is some secret series of presses needed to make the light work, it seems my light is DOA right out of the box. Not completely DOA because the 2 lights on the switch do come on, but I was hoping for more than that. There is a stamp on the side of the box where it says (checker) that says PASS and has the number 12 next to it. The shipping box looked in perfect condition, so did the inside product gift box. Not sure how a light could have been tested, passed inspection, then shipped and now DOA.

Can anyone think of something obvious that I am doing wrong to get this light working?

I am sending a copy of this post to Fireflies (whoever started this thread) via PM.

Any other suggestions would be greatly appreciated. Not sure right now if I feel this light is worth shipping all the way back to China to get fixed, if it is in fact defective.

ToyKeeper
ToyKeeper's picture
Offline
Last seen: 1 hour 49 min ago
Joined: 01/12/2013 - 14:40
Posts: 10105
Location: (469219) 2016 HO3

FWIW, even the lockout mode should light up when the button is pressed… though only at a dim level.

It might be interesting to see what the light does if you click 7 times, or 3 times. But it sounds like something in the driver may be preventing the MCU from receiving power at all, because when the battery connection is made it should flash the main emitters briefly in order to confirm that it booted and is now operational.

Flash-O-Maniac
Offline
Last seen: 18 min 42 sec ago
Joined: 03/09/2016 - 17:41
Posts: 26

Thank you for your response ToyKeeper. I tried 3 presses, then I tried 7 presses with no response. If I unscrew the tailcap (as in locking it out) the 2 LED lights in the switch go off, but when I screw the tailcap back on they go back on, but no main emitters flashing briefly.

I guess I will have to wait for response to my PM from FireFlies.

But thanks again for your input ToyKeeper.

DB Custom
DB Custom's picture
Offline
Last seen: 7 hours 44 min ago
Joined: 01/13/2013 - 22:28
Posts: 20383
Location: Heart of Texas

F-O-M, if you put the cell in and then use something to bridge between the negative end of the cell and the bare aluminum end of the battery tube, do the emitters blink the “go” flash? If not, then your battery tube may not be connecting to the driver for ground. Is the battery tube installed in proper orientation? There are other things to check, but most of that depends on the answers to the previous questions…

Are you in the US?

Flash-O-Maniac
Offline
Last seen: 18 min 42 sec ago
Joined: 03/09/2016 - 17:41
Posts: 26

DB – I bridged the aluminum end of the battery tube to the negative end of the battery and no result. While both ends of the battery tube have anodization removed, the tube will only thread in the way it came. The opposite end threads (made for the tailcap) will not thread into the head. I contacted Jack of FireFlies via email, and he responded pretty quickly saying that he will send me another light using expedited mail (15 – 20 days) and asked if I would send the defective light into a US mailing address. I agreed to do that and asked him for the address, but still haven’t received a response.

Yes, I am in the US.

Thanks for your response DB Custom. Appreciate the effort.

d_t_a
Offline
Last seen: 15 hours 31 min ago
Joined: 08/04/2017 - 23:58
Posts: 1481
Location: Manila, Philippines

Just wondering, are there pictures of the different aux-LEDs available for the Fireflies E07?

DB Custom
DB Custom's picture
Offline
Last seen: 7 hours 44 min ago
Joined: 01/13/2013 - 22:28
Posts: 20383
Location: Heart of Texas

Well, if the whole “US Shipping Address” thing doesn’t work out I’d buy the light from you if you’d like. I could probably get it working if you’d just like me to fix it, either way.

polarweis
polarweis's picture
Offline
Last seen: 3 hours 15 min ago
Joined: 05/31/2017 - 17:05
Posts: 385

the other day i replaced the driver of my dads utorch ut02. When i put the battery in, the side switch lit up but no light out the front. After a quick search it turned out the tube that was in the wrong orientation.

"It wouldn’t be so bright if there wasn’t a shadow every once in a while." - Jason Mraz

M4D M4X
M4D M4X's picture
Offline
Last seen: 1 hour 39 min ago
Joined: 03/19/2014 - 05:17
Posts: 7813
Location: Austria (GMT + 1)

the E07 has different threading on both sides of the tube Wink

 

 

already member of M4DM4X.com ?

the best deals are waiting for YOU!

BIG THANKS for helping me by using my REFLinks

before you buy elsewhere mail me: MARTIN@M4DM4X.COM - i will try to save you money!

DB Custom
DB Custom's picture
Offline
Last seen: 7 hours 44 min ago
Joined: 01/13/2013 - 22:28
Posts: 20383
Location: Heart of Texas

Yeah, so I’m wondering if a particular light might have a slightly short tube that doesn’t contact the driver when assembled? Or on the other end, the switch PCB? Perhaps a shorter cell would allow this light to function properly?

M4D M4X
M4D M4X's picture
Offline
Last seen: 1 hour 39 min ago
Joined: 03/19/2014 - 05:17
Posts: 7813
Location: Austria (GMT + 1)

easy to test with a 18650 and a wire without the tube and tailcap...

thats my first test (direct at the  driver) usually if something does not work

 

 

already member of M4DM4X.com ?

the best deals are waiting for YOU!

BIG THANKS for helping me by using my REFLinks

before you buy elsewhere mail me: MARTIN@M4DM4X.COM - i will try to save you money!

cclight
Offline
Last seen: 1 hour 17 min ago
Joined: 12/17/2016 - 15:53
Posts: 93
Location: Brazil

My rot66 had a similar problem; lit up in the beginning but weak, later died completely. Not even any of the switch or aux leds turn on anymore. Of course I did M4D M4X test of connecting the head directly, no change.

So the problem F-O-M has with the E07 also happens with other models.

agent80
Offline
Last seen: 7 hours 51 min ago
Joined: 01/06/2013 - 02:28
Posts: 387

Can we have a built in USB charger?

DB Custom
DB Custom's picture
Offline
Last seen: 7 hours 44 min ago
Joined: 01/13/2013 - 22:28
Posts: 20383
Location: Heart of Texas

Martin, that SHOULD be an easy test, but a slip and all kinds of things can go wrong. I was testing a 30T on my 17 emitter Ham’r and the wire slipped from my grip and shorted… ever so briefly with the tiniest of sparks… killed my monster. Well, it worked, but only the FET’s worked and it wouldn’t shut off at the switch. So I had to completely disassemble the entire light, all 5 drivers, and replace the RPP diode and all 5 7135 regulation chips. Works now, but what a pain it was all due to that one easy slip…

Pages