Is my Convoy S2+ Faulty?

44 posts / 0 new
Last post
AltaLumen
Offline
Last seen: 1 day 13 hours ago
Joined: 02/07/2019 - 23:14
Posts: 21
Location: Calgary, Alberta, Canada

RobertB wrote:
Somewhat suspicious of the EVVA cell. This guy’s D4s with a EVVA 26650 is doing the exact same thing, and purchased from the same place. Probably just a coincidence though

You won’t hit 3A charging a cell phone like you would on the flashlight

Hmmmm. Well, I ordered the cell based on mtn’s reputation, which I assume is good. You’re right though. I don’t have any other way to test the discharge ability of the cell. All I know is that it seems to charge normally and charged my cell phone fine from the Nitecore F2… that’s about a 1A draw. Maybe the flashlight driver is trying to start at 2800mA (100%) and the cell is too worn for that???

BlueSwordM
BlueSwordM's picture
Online
Last seen: 1 min 48 sec ago
Joined: 11/29/2017 - 12:34
Posts: 3082
Location: Canada

Nah, it’s probably not the battery.

Probably something else in the driver.

My very own high current Beryllium Copper springs: http://budgetlightforum.com/node/64047
Liitokala Aliexpress Stores Battery Fraud: http://budgetlightforum.com/node/60547

AltaLumen
Offline
Last seen: 1 day 13 hours ago
Joined: 02/07/2019 - 23:14
Posts: 21
Location: Calgary, Alberta, Canada

Jack Kellar][quote=AltaLumen wrote:

Just be careful not to run it pell mell at 100% power too long, the S2+ doesn’t have the cooling potential to safely maintain that much output. I like to keep my S2 at mode group 8 (max mode 50% of full power) and will do the same when my Nichia S2+ gets to me.

Did you order the Nichia with a 7135 ×8?

Jack Kellar
Jack Kellar's picture
Offline
Last seen: 1 hour 37 min ago
Joined: 03/09/2014 - 14:21
Posts: 1441
Location: Throwing bolts at anomalies

AltaLumen wrote:
Jack Kellar wrote:

Just be careful not to run it pell mell at 100% power too long, the S2+ doesn’t have the cooling potential to safely maintain that much output. I like to keep my S2 at mode group 8 (max mode 50% of full power) and will do the same when my Nichia S2+ gets to me.

Did you order the Nichia with a 7135 ×8?


Sure did. Mostly my lumen usage is modest (below 10%), but if I need the extra blast (well, as much ‘blast’ as you can get from a Nichia anyway), it’s a quick mode selection away.

AltaLumen
Offline
Last seen: 1 day 13 hours ago
Joined: 02/07/2019 - 23:14
Posts: 21
Location: Calgary, Alberta, Canada

RobertB wrote:
Somewhat suspicious of the EVVA cell. This guy’s D4s with a EVVA 26650 is doing the exact same thing, and purchased from the same place. Probably just a coincidence though

You won’t hit 3A charging a cell phone like you would on the flashlight

Out of curiousity, where do you get your batteries? I have two more of the exact same batteries on the way from Mtn Electronics. I’ll charge those up and see if I get the same result. Unfortunately, these are my first and only 18650s, so I don’t have anything else to try.

RobertB
RobertB's picture
Offline
Last seen: 4 hours 20 min ago
Joined: 12/18/2015 - 17:49
Posts: 2999
Location: USA, Michigan

AltaLumen wrote:
RobertB wrote:
Somewhat suspicious of the EVVA cell. This guy’s D4s with a EVVA 26650 is doing the exact same thing, and purchased from the same place. Probably just a coincidence though

You won’t hit 3A charging a cell phone like you would on the flashlight

Out of curiousity, where do you get your batteries? I have two more of the exact same batteries on the way from Mtn Electronics. I’ll charge those up and see if I get the same result. Unfortunately, these are my first and only 18650s, so I don’t have anything else to try.

I’m sure there are some local vape shops in Calgary. You could go over and try a fully charged unprotected 18650, like a high drain Samsung, LG or Sony, and rule out a battery problem.

AltaLumen
Offline
Last seen: 1 day 13 hours ago
Joined: 02/07/2019 - 23:14
Posts: 21
Location: Calgary, Alberta, Canada

RobertB wrote:
AltaLumen wrote:
RobertB wrote:
Somewhat suspicious of the EVVA cell. This guy’s D4s with a EVVA 26650 is doing the exact same thing, and purchased from the same place. Probably just a coincidence though

You won’t hit 3A charging a cell phone like you would on the flashlight

Out of curiousity, where do you get your batteries? I have two more of the exact same batteries on the way from Mtn Electronics. I’ll charge those up and see if I get the same result. Unfortunately, these are my first and only 18650s, so I don’t have anything else to try.

I’m sure there are some local vape shops in Calgary. You could go over and try a fully charged unprotected 18650, like a high drain Samsung, LG or Sony, and rule out a battery problem.

Good call. Thanks for the suggestion.

DOC1500
DOC1500's picture
Offline
Last seen: 2 hours 54 min ago
Joined: 01/19/2019 - 10:18
Posts: 26
Location: Clarks Summit, Pennsylvania

Chinese New Year may be over, they are starting to ship my convoys.

A lie is a lie even if everybody believes it.. The truth is the truth even if nobody believes it.
John 3:16 --
2 Cor 5:17

AltaLumen
Offline
Last seen: 1 day 13 hours ago
Joined: 02/07/2019 - 23:14
Posts: 21
Location: Calgary, Alberta, Canada
DOC1500 wrote:
Chinese New Year may be over, they are starting to ship my convoys.

Yup! I received a shipping notification for my order this morning! I paid an extra dollar or two for 16-26 day shipping lol. That’s in contrast to regular which is up to 2 months? I don’t know.

AltaLumen
Offline
Last seen: 1 day 13 hours ago
Joined: 02/07/2019 - 23:14
Posts: 21
Location: Calgary, Alberta, Canada

RobertB, as it turned out, there is a vape shop just a few blocks from my work… who knew… strange culture, vaping… Anyway, I picked up two Samsung INR18650-30Q cells, and tried them on my Convoy. Nope! Same issue. So, it’s fair to say at this point that it’s not the cell.

I found it slightly interesting that the cells came pretty much fully charged at 4.10V and 4.11V.

SIGShooter
Offline
Last seen: 42 min 13 sec ago
Joined: 07/14/2013 - 02:10
Posts: 1221
Location: northern california

AltaLumen wrote:
RobertB, as it turned out, there is a vape shop just a few blocks from my work… who knew… strange culture, vaping… Anyway, I picked up two Samsung INR18650-30Q cells, and tried them on my Convoy. Nope! Same issue. So, it’s fair to say at this point that it’s not the cell.

I found it slightly interesting that the cells came pretty much fully charged at 4.10V and 4.11V.


Maybe they were returns? I once bought some Panny 18650B’s from a highly recommended Ebay vendor and when I got them they were at 4.2v. I asked them why that was the case and he said they were returns and he also decided to test a charger on them Angry
RobertB
RobertB's picture
Offline
Last seen: 4 hours 20 min ago
Joined: 12/18/2015 - 17:49
Posts: 2999
Location: USA, Michigan

AltaLumen wrote:
RobertB, as it turned out, there is a vape shop just a few blocks from my work… who knew… strange culture, vaping… Anyway, I picked up two Samsung INR18650-30Q cells, and tried them on my Convoy. Nope! Same issue. So, it’s fair to say at this point that it’s not the cell.

I found it slightly interesting that the cells came pretty much fully charged at 4.10V and 4.11V.

They probably charged them to test and ready to sell. The 30Q’s are one of the best all around batteries you can buy.

AltaLumen
Offline
Last seen: 1 day 13 hours ago
Joined: 02/07/2019 - 23:14
Posts: 21
Location: Calgary, Alberta, Canada

I’ll assume the latter as there is no sign of wear/marks on the terminals.

Pages