Astrolux S43 not working

7 posts / 0 new
Last post
Cleng_Lade
Offline
Last seen: 2 weeks 2 days ago
Joined: 02/08/2019 - 02:25
Posts: 2
Astrolux S43 not working

I have an astrolux S43.. just recently.. it just won’t turn on.. the green button just wouldn’t light up.. and it wouldn’t turn on.. i’ve put differnt 18650s in it.. and the only thing it does is blink twice when the battery makes contact inside.. if anyone knows anything about this.. please reply.. it would be of great help.. thanks in advance…

koziy
Offline
Last seen: 1 day 10 hours ago
Joined: 01/12/2019 - 12:08
Posts: 111

It sounds broken to me.

Lexel
Lexel's picture
Online
Last seen: 4 min 16 sec ago
Joined: 11/01/2016 - 08:00
Posts: 4863
Location: Germany

if it blinks 2 times then everything is working except the switch
if the green LED does not blink 2 times its the ground that broke contact

DavidEF
DavidEF's picture
Offline
Last seen: 3 days 13 hours ago
Joined: 06/05/2014 - 06:00
Posts: 6953
Location: Salisbury, North Carolina, USA

Did you try a quick 4 taps on the button? Maybe it’s in lock-out mode? I dunno. When I break contact with the battery, then tighten it back up on my S43S, it doesn’t blink at all, and it stays in lock-out mode. So maybe that’s not it. But it still might be worth trying.

The Cycle of Goodness: “No one prospers without rendering benefit to others”
- The YKK Philosophy

Lexel
Lexel's picture
Online
Last seen: 4 min 16 sec ago
Joined: 11/01/2016 - 08:00
Posts: 4863
Location: Germany
DavidEF wrote:
Did you try a quick 4 taps on the button? Maybe it’s in lock-out mode? I dunno. When I break contact with the battery, then tighten it back up on my S43S, it doesn’t blink at all, and it stays in lock-out mode. So maybe that’s not it. But it still might be worth trying.

wrong the driver does not memory lockout if you disconnect the battery it is for sure a ground problem on switch or driver

DavidEF
DavidEF's picture
Offline
Last seen: 3 days 13 hours ago
Joined: 06/05/2014 - 06:00
Posts: 6953
Location: Salisbury, North Carolina, USA
Lexel wrote:
DavidEF wrote:
Did you try a quick 4 taps on the button? Maybe it’s in lock-out mode? I dunno. When I break contact with the battery, then tighten it back up on my S43S, it doesn’t blink at all, and it stays in lock-out mode. So maybe that’s not it. But it still might be worth trying.

wrong the driver does not memory lockout if you disconnect the battery it is for sure a ground problem on switch or driver


Huh? Oh. I uh… didn’t get it completely tightened back down when I did that test. Facepalm
Just now tightened it again and it did blink twice and “unlock” the light. So yeah. You’re right. Innocent

The Cycle of Goodness: “No one prospers without rendering benefit to others”
- The YKK Philosophy

Lexel
Lexel's picture
Online
Last seen: 4 min 16 sec ago
Joined: 11/01/2016 - 08:00
Posts: 4863
Location: Germany

Dont worry its just expirience with building and modding a lot lights, I have seen this error before