Convoy S9 issue

6 posts / 0 new
Last post
justanotherguy
Offline
Last seen: 5 hours 39 min ago
Joined: 11/26/2012 - 22:11
Posts: 742
Location: ILLinois
Convoy S9 issue

Click

So in the 4 pics, if you can see them… On the boards, the lights have a trace on the outer edge that the retaining ring apparently screws down to… On the head with two solder blobs visible on that trace, the ring is smooshing into blobs. The one gives me trouble a lot.
One other light in daily use has no blobs and is pretty much trouble free.

One other light with no blob, and the other with one, are both spares…

Question is, should I attempt to remove those blobs? Do you think the blobs interfere with the ground?

anyone in NE ILLinois into get togethers?

Edited by: justanotherguy on 10/30/2019 - 13:30
everydaysurvivalgear
everydaysurvivalgear's picture
Offline
Last seen: 9 hours 32 min ago
Joined: 07/31/2015 - 10:25
Posts: 3474
Location: sydney australia (GMT+10)

Maybe the retaining ring was not making making proper contact so they added some solder? You can try and remove it and see if it helps, You can always add some solder back if needed.

justanotherguy
Offline
Last seen: 5 hours 39 min ago
Joined: 11/26/2012 - 22:11
Posts: 742
Location: ILLinois

Yes it’s wierd that some come with it and some don’t….
I have to dig up the vacu-sucker

anyone in NE ILLinois into get togethers?

everydaysurvivalgear
everydaysurvivalgear's picture
Offline
Last seen: 9 hours 32 min ago
Joined: 07/31/2015 - 10:25
Posts: 3474
Location: sydney australia (GMT+10)

You can see that’s its not a flat retaining ring the inside ground portion of the retaining ring sits really high, That might be an issue if it doesn’t screw down all the way. Maybe you can flip the retaining around like upside down?

justanotherguy
Offline
Last seen: 5 hours 39 min ago
Joined: 11/26/2012 - 22:11
Posts: 742
Location: ILLinois

You have a good eye.. The retaining ring is ‘shouldered’ the minor diameter goes all the way down to that trace.

The shoulder on the retaing ring is .120 tall.
The difference from the ledge down to the trace is about .107”
Obviously the gap is due to the solder blobs

anyone in NE ILLinois into get togethers?

everydaysurvivalgear
everydaysurvivalgear's picture
Offline
Last seen: 9 hours 32 min ago
Joined: 07/31/2015 - 10:25
Posts: 3474
Location: sydney australia (GMT+10)

As long as the solder is there it should work okay.
Also the driver has the USB port attached i think (i don’t own one)? So maybe the solder is added so the USB port aligns properly?