Editor bug?

15 posts / 0 new
Last post
Don
Don's picture
Offline
Last seen: 6 months 3 weeks ago
Joined: 01/12/2010 - 16:32
Posts: 6617
Location: Scotland
Editor bug?
Whenever i paste stuff in (From a Mac and Safari browser), it gets inserted at the beginning of the text, not at the cursor. Is this just a Mac thing, or a Don thig, or does it happen on other platforms?

 

The numbers from my light tests are always to be found here.

https://spreadsheets.google.com/ccc?key=0ApkFM37n_QnRdDU5MDNzOURjYllmZHI...

sb56637
sb56637's picture
Offline
Last seen: 10 hours 14 min ago
Joined: 01/08/2010 - 09:29
Posts: 5941
Location: The Light

Hi there, thanks for reporting this.  I have personally never encountered this bug running Firefox on Linux.  I just tried to paste, and it inserted it at the cursor point.  Could you try one more time, and if it still happens I'll install another web browser to see how it reacts.

 

 :arrow:Update: I just updated some components of the forum software, could you confirm if you still have this bug?  Thanks!

 

Take care!

Budget Light Forum ...where Frugal meets with Flashlight!

charlestt
Offline
Last seen: 4 months 3 weeks ago
Joined: 01/16/2010 - 09:05
Posts: 664
Location: Bristol UK

Hi i get this same problem and i'm also on a mac running Safari

 

 

 

 http://i776.photobucket.com/albums/yy41/charlestt225/Sig/A1200023-1.jpg" width="159" he

sb56637
sb56637's picture
Offline
Last seen: 10 hours 14 min ago
Joined: 01/08/2010 - 09:29
Posts: 5941
Location: The Light

Ok, I'll try to see if I can get some help from the programmers of this forum software.  Meanwhile please hang in there, it'll probably be resolved quickly.  Thanks for the tip!

Budget Light Forum ...where Frugal meets with Flashlight!

sb56637
sb56637's picture
Offline
Last seen: 10 hours 14 min ago
Joined: 01/08/2010 - 09:29
Posts: 5941
Location: The Light

Would someone on Mac / Safari be so kind as to try this following to link to see if copy and paste works for you on a newer version of this editor?


http://nightly.ckeditor.com/4935/_samples/fullpage.html

 

Thanks very much!

Budget Light Forum ...where Frugal meets with Flashlight!

Don
Don's picture
Offline
Last seen: 6 months 3 weeks ago
Joined: 01/12/2010 - 16:32
Posts: 6617
Location: Scotland

Still does the same when using keyboard cut and paste which is a reflex with me - I almost never use the right click copy/paste stuff. Not really an issue for me as I have to use Firefox for Photobucket anyway so will just use Firefox if I think I want to paste anything.  

 

 

The numbers from my light tests are always to be found here.

https://spreadsheets.google.com/ccc?key=0ApkFM37n_QnRdDU5MDNzOURjYllmZHI...

sb56637
sb56637's picture
Offline
Last seen: 10 hours 14 min ago
Joined: 01/08/2010 - 09:29
Posts: 5941
Location: The Light

Don wrote:


Still does the same when using keyboard cut and paste which is a reflex with me - I almost never use the right click copy/paste stuff. Not really an issue for me as I have to use Firefox for Photobucket anyway so will just use Firefox if I think I want to paste anything.  

 




Hello again, thanks for checking.  You say copy/paste still doesn't work with Mac / Safari on this site, or on http://nightly.ckeditor.com/4935/_samples/fullpage.html?

Budget Light Forum ...where Frugal meets with Flashlight!

Don
Don's picture
Offline
Last seen: 6 months 3 weeks ago
Joined: 01/12/2010 - 16:32
Posts: 6617
Location: Scotland

sb56637 wrote:

Don wrote:


Still does the same when using keyboard cut and paste which is a reflex with me - I almost never use the right click copy/paste stuff. Not really an issue for me as I have to use Firefox for Photobucket anyway so will just use Firefox if I think I want to paste anything.  

 




Hello again, thanks for checking.  You say copy/paste still doesn't work with Mac / Safari on this site, or on http://nightly.ckeditor.com/4935/_samples/fullpage.html?

 

  Both, I'm afraid - just checked again. I'll just use Firefox instead

 

The numbers from my light tests are always to be found here.

https://spreadsheets.google.com/ccc?key=0ApkFM37n_QnRdDU5MDNzOURjYllmZHI...

sb56637
sb56637's picture
Offline
Last seen: 10 hours 14 min ago
Joined: 01/08/2010 - 09:29
Posts: 5941
Location: The Light

Hey there Mac / Safari guys, could I ask one more small favor please?  Could you give me your opinion on this editor, to see if it works ok on your setup, especially the copy/paste bug?  http://drupal.fckeditor.net/comment/reply/1#comment-form


Thanks for the help!

Budget Light Forum ...where Frugal meets with Flashlight!

charlestt
Offline
Last seen: 4 months 3 weeks ago
Joined: 01/16/2010 - 09:05
Posts: 664
Location: Bristol UK

When i past text into the box it disappears 

 

 

 

 http://i776.photobucket.com/albums/yy41/charlestt225/Sig/A1200023-1.jpg" width="159" he

Don
Don's picture
Offline
Last seen: 6 months 3 weeks ago
Joined: 01/12/2010 - 16:32
Posts: 6617
Location: Scotland

That one is even stranger. When you paste from the keyboard, the text disappears. I suspect this is by design. However, it functions correctly from the right-click menu popping up the box to paste stuff into. Actually, the right click menu here works too. It is only an issue when I paste from the keyboard. Since it seems to be a purely Mac/Safari issue I'd just put up a note saying use the right click menu which I suspect most people already do. Probably not worth the effort to fix as I suspect the developers don't want keyboard pasting. The pop-up box says it is because of my browser security settings that I have to paste into a box as the editor can't access the clipboard. 

 

The numbers from my light tests are always to be found here.

https://spreadsheets.google.com/ccc?key=0ApkFM37n_QnRdDU5MDNzOURjYllmZHI...

sb56637
sb56637's picture
Offline
Last seen: 10 hours 14 min ago
Joined: 01/08/2010 - 09:29
Posts: 5941
Location: The Light

Ah, when you use the keyboard paste shortcut it pops up a paste-box? I wonder if you could adjust your browser settings.  OK, I have a few bug reports filed with the editor programmers, hopefully they'll get it fixed sooner or later.  I am not a "standard" Windows/InternetExplorer user either, so I know it's frustrating when your preferred browser doesn't work right with a site.  I'll try to work it out.  Thanks for helping me debug it.

Budget Light Forum ...where Frugal meets with Flashlight!

Don
Don's picture
Offline
Last seen: 6 months 3 weeks ago
Joined: 01/12/2010 - 16:32
Posts: 6617
Location: Scotland

I would change them if I had the faintest idea of which one has this as a side effect. Safari is not the most configurable browser and I can't see anything in the config that would have this effect. This may be the case for all WebKit browsers, but Safari is the only one I've any experience of. There appear to be half a dozen WebKit based browsers for Linux.

 

The numbers from my light tests are always to be found here.

https://spreadsheets.google.com/ccc?key=0ApkFM37n_QnRdDU5MDNzOURjYllmZHI...

sb56637
sb56637's picture
Offline
Last seen: 10 hours 14 min ago
Joined: 01/08/2010 - 09:29
Posts: 5941
Location: The Light

Yes, I should probably start testing this site with Chrome or Midori too (both Webkit), I imagine most of our users, who are not typical flashlight buyers, probably aren't typical Windows / IE users either.  That popup thing on Safari might be the editor script recognizing your browser and automatically using that paste-bin.

Budget Light Forum ...where Frugal meets with Flashlight!

alfreddajero
alfreddajero's picture
Offline
Last seen: 7 hours 47 min ago
Joined: 01/14/2010 - 00:28
Posts: 1795
Location: Virginia Beach VA

I was using AOL......for this site but it gave me problems, kept logging me off when i went to the main forum and i had to keep logging in, dont worry its not the first and it surely wont be the last.  I use IE for some of the sites that have a hard time loading up and it makes hitting the back button on the mouse easier in IE since it will go back to the last page or site that i was on. 

With Darkness, there will always be Light.