Review: XinTD C8 (SC-82)

74 posts / 0 new
Last post
MarioSS
MarioSS's picture
Offline
Last seen: 3 years 11 months ago
Joined: 11/02/2012 - 12:17
Posts: 145
Location: Jordan
Lagerregal wrote:

how much force is needed to unscrew the reflector from the pill? it seems to be too tight to be unscrewed with bare hands on mine and i dont want to damage it.

sorry to bump this up. But i am having the same issue. The reflector isn’t moving at all i tried applying loads of force to unscrew it but nothin happened.

MaddoxX
Offline
Last seen: 11 months 1 day ago
Joined: 12/28/2011 - 20:56
Posts: 34
Location: Europe

Which one would be brighter the KD c8 or XinTD?

Lagerregal
Offline
Last seen: 6 years 5 months ago
Joined: 04/22/2012 - 07:13
Posts: 10
Location: Germany
MarioSS wrote:
Lagerregal wrote:

how much force is needed to unscrew the reflector from the pill? it seems to be too tight to be unscrewed with bare hands on mine and i dont want to damage it.

sorry to bump this up. But i am having the same issue. The reflector isn’t moving at all i tried applying loads of force to unscrew it but nothin happened.

i got it apart with wrapping a thin towel around and just trying harder Smile
it is my most used light for several month now…but one question is left: after gettimg a bump mine changes the mode to some sort of beacon/ blinking mode, although i have the three mode low med high version…one click and it starts again from low. any ideas why this happens?

koyotee
koyotee's picture
Offline
Last seen: 1 month 4 weeks ago
Joined: 11/22/2012 - 11:12
Posts: 1676
Location: Slovenia

i got mine today from intl-outdoor, ordered on 29.12. sent on 1.1.2013 (so i was told) and recieved it today 16.1.2013.
It has no flaws, and the threads are slightly lubed. I like the 3 mode, wish all lights were like this one Smile

Finaly, proud owner of a Powerex Maha mh c-9000 for my Eneloops:)

koyotee
koyotee's picture
Offline
Last seen: 1 month 4 weeks ago
Joined: 11/22/2012 - 11:12
Posts: 1676
Location: Slovenia

mine produces some high frequency sound on mid mode, but not on low or high. any1 has the same “problem”?

Finaly, proud owner of a Powerex Maha mh c-9000 for my Eneloops:)

M3TAL_L0RD
M3TAL_L0RD's picture
Offline
Last seen: 3 months 1 week ago
Joined: 09/09/2011 - 18:21
Posts: 924
Location: Suomi Finland Perkele

koyotee wrote:
mine produces some high frequency sound on mid mode, but not on low or high. any1 has the same "problem"?

Not a problem, it's feature Laughing. And there is sound on low too.

skyrider1
Offline
Last seen: 3 months 3 weeks ago
Joined: 11/18/2012 - 21:54
Posts: 762
Location: USA

It’s normal. I think it is the PWM

eebowler
eebowler's picture
Offline
Last seen: 1 week 22 hours ago
Joined: 08/13/2012 - 11:34
Posts: 1822
Location: Trinidad and Tobago GMT -4

I’ve found that sometimes when there is a bad connection, the driver humms. Try cleaning out all the threads etc and listen for humming again. If it’s still there, relube and forget it.

My gratitude to those who are willing and able to help others (in whatever way you can)! Being human is more than just existing for yourself. Smile

gords1001
gords1001's picture
Offline
Last seen: 1 year 4 months ago
Joined: 05/07/2012 - 14:02
Posts: 5276
Location: wigan england
Lagerregal wrote:
MarioSS wrote:
Lagerregal wrote:

how much force is needed to unscrew the reflector from the pill? it seems to be too tight to be unscrewed with bare hands on mine and i dont want to damage it.

sorry to bump this up. But i am having the same issue. The reflector isn’t moving at all i tried applying loads of force to unscrew it but nothin happened.

i got it apart with wrapping a thin towel around and just trying harder Smile
it is my most used light for several month now…but one question is left: after gettimg a bump mine changes the mode to some sort of beacon/ blinking mode, although i have the three mode low med high version…one click and it starts again from low. any ideas why this happens?

It sounds like the bump broke the solder joint on the driver star so the driver reverted to 5 mode, unscrew the pill and have a look, the stars are on the spring side of the driver. Just reflow the solder joint and you should be back to 3 mode.

lightme
lightme's picture
Offline
Last seen: 3 years 7 months ago
Joined: 11/12/2012 - 19:51
Posts: 615
Location: WV

koyotee wrote:
mine produces some high frequency sound on mid mode, but not on low or high. any1 has the same “problem”?
Never noticed til I listened closely. It’s there in high mode, too. I can barely hear it, but it’s there.

M3TAL_L0RD wrote:
Not a problem, it’s feature
For the blind Steve ?
Jinx
Jinx's picture
Offline
Last seen: 2 hours 24 min ago
Joined: 10/16/2011 - 11:35
Posts: 1081

Coming up for a year since I did this review so just thought I’d mention the light has been faultless. It has by no means been used daily but it has seen others fail and fall by the wayside (Roche F12 and UF zebralight clone I’m thinking of you). So this flashlight remains a recommended purchase. I hope someone updates now with the newer enmmiter and a touch more drive on high……

eebowler
eebowler's picture
Offline
Last seen: 1 week 22 hours ago
Joined: 08/13/2012 - 11:34
Posts: 1822
Location: Trinidad and Tobago GMT -4

Thank you for the update Jeansy! Also: WOAH!!! Your Roche F12 failed on you?? How? What happened? I love the construction of that light and can’t imagin it failing Sad PM me details if you don’t want to derail this thread. Thanks.

My gratitude to those who are willing and able to help others (in whatever way you can)! Being human is more than just existing for yourself. Smile

Jinx
Jinx's picture
Offline
Last seen: 2 hours 24 min ago
Joined: 10/16/2011 - 11:35
Posts: 1081
eebowler wrote:
Thank you for the update Jeansy! Also: WOAH!!! Your Roche F12 failed on you?? How? What happened? I love the construction of that light and can’t imagin it failing Sad PM me details if you don’t want to derail this thread. Thanks.

Hi eebowler, I loved the Roche too and it was EDC’d for a couple of months but began flickering which got worse, now it only gives a very low, flickering output. I’m sure it’s the switch that has failed, it is way underrated. Finding a replacement with a suitable rating is not really happening Sad

Still I have the XinTD to confidently fall back on Smile

Pages