Astrolux S43S Unusual Problem

7 posts / 0 new
Last post
zoulas's picture
Last seen: 4 hours 23 min ago
Joined: 06/01/2020 - 08:35
Posts: 2445
Astrolux S43S Unusual Problem

Greetings and this is my first post.

The unit worked perfect for a month. Now it has the following problem: When I screw in the tail cap, it blinks twice but does not turn on. I repeat the process several times, then it works and turns on. While its on, it locks up and wont turn off until the tailcap is released. The problem is intermittent. I cleaned the contacts, no improvement. I tighten the tailcap and the head as far as it goes, no improvement. I shake the light to see if the battery is moving around, there is no movement, its tight.

Here is s video I made for Banggood.

Edited by: zoulas on 06/01/2020 - 09:05
G0OSE's picture
Last seen: 16 hours 9 min ago
Joined: 09/03/2014 - 12:34
Posts: 2401

I bet it’s to do with the body not contacting the tail cap correctly.
Tighten it right up (maybe you tired this) the tube inside (if there is one?) needs to contact the head and tailcap to work.
Also clean all the threads.
Worth trying those if you haven’t.
I literally have one in the mail, so may be able to help more in a few days.

zoulas's picture
Last seen: 4 hours 23 min ago
Joined: 06/01/2020 - 08:35
Posts: 2445

Although your recommendation is spot on, there are many doubts this is the problem. I have managed to get the light to turn on by tightening the tail and head but why would it refuse to turn off afterwards ? If it made the connection to turn on, why seconds later does it not want to turn off? I love Astrolux and will continue to buy them but this simply looks faulty.

Colemanzeb's picture
Last seen: 2 years 3 months ago
Joined: 04/15/2020 - 03:59
Posts: 1
Location: Iowa

I have the exact same thing going on as you described my with my Astrolux S43S . Wish someone knew how to fix this. It's aggravating with such a new light.    I have cleaned the threads several times.  It's a neat light when it actually works.  


middle age man
Last seen: 3 months 1 week ago
Joined: 03/26/2019 - 18:38
Posts: 205

The switch on my S43 is erratic; sometimes it doesn’t turn off and I have to unscrew the tailcap. I recall Flashaholics mentioned switch problems on these models as well.

xevious's picture
Last seen: 3 days 8 hours ago
Joined: 02/27/2013 - 21:55
Posts: 3176
Location: Hoboken, NJ USA

Speaking of erratic, here’s something I’ve been experiencing with my S43S since new:

On occasion, when I go to turn off the light, I’ll single click but nothing happens. The green switch LED will flash a couple times and the light stays on. I click again, same deal. Then I click & hold to change brightness, followed by a single click, and THEN the light goes off. Other times it happens just once, then I click again without first changing intensity, and it’s off. One time I kept single clicking, waiting a second, then single clicking again and NOTHING—light stayed on. I turned the tailcap to break the connection (foolproof).

I don’t know why this happens. It’s very weird! I have to wonder if it’s something to do with carbon build-up in the switch? I haven’t yet figured out what’s the scenario that reproduces it. I just picked up my S43S and turned it on/off about a dozen times, no problem. Tried it from turbo, then from moonlight, then last known medium level brightness. No issue. I don’t know if there’s a precise output level where it pops up. If it happens again, I’ll switch to stepped ramping and see if that solves it.

Last seen: 1 week 1 day ago
Joined: 08/04/2017 - 23:58
Posts: 2712
Location: Manila, Philippines

I can’t see your video (it says video removed by uploader). But I think I might have encountered something similar quite some time ago with an S43, I think it may be some ground with certain contact parts (maybe the head or tail portion). Unfortunately can’t exactly remember how it was fixed…