Faulty Lumintop EDC18?

3 posts / 0 new
Last post
nzoomed
Offline
Last seen: 1 month 1 week ago
Joined: 08/01/2019 - 03:32
Posts: 120
Location: New Zealand
Faulty Lumintop EDC18?

Ive just got mine i ordered off their aliexpress store and it seems to have issues with brightness.
At first I thought it was throttling down due to a bad battery, but its a high drain 18650 rated at 10A.

When I first switched it on, I could get full brightness (still not sure if it was turbo mode) by holding the button down and it would ramp up from moonlight to max.
lasted a few seconds and then went back to a low setting.
Is probably only giving me about 100 lumens of light if im lucky, have tried different batteries with same issues.

Also noticed the light flickers a little bit.
Would be interested to know if others have had similar issues.

Hank33
Hank33's picture
Offline
Last seen: 1 year 1 week ago
Joined: 11/22/2019 - 16:00
Posts: 1405
Location: Vancouver, B.C.

Maybe the driver or switch even? Mine is kinda like the opposite. Sometimes when I go and press and hold to ram up, it will but starts to strobe quickly dimly. Have no idea why it does that? Other times it will ramp up fine. Hmmm I might change my driver and see what happens.

nzoomed
Offline
Last seen: 1 month 1 week ago
Joined: 08/01/2019 - 03:32
Posts: 120
Location: New Zealand
Hank33 wrote:
Maybe the driver or switch even? Mine is kinda like the opposite. Sometimes when I go and press and hold to ram up, it will but starts to strobe quickly dimly. Have no idea why it does that? Other times it will ramp up fine. Hmmm I might change my driver and see what happens.

I think ive fixed it now, the ends of the barrel were a bit dirty, possible from thread grease, ive cleaned them and put back firmly and seems OK.

Will test further tonight.
Can now get turbo mode to work.