FF 14500 bad switch?

3 posts / 0 new
Last post
buck91
buck91's picture
Offline
Last seen: 50 min 6 sec ago
Joined: 07/29/2016 - 08:21
Posts: 881
Location: Michigan
FF 14500 bad switch?

So a couple months ago I ordered the stainless steel version of the 14500 USB rechargeable light from ff-light and it finally arrived the other day. I tossed a cell in there today and low and behold the tail switch doesn’t work- the light is always on. I did reach out to FF but obviously haven’t heard back. Has anybody pulled one apart? Any common faults?

pinkpanda3310
pinkpanda3310's picture
Offline
Last seen: 1 day 4 hours ago
Joined: 12/28/2013 - 08:45
Posts: 3200
Location: Perth

I’ve had a couple of these lights and never had an issue. From memory the retaining ring in the tail is a little difficult to remove. Hope you get it sorted.

  

MascaratumB
MascaratumB's picture
Offline
Last seen: 46 min 41 sec ago
Joined: 10/29/2016 - 12:12
Posts: 7362
Location: Portugal

I took the switch of mine SS (not brass version) out to check it when it arrived.
It is probable that you can use some nose tip pliers to rotate the tail retaining ring (from the outside). And it may leave some marks in the brass Oops

The the metal cap will get out easily, and then you can see the whole switch structure, to perceive what is going on and fix it.

Try not to use long cells (protected or not). Mine was modded, but I use it with unprotected button top Vapcells.

If I remember correctly, this is the type of switch it uses:
https://www.aliexpress.com/item/32701410625.html