Efest LUC V4 4 bay LCD & USB charger

7 posts / 0 new
Last post
Yellowhorse
Yellowhorse's picture
Offline
Last seen: 6 years 4 months ago
Joined: 11/26/2011 - 19:16
Posts: 432
Location: Deepest Darkest West Virginia
Efest LUC V4 4 bay LCD & USB charger

I sure would like to see a review on this charger by HKJ.

http://www.efestpower.com/Product/7021353648.html

TexasToasted
TexasToasted's picture
Offline
Last seen: 7 hours 47 min ago
Joined: 10/25/2012 - 08:48
Posts: 1362
Location: Texas Gulf Coast

Yellowhorse wrote:
I sure would like to see a review on this charger by HKJ.

http://www.efestpower.com/Product/7021353648.html

There are 2 reviews of this charger by HKJ
Version 1
Version 2

Yellowhorse
Yellowhorse's picture
Offline
Last seen: 6 years 4 months ago
Joined: 11/26/2011 - 19:16
Posts: 432
Location: Deepest Darkest West Virginia

@ TexasToasted:

Those links don’t work. Got anything else? I looked for a review on this before I posted but found nothing. Maybe I missed it.

Yellowhorse
Yellowhorse's picture
Offline
Last seen: 6 years 4 months ago
Joined: 11/26/2011 - 19:16
Posts: 432
Location: Deepest Darkest West Virginia

Never mind. I found it. DUH. If at first you don’t succeed……………………………….

Yellowhorse
Yellowhorse's picture
Offline
Last seen: 6 years 4 months ago
Joined: 11/26/2011 - 19:16
Posts: 432
Location: Deepest Darkest West Virginia

Wow! What a short memory I have. I even commented on the review and completely forgot about it. Once again – DUH!

TexasToasted
TexasToasted's picture
Offline
Last seen: 7 hours 47 min ago
Joined: 10/25/2012 - 08:48
Posts: 1362
Location: Texas Gulf Coast

Yellowhorse wrote:
@ TexasToasted:

Those links don’t work. Got anything else? I looked for a review on this before I posted but found nothing. Maybe I missed it.

I see that the links are not working from this forum, but I can paste the link into a new browser tab and it works. Trying to figure out why.

leaftye
Offline
Last seen: 11 months 3 weeks ago
Joined: 07/25/2012 - 17:43
Posts: 4278
Location: San Diego, CA

Yellowhorse wrote:
Wow! What a short memory I have. I even commented on the review and completely forgot about it. Once again - DUH!

I did that yesterday.  I asked for pics of a driver even though I had previously quoted pics of that driver.

The low mode should be lower.