A17DD-L FET+1 Driver Issue

10 posts / 0 new
Last post
metz3006
Offline
Last seen: 5 years 2 months ago
Joined: 05/05/2015 - 09:09
Posts: 24
A17DD-L FET+1 Driver Issue

I just modded a Red Convoy S2+ with an A17DD-L FET+1 Driver, triple XP-L HI on Noctigon from Mountain Electronics, copper spacer, and bypassed the tail spring.

I can only progress through the lower 6 of 7 modes in the 7 mode configuration and 3 of 4 modes in the 4 mode configuration. Basically, it will not enter turbo. When I click into the turbo mode I get a brief flash and then nothing. If I click again it reverts back to the previous brightness.

I fear I may have damaged the driver during installation or perhaps bridged something by mistake. Any ideas?

Edited by: metz3006 on 02/01/2016 - 21:57
BobbyMK
BobbyMK's picture
Offline
Last seen: 4 days 13 hours ago
Joined: 09/10/2015 - 05:50
Posts: 379
Location: Macedonia

What kind of battery u are using, this happened to me when i tried to use protected battery in my triple that was not rated for high discharge current. All modes worked fine except turbo.

 Olight i3s, Olight S1, Olight S Mini, JetBeam Jet-1, BLF 348, Astrolux S41S, UF SK-98, Convoy S2+ 3*XP-G2, Convoy S2+ 3*XPL, Convoy S2+ 219CT, Convoy M1, Convoy C8, Brinyte B158, Courui D01, Convoy L6, Noctigon M43

djburkes
djburkes's picture
Offline
Last seen: 4 years 10 months ago
Joined: 03/16/2015 - 11:00
Posts: 1829
Location: Arkansas

Take the tailcap off and put a piece of metal or wire across the negative end of the battery and the body, see if it let’s you access all 7 modes, if so…you’ve got a short in the tailcap somewhere. Probably solder or wire touching the inside of the tailcap.

metz3006
Offline
Last seen: 5 years 2 months ago
Joined: 05/05/2015 - 09:09
Posts: 24

I was using a 30Q. I’ll try bypassing the switch tomorrow.

wight
Offline
Last seen: 2 years 8 months ago
Joined: 11/27/2013 - 16:40
Posts: 4969
Location: Virginia, USA
  • Doesn’t sound like a short to me. I can’t imagine a short not showing up in your second highest mode…
  • Does it memorize the turbo mode?
  • I assume that the light does not warm up while in turbo/black mode?
  • The protection circuit suggestion sure does sound like what you see, but if you’re using unprotected cells I suppose that’s not it.
  • Did you mix up C1 and OTC? That would be very important.
  • If you definitely got C1 and OTC correct, maybe doubling C1 helps?
  • I doubt that you’ve damaged the driver. Posting pics would be good.

Still fine, still on a break. One day I’ll catch up with you folks! previous wight catchup Wink
list of my drivers & variants (A17DD, FET+1 stuff, WIP stuff, etc)

chouster
Offline
Last seen: 1 year 8 months ago
Joined: 02/20/2014 - 15:05
Posts: 746
Location: germany

That might be some sort of voltage spike issue, I think that’s where wight is going with his suggestion of doubling C1.

Tom E solved similiar issues that way IIRC.

What type of FET are you using, metz3006?

djburkes
djburkes's picture
Offline
Last seen: 4 years 10 months ago
Joined: 03/16/2015 - 11:00
Posts: 1829
Location: Arkansas

I bypassed the tail spring on a X6 about a week ago, I was having a similar issue. I was able to access modes 1-6…when trying to reach 7, I’d get a brief flash then a lower than low moonlight. I found that I had too much solder on the switch leg and a little dremel action solved it for me.

metz3006
Offline
Last seen: 5 years 2 months ago
Joined: 05/05/2015 - 09:09
Posts: 24

Good morning all,

Thank you all for you help with this issue.

It appears that I should not try to troubleshoot late at night; when I went to bypass the switch this morning I realized that this light had a protected NCR18650B in it. Tired I worked on my B158 last night as well, and that is the light that had the 30Q in it.

I switched the 30Q in and it now works fine.

Bonus points to BobbyMK and wight for knowing what mistake I made despite my misinformation.

BobbyMK
BobbyMK's picture
Offline
Last seen: 4 days 13 hours ago
Joined: 09/10/2015 - 05:50
Posts: 379
Location: Macedonia

I was using the same battery Big Smile Glad that you resolved the “problem” Smile

 Olight i3s, Olight S1, Olight S Mini, JetBeam Jet-1, BLF 348, Astrolux S41S, UF SK-98, Convoy S2+ 3*XP-G2, Convoy S2+ 3*XPL, Convoy S2+ 219CT, Convoy M1, Convoy C8, Brinyte B158, Courui D01, Convoy L6, Noctigon M43

wight
Offline
Last seen: 2 years 8 months ago
Joined: 11/27/2013 - 16:40
Posts: 4969
Location: Virginia, USA

Happens to the best of us!

Still fine, still on a break. One day I’ll catch up with you folks! previous wight catchup Wink
list of my drivers & variants (A17DD, FET+1 stuff, WIP stuff, etc)