BLF Edition ThruNite Saber 1A Group Buy - $19.99

221 posts / 0 new
Last post
Trevi_lux
Trevi_lux's picture
Offline
Last seen: 1 year 11 months ago
Joined: 09/04/2012 - 10:52
Posts: 2296
Location: Spain

Received Tracking number :bigsmile:

Backpacker Light
Offline
Last seen: 3 months 3 weeks ago
Joined: 01/30/2013 - 20:15
Posts: 446
Location: Rochester, NY USA

Mine shipped.

Can’t wait to see how small it is, it might replace my AAA LD01 in my pocket.

The lighter the brighter the better.

tolight
Offline
Last seen: 7 years 3 weeks ago
Joined: 02/22/2013 - 10:55
Posts: 228

Backpacker Light wrote:
Mine shipped.

Can’t wait to see how small it is, it might replace my AAA LD01 in my pocket.

I have both. Its a little longer with the diameter of the AA… a great light! (though for my edc I am still usually using either my LD01 or my Tank007 E09 S3)…

Flomotion
Flomotion's picture
Offline
Last seen: 1 year 7 months ago
Joined: 12/02/2012 - 15:13
Posts: 1402
Location: Pacific Northwest

Item Sku Qty
Group Buy: ThruNite Saber 1A BLF Edition Saber 1A Group 1
Shipped By Tracking Number
Singapore Registered Airmail http://www.singpost.com/ RF133013XXXXX

Flomotion

dbare
Offline
Last seen: 9 months 3 weeks ago
Joined: 03/05/2012 - 16:20
Posts: 96
Location: Virginia, USA

Backpacker Light wrote:
Mine shipped.

Can’t wait to see how small it is, it might replace my AAA LD01 in my pocket.

You will hardly notice it in your pocket. I have both the T10 and Saber versions. Great threads for effortless one hand operation. Move the LD01 to the keychain.

dbare

Rozen
Offline
Last seen: 6 years 3 months ago
Joined: 05/04/2012 - 00:55
Posts: 107
Location: United States

Still waiting for mine to ship. Sad

Rufusbduck
Rufusbduck's picture
Offline
Last seen: 3 weeks 2 days ago
Joined: 04/04/2012 - 15:34
Posts: 10389
Location: Golden state

Mine has shipped and has apparently left singapore so that usually means a week to clear customs in SF and post to my house. I’m interested to see how it compares to one of my 10440 Solitaires.

Three Tanna leaves to give him life, nine to give him movement. But what if he eats the whole bag?

Scott

radiancez567
Offline
Last seen: 23 hours 59 min ago
Joined: 01/01/2013 - 03:50
Posts: 475
Location: Flash-a-holic world

I was supposed to see mine today, has apparently reached but I wasn’t in. The wait for tomorrow…

radiancez567
Offline
Last seen: 23 hours 59 min ago
Joined: 01/01/2013 - 03:50
Posts: 475
Location: Flash-a-holic world

Loving this nice little light Smile Limited edition Smile

agent80
Offline
Last seen: 2 days 3 hours ago
Joined: 01/06/2013 - 02:28
Posts: 460

When is the group buy for the Saber going to be available again? I want to buy some of these.

radiancez567
Offline
Last seen: 23 hours 59 min ago
Joined: 01/01/2013 - 03:50
Posts: 475
Location: Flash-a-holic world

Just tried the firefly mode in a dark room. It’s awesome.

TotalPower
Offline
Last seen: 5 months 1 week ago
Joined: 04/06/2013 - 12:27
Posts: 1

I received this flashlight today in the mail. It looks great however I can not get it to work with fresh AA’s. Any ideas before I completely call it a defective?

brted
brted's picture
Offline
Last seen: 1 month 12 hours ago
Joined: 01/12/2010 - 19:44
Posts: 2371
Location: Atlanta

I don’t have mine yet, but you can try this thread for some basic troubleshooting:

http://budgetlightforum.com/node/250

Hope you can get it to work. Usually there isn’t much that can go wrong with a twisty light.

dusty99
Offline
Last seen: 2 months 2 weeks ago
Joined: 03/05/2013 - 13:16
Posts: 98

My saber hasn’t arrived yet, but my T10 had contact issues. I finally did a thorough contact cleaning (had done a quick one before), cleaned all the factory lube off the threads and o-ring, then relubed everything with nyogel 760g dialectric lube. Seems fine since then.

TotalPower wrote:
I received this flashlight today in the mail. It looks great however I can not get it to work with fresh AA’s. Any ideas before I completely call it a defective?
Dimlux
Dimlux's picture
Offline
Last seen: 5 years 1 month ago
Joined: 10/27/2011 - 19:34
Posts: 214

TotalPower wrote:
I received this flashlight today in the mail. It looks great however I can not get it to work with fresh AA's. Any ideas before I completely call it a defective?

I received my Saber 1A today and have to say I'm very disappointed with it. Tried a fresh Eneloop and it turned on in moonlight mode... for about 10 seconds before it started flickering and turned off. The pill was a bit lose (you could hear it move if you moved the flashlight up and down) so I tightened it. Still nothing, if lucky I get some flickering for a couple of seconds when turning it on before it goes dark.

Another thing is the tint, much "worse" than my T10. It has a very cool tint, you could almost say blueish while my T10 is very neutral, almost on the warmer side.

I'm gonna see tomorrow if I can get it fixed, if not I'm gonna contact Thrunite and see what they suggest.

Trevi_lux
Trevi_lux's picture
Offline
Last seen: 1 year 11 months ago
Joined: 09/04/2012 - 10:52
Posts: 2296
Location: Spain

I have received my Saber 1A today. I have to try it a few days, but I’m happy, it shows more power than the T10, lightweight, easy to change modes with one hand, and is cooler tint than the T10.

Compared to my T10

ezarc
Offline
Last seen: 2 months 2 weeks ago
Joined: 10/17/2011 - 18:23
Posts: 2108
Location: South Aus

I don’t have my BLF one yet but my Saber is pure white where as my T10 has a blue/purple tint. It will be interesting to see what my BLF one is like compared to the regular Saber then.

lgr45
Offline
Last seen: 7 years 5 months ago
Joined: 11/08/2012 - 14:11
Posts: 47

mine are still sitting in singapore :~ …where they have been since march 26th. maybe one day they will come! getting a bit worried though with all of the people i see with complaints

Streamer
Streamer's picture
Offline
Last seen: 1 year 4 months ago
Joined: 12/01/2011 - 21:06
Posts: 3792
Location: TX

Just checked tracking for my BLF Saber for 100th time. It is scheduled for delivery today. There was NO previous updating to tracking until this morning.

Hope it’s a good one. Will update.

lgr45
Offline
Last seen: 7 years 5 months ago
Joined: 11/08/2012 - 14:11
Posts: 47

hah same. said it was in Singapore until today and now it says its here!

radiancez567
Offline
Last seen: 23 hours 59 min ago
Joined: 01/01/2013 - 03:50
Posts: 475
Location: Flash-a-holic world

To those who have received it, does your Saber 1A make a barely noticeable high-pitch noise (got to put it close your ears) when in firefly mode? The noise wasn’t in the medium or high mode.

Trevi_lux
Trevi_lux's picture
Offline
Last seen: 1 year 11 months ago
Joined: 09/04/2012 - 10:52
Posts: 2296
Location: Spain

Yes, there are moonlight noise but is not annoying (you have to put the flashlight near the ear and must have absolute silence).
In other modes no noise.

Chicken Drumstick
Offline
Last seen: 2 months 4 days ago
Joined: 08/27/2012 - 05:00
Posts: 2762
Location: UK

Do you think I should ignore the tracking?

I ask as it says:

30th March Despatched overseas (Country Code: US)

This sounds a little concerning as I’m in the UK….

6th April Attempted Delivery (Country Code: US)

Not had anything through the door, no card left and no package.

Of course this tracking number might not be for me, I have two emails from Thrunite, one with this tracking number on but doesn’t actually say it is a tracking number. And one that says tracking number, but instead of a number has my name inserted info the field….

JohnnyMac
JohnnyMac's picture
Offline
Last seen: 2 weeks 2 days ago
Joined: 04/12/2011 - 16:03
Posts: 8859
Location: Eastern PA

My tracking info still says dispatched to overseas on 3/30.  Nothing on the USPS site yet.  Looks like you guys in Europe are getting yours quicker than here in the states.  Maybe by the end of this week or early next mine will appear.

I admit I am worried with all the issues reported from those who have received already.  Can't recall why but I was under the impression that the Saber was supposed to be less CW than the T10.  Sounds like it's not.

Squidboy
Squidboy's picture
Offline
Last seen: 6 months 3 weeks ago
Joined: 01/26/2011 - 08:20
Posts: 155
Location: Scotland

Very nice, like the modes. I had only one problem – I have some vapex instants (no laughing at the back) and they don’t fit the tube, eneloops and duraloops do.
Duracell and Energiser AA fit too.

On the Flats mine has Thrunite T10 on one side and Saber 1A on the other

So overall I’m happy, as has been said before nice smooth threads and very nice modes

EDIT : Looks like the spare o rings are for the Ti AAA though

Candlepower (abbreviated as cp) is a now-obsolete unit which was used to express levels of light intensity.

Candlepowerforums (abbreviated as cpf) a website, also obsolete.

radiancez567
Offline
Last seen: 23 hours 59 min ago
Joined: 01/01/2013 - 03:50
Posts: 475
Location: Flash-a-holic world
Trevi_lux wrote:
Yes, there are moonlight noise but is not annoying (you have to put the flashlight near the ear and must have absolute silence). In other modes no noise.

Thanks. Was worried mine wasn’t normal. Maybe the noise is used to chase small little bugs away from the firefly light?

dusty99
Offline
Last seen: 2 months 2 weeks ago
Joined: 03/05/2013 - 13:16
Posts: 98

Mine arrived today, and since I came home for lunch I took a few minutes to check it out.

First, there were major contact problems, even after an alcohol cleaning: light wouldn’t fire, or would flicker, or go on and off by itself after tightening. There was more manufacturing grease and sloppy, thin thread grease than on my original T10, and the threads were rougher. Another cleaning and 760G application and no better, I wondered about the contact spring and reached in with a pair of needle-nose pliers and rotated it half a turn. That seems to have done the trick, as it’s running correctly now.

The beam is like my original XPG T10, but a little bluer (and just barely brighter). Although it’s rated at 169L it’s noticeably less bright than my ET D25A, rated at 121L (ANSI), and still less bright after the D25A drops down to around 100 ANSI lumens after 3 minutes (of course, maybe EagleTac underestimates their output, as has been suggested elsewhere). And the CW tint of my D25A is much nicer. Moon mode is nice. I’ll run a few duraloops through it and see how it looks after a little burn-in.

All in all, not a bad little light, but considering what else is out there it’s far from mind-blowing. The coolest thing about it is that it has “BLF” on the head.

EDIT: My D25A is an XPG2 R5

JohnnyMac
JohnnyMac's picture
Offline
Last seen: 2 weeks 2 days ago
Joined: 04/12/2011 - 16:03
Posts: 8859
Location: Eastern PA

dusty99 wrote:
Mine arrived today, and since I came home for lunch I took a few minutes to check it out. First, there were major contact problems, even after an alcohol cleaning: light wouldn't fire, or would flicker, or go on and off by itself after tightening. There was more manufacturing grease and sloppy, thin thread grease than on my original T10, and the threads were rougher. Another cleaning and 760G application and no better, then I wondered about the contact spring and reached in with a pair of needle-nose pliers and rotated it half a turn. That seems to have done the trick, as it's running correctly now. The beam is like my original XPG T10, but a little bluer (and just barely brighter). Although it's rated at 169L it's noticeably less bright than my ET D25A, rated at 121L (ANSI), and still less bright after the D25A drops down to around 100 ANSI lumens after 3 minutes (of course, maybe EagleTac underestimates their output, as has been suggested elsewhere). And the CW tint of my D25A is much nicer. Moon mode is nice. I'll run a few duraloops through it and see how it looks after a little burn-in. All in all, not a bad little light, but considering what else is out there it's far from mind-blowing. The coolest thing about it is that it has "BLF" on the head.
Not good! Not good at all. Sad  WTH has happened to Thrunite??  These quality control issues are popping up way too much on this light.  Starting to look like they crapped out a bunch of seconds and pawned them off on us by engraving "BLF" on them.  Poor LEDs, weak drivers, poor assembly, inferior machining, using battery tubes from a different model...simply inexcusable! Starting to not look forward to getting mine.  Flat Stare
dusty99
Offline
Last seen: 2 months 2 weeks ago
Joined: 03/05/2013 - 13:16
Posts: 98

I don’t want to be a downer. At this point I’m used to a clean-up and relube with Nyogel 760g on any new light, even those costing north of $100 (it blows away every factory lube I’ve experienced, and it’s conductive). The light is now burning fine (I grabbed it and a case of NiMHs to keep it running the rest of the day). I wish the tint was different and the output a bigger step up from the old T10 I have, but I knew the XPG2 would only give about 15% more than the XPG. I do wish the threads weren’t rough though, as I like the smooth one-handed operation of my old T10. I’ll see how I feel after a week of use.

Should probably be a $12 light, not $20.

JohnnyMac wrote:

Not good! Not good at all. Sad  WTH has happened to Thrunite??  These quality control issues are popping up way too much on this light.  Starting to look like they crapped out a bunch of seconds and pawned them off on us by engraving “BLF” on them.  Poor LEDs, weak drivers, poor assembly, inferior machining, using battery tubes from a different model…simply inexcusable! Starting to not look forward to getting mine.  Flat Stare

Streamer
Streamer's picture
Offline
Last seen: 1 year 4 months ago
Joined: 12/01/2011 - 21:06
Posts: 3792
Location: TX

I hear ya JM. I hope Thrunite is listening. Could be end of road for me and Thrunite. :~

Mine will be here in couple hours.

I was under the impression that the xpg2 was a clean neutral white and noticeably brighter than xpg.

Pages