FLEX Asgard @ Fasttech

343 posts / 0 new
Last post
ChibiM
ChibiM's picture
Offline
Last seen: 14 hours 24 min ago
Joined: 05/09/2011 - 10:25
Posts: 7065
Location: Holland

Anyone received his?

kreisler
kreisler's picture
Offline
Last seen: 8 years 11 months ago
Joined: 11/12/2011 - 23:32
Posts: 3992
Location: Deutcheland

So how bright is it really, i mean measured, on the FENIX lumens scale?

anyone with a integrating sphere and comparable FENIX lights?

*FMI* i got 4 i/o sh
picrthis
picrthis's picture
Offline
Last seen: 1 year 9 months ago
Joined: 07/18/2011 - 06:46
Posts: 602
Location: USA

@ Fasttech

I copied the info off the webpage into a nice word document now for reference, I didn’t even have a clue how to enter the proper mode or pairing, sure it’s on BLF somewhere but I really didn’t feel like reading back over a months worth of post to find it; I’ll d/l the windows app now and give it a whirl.

Fenix TK12, TK15, TK21-U2, TK61, TK75 Olight M20S, M21<span style="color: #0000ff;"

JohnnyMac
JohnnyMac's picture
Offline
Last seen: 2 months 2 weeks ago
Joined: 04/12/2011 - 16:03
Posts: 8879
Location: Eastern PA

picrthis wrote:
@ Fasttech I copied the info off the webpage into a nice word document now for reference, I didn't even have a clue how to enter the proper mode or pairing, sure it's on BLF somewhere but I really didn't feel like reading back over a months worth of post to find it; I'll d/l the windows app now and give it a whirl.
From any mode switch into the next mode and exactly 8 seconds into it give a half press on the switch to enter bt mode. If you did it right you will see the light enter a new mode where it blinks 3 times in a row in moon low, pauses about 5 seconds then flashes 3 times followed by the pause, etc.  It should stay in this mode until you click out of it with the switch. 
mhanlen
mhanlen's picture
Offline
Last seen: 11 months 3 weeks ago
Joined: 03/01/2013 - 11:42
Posts: 2601
Location: Eastern USA

Yeah, any more reviews of this light? Like full ones? I bought one of the NW, and it’s on the way. People really seem to like the small sun, so hopefully this one is good.

picrthis
picrthis's picture
Offline
Last seen: 1 year 9 months ago
Joined: 07/18/2011 - 06:46
Posts: 602
Location: USA
JohnnyMac wrote:

picrthis wrote:
@ Fasttech I copied the info off the webpage into a nice word document now for reference, I didn’t even have a clue how to enter the proper mode or pairing, sure it’s on BLF somewhere but I really didn’t feel like reading back over a months worth of post to find it; I’ll d/l the windows app now and give it a whirl.
From any mode switch into the next mode and exactly 8 seconds into it give a half press on the switch to enter bt mode. If you did it right you will see the light enter a new mode where it blinks 3 times in a row in moon low, pauses about 5 seconds then flashes 3 times followed by the pause, etc.  It should stay in this mode until you click out of it with the switch. 

Thanks! up & running on my Dell XPS :bigsmile:

Fenix TK12, TK15, TK21-U2, TK61, TK75 Olight M20S, M21<span style="color: #0000ff;"

picrthis
picrthis's picture
Offline
Last seen: 1 year 9 months ago
Joined: 07/18/2011 - 06:46
Posts: 602
Location: USA

Question: Is the Bluetooth Class 1 or Class 2 ?

Fenix TK12, TK15, TK21-U2, TK61, TK75 Olight M20S, M21<span style="color: #0000ff;"

_the_
_the_'s picture
Offline
Last seen: 5 months 2 days ago
Joined: 07/08/2011 - 06:22
Posts: 3647
Location: Finland

Just a quick status update for people waiting for my review.

My sample had severe Bluetooth connectivity issues, which should be fixed in the new driver. I'm waiting for the driver to arrive (currently laying in Finnish Customs).

Meanwhile I have been beta-testing the Windows App and I have to say that Fasttech developers (& Jasmine) have done very good job ironing out (nearly) all the bugs reported by me in a short time. Big thumbs up for them!

Here's a screenshot of my issue list, sorted by priority & status: (removed to stop annoying picrthis)

As you can see, the app is nearly ready for public release. Just one high priority issue left. Smile

 

=the=

 

picrthis
picrthis's picture
Offline
Last seen: 1 year 9 months ago
Joined: 07/18/2011 - 06:46
Posts: 602
Location: USA

I like to be able to read that “pic” but it is what 1pt sub-script? I can’t read one word of it Sad do you have a copy in larger print?

Fenix TK12, TK15, TK21-U2, TK61, TK75 Olight M20S, M21<span style="color: #0000ff;"

_the_
_the_'s picture
Offline
Last seen: 5 months 2 days ago
Joined: 07/08/2011 - 06:22
Posts: 3647
Location: Finland

picrthis wrote:
I like to be able to read that "pic" but it is what 1pt sub-script? I can't read one word of it Sad do you have a copy in larger print?

Sorry, but I don't want to share all those issues publicly. If there is a specific issue you would like to discuss about, please PM me.

The pic is there just to highlight the good progress fixing the reported issues. Usually I have sent issue report one evening and got a new release for testing next day! Different time zones are a bless in this case.. Smile

=the=

 

picrthis
picrthis's picture
Offline
Last seen: 1 year 9 months ago
Joined: 07/18/2011 - 06:46
Posts: 602
Location: USA

Sorry but I think it is pointless to post something nobody can read, I see 4 red items in your “list” but again doesn’t matter we can’t read it; never seen anyone make a post like that before :~

Fenix TK12, TK15, TK21-U2, TK61, TK75 Olight M20S, M21<span style="color: #0000ff;"

_the_
_the_'s picture
Offline
Last seen: 5 months 2 days ago
Joined: 07/08/2011 - 06:22
Posts: 3647
Location: Finland

picrthis wrote:
Sorry but I think it is pointless to post something nobody can read, I see 4 red items in your "list" but again doesn't matter we can't read it; never seen anyone make a post like that before :~

Sorry. Pics removed.

I have seen this type of status reports many times. The idea was to show only the overview, without going into details.

=the=

 

comfychair
comfychair's picture
Offline
Last seen: 6 years 7 months ago
Joined: 01/12/2013 - 05:39
Posts: 6198

It's a $60 flashlight. I have worked in many many car dealerships where it was routine policy to treat customers who'd bought $40k cars worse than how Fasttech handles issues like this.

picrthis
picrthis's picture
Offline
Last seen: 1 year 9 months ago
Joined: 07/18/2011 - 06:46
Posts: 602
Location: USA

I can’t see the sense without details, does that mean only the high priority item will be fixed before a full public release? that would then mean lots of redundant bug reports to flexcandles for probably items you already discovered but didn’t share, thus people will report same issues and probably get answer like “known issue” that ought to be fun, sorry I believe in transparency or……..well you know; wasn’t that the purpose of choosing some testers on here so we all can see the results?

Fenix TK12, TK15, TK21-U2, TK61, TK75 Olight M20S, M21<span style="color: #0000ff;"

JohnnyMac
JohnnyMac's picture
Offline
Last seen: 2 months 2 weeks ago
Joined: 04/12/2011 - 16:03
Posts: 8879
Location: Eastern PA

I am waiting for yet another full driver and pill from fasttech. I installed the new driver in my test light and while I can pair easily with the light on 3 different Android devices I am completely unable to connect to or program the light. It's good to see that someone here has a working light from the official release.  I am eagerly waiting for _the_'s experience with the new driver.  Foy has been reluctant to swap his beta driver for the real driver because his beta works with a few exceptions. Hopefully he will swap the driver so we can find out what his experience with the production driver is. I hope my bad experience is limited to only mine and that a whole new replacement pill resolves it all. 

The windows app won't even run for me on my W7 64bit laptop. Not sure why it seems to work for others. 

Johnny *frustrated* Mac

picrthis
picrthis's picture
Offline
Last seen: 1 year 9 months ago
Joined: 07/18/2011 - 06:46
Posts: 602
Location: USA
comfychair wrote:

It’s a $60 flashlight. I have worked in many many car dealerships where it was routine policy to treat customers who’d bought $40k cars worse than how Fasttech handles issues like this.

Who’s complaining about how FastTech is handling things?? I think they are doing a GREAT job. I really don’t care about how a dealership treated a customer who bought a $40k car, it’s irrelevant here and most of us know once a Dealership gets your money, the “relationship” is over.

Back on Topic.

Fenix TK12, TK15, TK21-U2, TK61, TK75 Olight M20S, M21<span style="color: #0000ff;"

picrthis
picrthis's picture
Offline
Last seen: 1 year 9 months ago
Joined: 07/18/2011 - 06:46
Posts: 602
Location: USA
JohnnyMac wrote:

I am waiting for yet another full driver and pill from fasttech. I installed the new driver in my test light and while I can pair easily with the light on 3 different Android devices I am completely unable to connect to or program the light. Is Good to see that someone here ha a working light from the official release.  I am eagerly waiting for the’s experience with the new driver.  Foy has been reluctant to swap his beta driver for the real driver because his beta works with a few exceptions. Hopefully he will swap the driver so we can find out what his experience with the production driver is. I hope my bad experience is limited to only mine and that a while new replacement pill resolves it all. 

The windows app won’t even run for me on my W7 64bit laptop. Not sure why it seems to work for others. 

Johnny frustrated Mac

Seriously? It won’t run on Windows 7 64bit for you? I’m running it on a Dell XPS Windows 7 ×64-bit Service Pack 1.

About an hour ago I loaded it on my HP Laptop Windows 8 ×64 Media Center Pro edition and it connects instantly, I’m very impressed with it. I don’t have my S4 yet, so can’t speak on Android yet.

Fenix TK12, TK15, TK21-U2, TK61, TK75 Olight M20S, M21<span style="color: #0000ff;"

_the_
_the_'s picture
Offline
Last seen: 5 months 2 days ago
Joined: 07/08/2011 - 06:22
Posts: 3647
Location: Finland

picrthis wrote:
I can't see the sense without details, does that mean only the high priority item will be fixed before a full public release? that would then mean lots of redundant bug reports to flexcandles for probably items you already discovered but didn't share, thus people will report same issues and probably get answer like "known issue" that ought to be fun, sorry I believe in transparency or........well you know; wasn't that the purpose of choosing some testers on here so we all can see the results?

Well.. The priorization was my own interpretation of severity. High means "must be fixed before release", medium is more like minor usability issue, and low is just cosmetic (like: button is 1pix too much to the right). As a professional software developer, I'm a bit strict with these.. Wink

=the=

 

picrthis
picrthis's picture
Offline
Last seen: 1 year 9 months ago
Joined: 07/18/2011 - 06:46
Posts: 602
Location: USA

I understand, as a Director when I give out info to my Team I use transparency and expect them to do the same with reports back to me, not to blur out “info” and say you can see by the graph we have just an issue or two to resolve, actually NO I can’t; nothing personal if your going to post, post – otherwise it’s a waste of bandwidth.

Fenix TK12, TK15, TK21-U2, TK61, TK75 Olight M20S, M21<span style="color: #0000ff;"

mhanlen
mhanlen's picture
Offline
Last seen: 11 months 3 weeks ago
Joined: 03/01/2013 - 11:42
Posts: 2601
Location: Eastern USA

So, are the people who bought the lights getting the updated driver? Mines currently in transit. It shipped last week.

Foy
Foy's picture
Offline
Last seen: 7 years 7 months ago
Joined: 01/02/2011 - 17:56
Posts: 3009
Location: Las Vegas

Johnny is right, I have been dragging my feet putting in the new driver.  Except for not being able to program the lowest non-PWM mode and the next two higher, my light programs and functions beautifully so, I'm reluctant to tear apart a light that works so well.

The thing is, I have to do it, sooner rather than later.  I'm using the very first version app to hit Play Store and if I update, it won't work with the old driver.  My bad for putting it off.  The thing is, unlike the other guys, my light usually connects on the very first try and accepts new profiles without a hitch.  It's actually got a foot, and sometimes almost three feet range.

Not trying to justify my tardiness but my example is pretty dang stable as is.  They've had me hopping at work but I think I'll be able to do it tomorrow night.  Sorry I haven't been more communicative but Johnny and _the_ have put this extra time to good use, working through all the issues.  It's actually a good thing the problems happened to the other guys' lights because they are much more qualified than Foy.  They've really gone the extra mile helping Fastech get this right.

 

Foy

No referral links and nothing embedded . . . ever.

                      &nbsp

relic38
relic38's picture
Offline
Last seen: 4 years 11 months ago
Joined: 12/28/2012 - 00:39
Posts: 3390
Location: Toronto, Canada

I got mine today and it was connecting, but now it’s the same as Johnny’s. it pairs up no problem, but the app immediately fails when I tap connect. The issue has been reported to Fasttech.
I am not sure, but I think I might have set the light down on its tail while connected to it. The ZY-T08 is know for mode-switching when tapped on the tail end. This is what happened (I had the light on high using the cool remote control feature), and the light immediately turned off, and has not connected since.
If I had a pre-release driver, I would not report this here. Since this is a released driver and many of us now or will soon have them, I feel it is important to inform everyone of what has happened without concluding that something is wrong or broken.
Until I get a response from Fasttech, I’m not going to jumping to conclusions. it is possible that I messed up somehow and there is a simple solution.

Welcome the night.

My Reviews   My Mods    http://budgetlightforum.com/search?

fasttech
fasttech's picture
Offline
Last seen: 1 month 1 day ago
Joined: 11/12/2012 - 04:56
Posts: 1106

@Relic38, there is no Android crash reports received. Are you using the Windows application? We are interested in the crash message — I’ll try to find your ticket now.

FASTTECH - LED Flashlights, Lasers and Electronics

relic38
relic38's picture
Offline
Last seen: 4 years 11 months ago
Joined: 12/28/2012 - 00:39
Posts: 3390
Location: Toronto, Canada

Hi Fasttech, It doesn’t crash, it just doesn’t connect. I had to email the ticket, for some reason I could not enter one through the online form. PM me if you cannot find it, I’ll resend.

Welcome the night.

My Reviews   My Mods    http://budgetlightforum.com/search?

picrthis
picrthis's picture
Offline
Last seen: 1 year 9 months ago
Joined: 07/18/2011 - 06:46
Posts: 602
Location: USA

@relic38

Are you using Andriod or PC App?

Fenix TK12, TK15, TK21-U2, TK61, TK75 Olight M20S, M21<span style="color: #0000ff;"

relic38
relic38's picture
Offline
Last seen: 4 years 11 months ago
Joined: 12/28/2012 - 00:39
Posts: 3390
Location: Toronto, Canada

Android.

Welcome the night.

My Reviews   My Mods    http://budgetlightforum.com/search?

picrthis
picrthis's picture
Offline
Last seen: 1 year 9 months ago
Joined: 07/18/2011 - 06:46
Posts: 602
Location: USA

OK, Thanks I’m using the PC app myself on a Retail unit and it works just fine…..I’m pleased with it so far.

Fenix TK12, TK15, TK21-U2, TK61, TK75 Olight M20S, M21<span style="color: #0000ff;"

relic38
relic38's picture
Offline
Last seen: 4 years 11 months ago
Joined: 12/28/2012 - 00:39
Posts: 3390
Location: Toronto, Canada

PC App will connect to the device, but it goes downhill from there.
I’ll work this out with Fasttech support and report the results here.

Welcome the night.

My Reviews   My Mods    http://budgetlightforum.com/search?

fasttech
fasttech's picture
Offline
Last seen: 1 month 1 day ago
Joined: 11/12/2012 - 04:56
Posts: 1106

Relic38, we have got your message and ticket. From your screenshots the Windows app is able to connect and show voltage/temperature, but it can’t pull profiles.

We have determined that this is caused by the apps not correctly handling memory corruptions caused by the power interruption. Please test the updated Windows/Android apps we have sent you and see if they corrects the situation.

Thanks!

FASTTECH - LED Flashlights, Lasers and Electronics

ChibiM
ChibiM's picture
Offline
Last seen: 14 hours 24 min ago
Joined: 05/09/2011 - 10:25
Posts: 7065
Location: Holland

Just received the light... didnt have time yet to check it out..
I hope to do that very soon.

thanks Fasttech!

Pages