My KD C8 XML stopped working, pulled head off to find a funny smell.

7 posts / 0 new
Last post
snoozin
Offline
Last seen: 8 years 8 months ago
Joined: 03/05/2011 - 16:12
Posts: 20
Location: Canada
My KD C8 XML stopped working, pulled head off to find a funny smell.

I really liked this flashlight, I was using it when working on my vehicle. It took a few minor bumps. I want to fix it. Can I just buy a part from Kaidoman to just swap in?

 

This is a really good flashlight, I dropped it lets say 12 times in its lifetime. I was using a non protected trustfire and I left the flashlight on for a long time, to the point to where the light was diming. It was still working. I turned it off and then it wouldn't turn back on. I tried several newly charged batteries with no sucess.

 

Please help me fix my first XML flashlight.

trooplewis
trooplewis's picture
Offline
Last seen: 2 years 2 months ago
Joined: 03/26/2011 - 15:35
Posts: 2613
Location: San Diego

First tighten up everything inside; make sure the pill and the tailpiece switch are not loose, you may just have a bad connection.

Rats, finally sold my 2010 509hp Mustang...now I can buy more lights!

Sold the red one too! Now guess what I drive, doing my penance for 500 hp commuters...

http://dreammustang.com/

http://i884.photobucket.com/albums/ac47/Ha

josith
Offline
Last seen: 8 years 6 months ago
Joined: 03/16/2011 - 01:05
Posts: 65

u said u turned it on for a long time. was it on high?  examine the pill, see if anything melted.

Don
Don's picture
Offline
Last seen: 1 year 1 month ago
Joined: 01/12/2010 - 16:32
Posts: 6617
Location: Scotland

The smell implies something burned. My guess, it needs a new driver.

 

The numbers from my light tests are always to be found here.

https://spreadsheets.google.com/ccc?key=0ApkFM37n_QnRdDU5MDNzOURjYllmZHI...

agenthex
agenthex's picture
Offline
Last seen: 8 years 3 weeks ago
Joined: 07/14/2010 - 04:49
Posts: 3070
Location: Merica

Depends on whether it smelled like Magic Smoke (tm). Smile

Reading this makes you smarter: http://lesswrong.com/

snoozin
Offline
Last seen: 8 years 8 months ago
Joined: 03/05/2011 - 16:12
Posts: 20
Location: Canada

It is working now. Its something in the tail cap thats loose. Because I have been rough with my torch with the clicker button doesn't seem so tight anymore Sealed

 

I was so happy when it suddenly started working again. 

Ifrit
Offline
Last seen: 1 year 8 months ago
Joined: 08/28/2010 - 20:50
Posts: 122

i definitely know the feeling. My aurora ak-p7-2 was getting wonky for a while, flickering and occasionally not working at all. I was so very pleased to find out the tailcap had just gotten a little loose.