Tmart Group Buy - Closed

283 posts / 0 new
Last post
skyrider1
Offline
Last seen: 3 years 3 months ago
Joined: 11/18/2012 - 21:54
Posts: 762
Location: USA

Just wondering, who hasn’t received their light yet?

I ordered the no name on the 22nd, shipped the 27th. Still waiting.

max
max's picture
Offline
Last seen: 2 days 12 hours ago
Joined: 02/17/2014 - 18:55
Posts: 483
Location: Austin, TX

My no name came today. XM-L2 led too!

 

 max

M4D M4X
M4D M4X's picture
Offline
Last seen: 1 year 1 month ago
Joined: 03/19/2014 - 05:17
Posts: 8821
Location: Austria (GMT + 1)
skyrider1 wrote:
I ordered the no name on the 22nd, shipped the 27th. Still waiting.

we are in the same boat…

PLEASE NOTE
i do not work in "reviews, deals and codes" for the time being
maybe M4D M4X will return one day, but until then:

THANK YOU FOR YEARS OF YOUR SUPPORT AND FRIENDLY CONTACTS!

DayLighter
DayLighter's picture
Offline
Last seen: 5 years 4 months ago
Joined: 11/29/2012 - 01:22
Posts: 2829
Location: New York City

Got mine today.. no name in grey color.. bad driver but good XM-L2,, can’t win them all I guess.
now.. how are we going to get the good driver? sending the whole light back to china is out of the question Flat Stare

The only way to do a great work is to love what you do.

SchwarzeWolke
Offline
Last seen: 1 year 10 months ago
Joined: 03/06/2014 - 16:09
Posts: 90
Location: Cologne

Mine also arrived this saturday. Seems legit, grey and no name. Dunno what driver is installed, I do wait for my tools…

Overall build quality is good, nothing like “white dust” or something else.

devman
Offline
Last seen: 1 year 3 months ago
Joined: 04/27/2011 - 06:24
Posts: 825
Location: Hong Kong / Vancouver, Canada

Still waiting here too.

Edit: apparently it was shipped via Sweden post from the Hong Kong warehouse to my address IN Hong Kong via Singapore. Still waiting.

maciex93
Offline
Last seen: 5 years 2 weeks ago
Joined: 10/15/2013 - 06:32
Posts: 118
Location: Poland

I’m waiting too ;(

Gj
Gj's picture
Offline
Last seen: 1 month 3 weeks ago
Joined: 06/26/2013 - 15:44
Posts: 3066
Location: NY,USA

DayLighter wrote:
Got mine today.. no name in grey color.. bad driver but good XM-L2,, can't win them all I guess. now.. how are we going to get the good driver? sending the whole light back to china is out of the question :|

See post 137.

http://budgetlightforum.com/node/29786?page=4#comment-563157

Sirius9
Sirius9's picture
Offline
Last seen: 1 day 17 hours ago
Joined: 03/04/2012 - 19:23
Posts: 4653
Location: South Europe

maciex93 wrote:
I’m waiting too ;(

This…

 

maciex93
Offline
Last seen: 5 years 2 weeks ago
Joined: 10/15/2013 - 06:32
Posts: 118
Location: Poland

Got mine today, no name model, and gray? but a little brownish, like that one http://www.tmart.com/UItraFire-CREE-XM-LT6-8W-1300-Lumen-5-Mode-LED-Flashlight-Gray_p135765.html

P4160010 (1024x768).jpgP4160011 (1024x768).jpgP4160012 (1024x768).jpgP4160013 (1024x768).jpgP4160014 (1024x768).jpgP4160015 (1024x768).jpgP4160017 (1024x768).jpg

Led is XM-L2, driver is not East092 (look on photo). Oring on head was broken, I think some one put too small oring on big head, unfortunately too big…
Pill has a very short thread, about half of normal pill from Old Lumens video.
Current in high mode is about 2,5A with fresh samsung cell.

Streamer
Streamer's picture
Offline
Last seen: 2 years 9 months ago
Joined: 12/01/2011 - 21:06
Posts: 3792
Location: TX

maciex93 wrote:
Got mine today, no name model, and gray? but a little brownish, like that one http://www.tmart.com/UItraFire-CREE-XM-LT6-8W-1300-Lumen-5-Mode-LED-Flas... P4160010 (1024x768).jpgP4160011 (1024x768).jpgP4160012 (1024x768).jpgP4160013 (1024x768).jpgP4160014 (1024x768).jpgP4160015 (1024x768).jpgP4160017 (1024x768).jpg Led is XM-L2, driver is not East092 (look on photo). Oring on head was broken, I think some one put too small oring on big head, unfortunately too big... Pill has a very short thread, about half of normal pill from Old Lumens video. Current in high mode is about 2,5A with fresh samsung cell.

 

That O-ring does not belong on the pill.  Causes fitment problems and POOFS!

Old Lumens even removes his. 

 

Streamer's picture
You 03/30/2014 - 11:51 

Hi OL. Got a question on Tangsfire HD2010. 
Turns out, I had to remove the pills o-ring to get the reflector to seat properly. With the o-ring installed, it jams the reflector base into the star/solder connections when I screw the bezel back on. Works fine without the pill o-ring save for losing waterproofness. 
I’m assuming this is what caused my short from the getgo. It melted/deformed the centering spacer slightly as a result.
Have you seen this on any of the HD2010’s you have handled? TIA….David

 

Old-Lumens's picture
Old-Lumens 03/30/2014 - 11:52 

Yes, I only had one that had the O-ring, but I had to remove it. It caused interference, as you describe.

M4D M4X
M4D M4X's picture
Offline
Last seen: 1 year 1 month ago
Joined: 03/19/2014 - 05:17
Posts: 8821
Location: Austria (GMT + 1)

if Poland was delivered today, I hope Austria will get them tomorrow Wink

but the picture I get is that the units that was on backorder where manufactured last minute without looking on quality Sad

PLEASE NOTE
i do not work in "reviews, deals and codes" for the time being
maybe M4D M4X will return one day, but until then:

THANK YOU FOR YEARS OF YOUR SUPPORT AND FRIENDLY CONTACTS!

maciex93
Offline
Last seen: 5 years 2 weeks ago
Joined: 10/15/2013 - 06:32
Posts: 118
Location: Poland

Oring wasn’t on pill, it was on head thread, here: http://obrazki.elektroda.pl/8614174000_1397664627.jpg

Streamer
Streamer's picture
Offline
Last seen: 2 years 9 months ago
Joined: 12/01/2011 - 21:06
Posts: 3792
Location: TX

Oooops..my bad.  Foot in Mouth  Anyways, watch out for o-rings on pills.

Old-Lumens
Old-Lumens's picture
Offline
Last seen: 5 years 9 months ago
Joined: 11/04/2011 - 11:39
Posts: 7478
Location: Tyler, TX, USA

I would remove the O rings on those pills. I took them off the ones I did. As poor as the rest of the O rings are, it certainly would not keep anything waterproof down there.

My PayPal address: oldlumens (insert the @ sign here) gmail.com

My YouTube Flashlight Video Channel

The BLF Modding Links Thread 

http://imageshack.com/a/img922/1374/jQ2wdL.jpg

 

Ejected Filament
Ejected Filament's picture
Offline
Last seen: 1 year 7 months ago
Joined: 12/03/2013 - 04:29
Posts: 2343
Location: Qld, Australia

I noticed my no name one had an o-ring on the pill. I assumed it was to help nip the pill down and keep it in place. Doesnt seem to be negatively effecting mine though.

Streamer
Streamer's picture
Offline
Last seen: 2 years 9 months ago
Joined: 12/01/2011 - 21:06
Posts: 3792
Location: TX

Ejected Filament wrote:
I noticed my no name one had an o-ring on the pill. I assumed it was to help nip the pill down and keep it in place. Doesnt seem to be negatively effecting mine though.

When you have the bezel removed, note if reflector is sitting flush atop of head.

With the pill O-ring installed, mine definitely was not.  So it smashed into the star and wires when bezel was installed.

Ejected Filament
Ejected Filament's picture
Offline
Last seen: 1 year 7 months ago
Joined: 12/03/2013 - 04:29
Posts: 2343
Location: Qld, Australia

If its hitting at all Im not getting any shorts. Ive run the light for several minutes at a time, several times. And it still works fine, and no damage like a melted centering ring etc.

Damn it, I just pulled the bezel off, noticed the reflector sits ever so slightly off the head. I kind of wobbled it to ensure it was off and not simply slightly proud due to fit, and sure enough slight movement. So I held the reflector in place, hit the button to smoke test it, the light lit, then stopped. I look inside, no LED. Oh wait, there it is, off to the side. I blame you streamer… *shakes fist

Im guessing I rotated the reflector, which was biting down on the centering ring, and voila, freed the LED. Pffft, who needs an iron to remove an LED… oops

Streamer
Streamer's picture
Offline
Last seen: 2 years 9 months ago
Joined: 12/01/2011 - 21:06
Posts: 3792
Location: TX

Been there done that too.   Remember, I'm just the messenger.

We'd all be better off with reflector hole large enough to fit around the star.

The spacer "thing" is an accident waiting to happen.

Ejected Filament
Ejected Filament's picture
Offline
Last seen: 1 year 7 months ago
Joined: 12/03/2013 - 04:29
Posts: 2343
Location: Qld, Australia

Streamer wrote:

Been there done that too.   Remember, I’m just the messenger.

We’d all be better off with reflector hole large enough to fit around the star.

The spacer “thing” is an accident waiting to happen.


I wasnt serious about blaming anyone except myself Streamer. I should have known better than to twist the reflector if its that tight down, I assume thats what i did. Not that it matters, so long as I havent damaged it, I now have the XML2 to put on a copper sinkpad, and into the copper pill I have. Might look to drive it with a single mode driver, hot.
bgyen
Offline
Last seen: 2 years 8 months ago
Joined: 03/02/2013 - 10:34
Posts: 633
Location: Canada

The o-ring on the light I got broke too… it was the one that connected the battery tube to the head.

Nightbird95
Nightbird95's picture
Offline
Last seen: 2 years 7 months ago
Joined: 01/03/2013 - 01:16
Posts: 1153
Location: N 11º 08', E 124º 37'
M4D M4X wrote:
skyrider1 wrote:
I ordered the no name on the 22nd, shipped the 27th. Still waiting.

we are in the same boat…

Me too. Sad

Gj
Gj's picture
Offline
Last seen: 1 month 3 weeks ago
Joined: 06/26/2013 - 15:44
Posts: 3066
Location: NY,USA

Ejected Filament wrote:
Streamer wrote:

Been there done that too.   Remember, I'm just the messenger.

We'd all be better off with reflector hole large enough to fit around the star.

The spacer "thing" is an accident waiting to happen.

I wasnt serious about blaming anyone except myself Streamer. I should have known better than to twist the reflector if its that tight down, I assume thats what i did. Not that it matters, so long as I havent damaged it, I now have the XML2 to put on a copper sinkpad, and into the copper pill I have. Might look to drive it with a single mode driver, hot.

That big glass thing on the front, if you look through it during re-assembly, you can see if the reflector is seating properly before something goes crunch. Tongue Out Laughing

Ejected Filament
Ejected Filament's picture
Offline
Last seen: 1 year 7 months ago
Joined: 12/03/2013 - 04:29
Posts: 2343
Location: Qld, Australia

Gj wrote:

Ejected Filament wrote:
Streamer wrote:

Been there done that too.   Remember, I’m just the messenger.

We’d all be better off with reflector hole large enough to fit around the star.

The spacer “thing” is an accident waiting to happen.

I wasnt serious about blaming anyone except myself Streamer. I should have known better than to twist the reflector if its that tight down, I assume thats what i did. Not that it matters, so long as I havent damaged it, I now have the XML2 to put on a copper sinkpad, and into the copper pill I have. Might look to drive it with a single mode driver, hot.

That big glass thing on the front, if you look through it during re-assembly, you can see if the reflector is seating properly before something goes crunch. Tongue Out Laughing


But its upside down… Big Smile

We are talking about a tiny amount, maybe .2mm. Nothing got crunched as I had pulled it down a couple of times, and each time the light worked perfectly. Beam was nice too, not ringy or anything, Im betting that will change now. Im guessing it just didnt like being held tight, and twisted. The amount of tightness seemed appropriate to keep everything from rattling, and keep the LED in the reflector.

Streamer
Streamer's picture
Offline
Last seen: 2 years 9 months ago
Joined: 12/01/2011 - 21:06
Posts: 3792
Location: TX

Old-Lumens wrote:

For those of you who got the wrong driver or got the right driver, but it is faulty, or only does low amps, please PM me.

In your PM to me, include the following:

  1. Order number
  2. Date you ordered
  3. Date you received it
  4. Exactly what the problem is (Example:) " My light will only put out 1 amp on high, with the East092 driver."  OR  "My driver was not an East092 driver, it was an XXXX driver (include the numbers on the driver if you can)"

 According to my contact, a replacement light or money back can be done.

 

For those of you that have some other issue, then PM me and I will see what I can do.

 

How bout an update on this?  Undecided

M4D M4X
M4D M4X's picture
Offline
Last seen: 1 year 1 month ago
Joined: 03/19/2014 - 05:17
Posts: 8821
Location: Austria (GMT + 1)

another day with no delivery…

PLEASE NOTE
i do not work in "reviews, deals and codes" for the time being
maybe M4D M4X will return one day, but until then:

THANK YOU FOR YEARS OF YOUR SUPPORT AND FRIENDLY CONTACTS!

SchwarzeWolke
Offline
Last seen: 1 year 10 months ago
Joined: 03/06/2014 - 16:09
Posts: 90
Location: Cologne

My lights had hit european ground a while ago. They have been idling at the customs for quite a while. Guess this might explain the delay for european customers…
One was delivered without going through customs, one is stuck…

Legolas Jr.
Legolas Jr.'s picture
Offline
Last seen: 1 month 1 week ago
Joined: 09/17/2013 - 21:55
Posts: 884
Location: Springport, IN

On my Tangsfire, the oring between the bezel and glass lens is slightly too big, and it lets water in. Can anyone suggest a place to get a quality replacement?

“Strive to be a warrior and a scholar. Be forged in fire and tempered by knowledge. If not, you will either lack the courage to fight for your ideals or lack ideals worth fighting for.”

Old-Lumens
Old-Lumens's picture
Offline
Last seen: 5 years 9 months ago
Joined: 11/04/2011 - 11:39
Posts: 7478
Location: Tyler, TX, USA

Streamer wrote:

Old-Lumens wrote:

For those of you who got the wrong driver or got the right driver, but it is faulty, or only does low amps, please PM me.

In your PM to me, include the following:

  1. Order number
  2. Date you ordered
  3. Date you received it
  4. Exactly what the problem is (Example:) " My light will only put out 1 amp on high, with the East092 driver."  OR  "My driver was not an East092 driver, it was an XXXX driver (include the numbers on the driver if you can)"

 According to my contact, a replacement light or money back can be done.

 

For those of you that have some other issue, then PM me and I will see what I can do.

 

How bout an update on this?  Undecided

The update is, I have passed on to tmart, all the PM information I have received, so it's up to them now. There's not much more I can do from there. I do know that many have been contacted by them via PM, since this info has been passed on to them.

 

My PayPal address: oldlumens (insert the @ sign here) gmail.com

My YouTube Flashlight Video Channel

The BLF Modding Links Thread 

http://imageshack.com/a/img922/1374/jQ2wdL.jpg

 

Pulsar13
Pulsar13's picture
Offline
Last seen: 2 months 5 days ago
Joined: 02/05/2012 - 10:23
Posts: 1909
Location: Malaysia

Received mine. Black Tangsfire with EAST092 chip 06N03 (should be good). Unfortunately comes with friggin’ next-mode memory, but easily removed with pencil. Nice, big and shiny aluminium reflector. I can see why people love this light.

Plain old XML, cold white. Quite bright from first turn on, without any mod. I haven’t tested amperage but I don’t really mind at this point, it works well, it uses the proper driver and honestly T-Mart hasn’t made any claim that it should be 5A or anything. That claim was based on O-L’s review and the assumption that they’re all built the same.

In all, I’m very satisfied with mine, especially for $20. It’s excellent. No complaint from me.

Thanks O-L and T-Mart for this great deal.

Pages