Measuring protected batteries?

3 posts / 0 new
Last post
gcbryan
Offline
Last seen: 9 months 1 week ago
Joined: 05/07/2010 - 20:42
Posts: 2571
Location: Seattle,WA
Measuring protected batteries?

I have a bunch of Trustfire 18650 protected batteries. They're not new, they're protected and I have a charger with an overcharge protection as well. So I guess I've really never checked them out with a multi-meter.

I thought I had but now I can't get a steady reading or a meaningful reading (on any of them). They all work. The numbers just keep moving on the display screen of my multi-meter.

It's not a setting problem I don't think. I can get readings on AA. I tried hitting the "range' button a few times anyway but that's apparently not the problem.

Is there anything about the protection circuit (not tripped) that would prevent taking a reading?

E1320
E1320's picture
Offline
Last seen: 9 months 1 week ago
Joined: 03/30/2011 - 05:26
Posts: 3376
Location: New Hampshire

Try cleaning the top and bottom of the batteries were they connect. Use a paper towel with some IPA on it and wipe them off good then use a pencil eraser and scrub until the connections are clean. If the batteries are bad you will see the voltage number steadily drop at rest.

I am already visualizing the duct tape over your mouth.

gcbryan
Offline
Last seen: 9 months 1 week ago
Joined: 05/07/2010 - 20:42
Posts: 2571
Location: Seattle,WA

Thanks. I think I must be losing my mind Smile I knew I had measured these before!

I just wiped the bottoms and tops off with a cloth and now the all measure correctly! I don't know what happened before. I tried to measure 6 of them before I started this thread. Now I wipe them and they all measure correctly. They didn't look "dirty" but I guess grease from handling builds up?

Anyway, thanks!