[Solved] SkyRC MC3000 Firmware Update Issue

7 posts / 0 new
Last post
Yourrid's picture
Last seen: 2 weeks 5 days ago
Joined: 05/17/2013 - 09:41
Posts: 1078
Location: ATL
[Solved] SkyRC MC3000 Firmware Update Issue

Hey guys,

I just received a new SkyRC MC3000 charger and have been enjoying using it, well until now. I saw that my firmware was old compared to the one listed on SkyRC’s website, so I figured I would update it. I downloaded both the monitor software and the firmware packages, followed the instructions, and as the charger was updating, this error popped up. “start vector err1”

The update pauses and doesn’t do anything. I clicked OK and it still didn’t do anything. My charger now has a completely blank screen and I’m freaked out that it may be one very expensive brick Crying

Anyone have any idea on this? I saw a thread on CPF talking about this, but the member never got back to the thread on how to resolve it.

Any help would be very appreciated.


I was looking through CPF and found a thread where one of their members, TJH, came up with a guide to solve a firmware flash issue.
Here are the steps:

TJH wrote:

Dummies guide to reflash a charger after a failed flash:

Step 0: Also, if you are using windows 10 make sure that you are up to date. You must be on build 1511. (Thanks to MarioJP)
Step 1: Get a better USB Cable
Step 2: Remove all and any USB devices/cables from your PC.
Step 3: Ensure no ports are in USB3 mode. Turn that off in your BIOS if you have to. Don’t ask me how to do this.
Step 4: Remove all cables from the charger
Step 5: Holding the Enter Key on the charger, plug in the Power. IT WILL POWER UP TO A BLANK SCREEN. THIS IS EXPECTED.
Step 6: Plug in the known-good USB cable into the charger, then into your PC.
Step 7: Run the UpgradeFirmware_MC3000_V11.exe program. Ensure it says “My Device was Found” then probably it’ll say “Some data was send”. It should also show “Boot Version: 1.x” where x is probably 1.
Step 8: Click the update button again.

If Step 7 is failing (can’t see your charger) then either:
1) You have managed to damange the built-in boot code of the charger. Almost impossible.
2) You have a bad PC/USB Cable/Windows install. Try another one. Borrow a friends PC.

The boot code that runs when you press Enter is hard coded. So it should always be possible to unbrick the charger by pressing enter when power is plugged in. The blank screen you get is expected, the charger is booting a very small “Boot Loader” and nothing else. This boot loader has nothing to do with the version of firmware your charger is/was running. It’s burnt onto the EEPROM of the charger.

Hope this helps.

Huge thank you to TJH for making this guide. I was really worried my charger just became a very expensive brick. Hopefully this will help someone else later on.

Edited by: Yourrid on 08/13/2017 - 18:59
Slayer1's picture
Last seen: 3 hours 33 min ago
Joined: 03/03/2016 - 02:59
Posts: 434
Location: Singapore
Thumbs Up

FS : SFT70 20mm DTP 6V 6500k / BLF A6

tjh's picture
Last seen: 5 years 3 months ago
Joined: 03/03/2016 - 17:31
Posts: 1
Location: Napier, New Zealand

Glad I could help Smile

Last seen: 1 day 51 min ago
Joined: 08/12/2015 - 17:00
Posts: 81
Location: Sweden

Thanks for the instruction – it saved my day.

ChibiM's picture
Last seen: 1 day 12 hours ago
Joined: 05/09/2011 - 10:25
Posts: 7086
Location: Holland

BTW, there is a new firmware update for the SkyRC MC3000 


maukka's picture
Last seen: 5 months 2 weeks ago
Joined: 12/31/2015 - 04:15
Posts: 2176
Location: Finland

Thank ChibiM! Looks like the update is to support the new phone app. No information on other changes.

ChibiM's picture
Last seen: 1 day 12 hours ago
Joined: 05/09/2011 - 10:25
Posts: 7086
Location: Holland

Ah, I only noticed a new update.. without looking into the details Wink