Astrolux S43 - New model (On Sale)

256 posts / 0 new
Last post
Texas_Ace
Texas_Ace's picture
Offline
Last seen: 1 week 3 days ago
Joined: 03/24/2016 - 07:44
Posts: 9036
Location: Everything is brighter in Texas

varbos wrote:
This is how my S43S from BG came:
https://i.imgur.com/nLSMWd0.jpg
https://i.imgur.com/EM0Yq3V.jpg
There’s a blob of solder joining one pad to the outer ring of the driver board. And the other pad does not have any solder at all.

Here is how it is supposed to look:
https://i.imgur.com/t0fMppC.jpg

Can anybody explain what I am seeing? Bad workmanship? A returned light which had to be repaired?
It seems to work okay..

My guess is too much solder was used when installing the second pcb and it touched the ground ring. Once that happens removing it is basically impossible.

Although in this case that rod and the ground ring are connected anyways so if anything it would lower resistance and should not effect the light.

varbos
Offline
Last seen: 3 days 17 hours ago
Joined: 02/16/2017 - 07:36
Posts: 573
Location: Europe

Texas_Ace wrote:

Although in this case that rod and the ground ring are connected anyways so if anything it would lower resistance and should not effect the light.

Thanks for info. If you think it should not affect anything (operation/reliability/safety) then I won’t complain to BG.
I just thought it looked very ugly and amatuerish compared to other owners pictures.
Texas_Ace
Texas_Ace's picture
Offline
Last seen: 1 week 3 days ago
Joined: 03/24/2016 - 07:44
Posts: 9036
Location: Everything is brighter in Texas

Yeah, it is ugly for sure but it should not effect the operation of the light.

MascaratumB
MascaratumB's picture
Offline
Last seen: 30 min 30 sec ago
Joined: 10/29/2016 - 12:12
Posts: 6273
Location: Portugal

Well, this isn’t about the S43 but about it’s clone (at least concerning the body design…)! Facepalm
It is also on sale…

JasonWW
JasonWW's picture
Offline
Last seen: 1 hour 36 min ago
Joined: 10/22/2016 - 11:41
Posts: 12806
Location: Houston Texas

Similar “looking”, but not the same light.

You should probably delete the link. (rule violation)

Texas Ace Lumen Tube and JoshK Sphere calibrated with Maukka lights

Click this to go to signature links. I'm still around, just not reading many new threads.

MascaratumB
MascaratumB's picture
Offline
Last seen: 30 min 30 sec ago
Joined: 10/29/2016 - 12:12
Posts: 6273
Location: Portugal

JasonWW wrote:
Similar “looking”, but not the same light.

You should probably delete the link. (rule violation)


Post edited!
BTW, what rule was I breaking?
raccoon city
raccoon city's picture
Online
Last seen: 11 min 36 sec ago
Joined: 10/06/2010 - 02:35
Posts: 15554
Location: रॅकून सिटी Palm Desert CA USA

MascaratumB wrote:

what rule was I breaking?

Good question!  :THUMBS-UP:

JasonWW
JasonWW's picture
Offline
Last seen: 1 hour 36 min ago
Joined: 10/22/2016 - 11:41
Posts: 12806
Location: Houston Texas

MascaratumB wrote:
JasonWW wrote:
Similar “looking”, but not the same light.

You should probably delete the link. (rule violation)


Post edited!
BTW, what rule was I breaking?

My bad, I read the thread title and was thinking this was a Group Buy thread from Freeme or MadMax, etc.. but it’s not. It’s just a regular thread. Link is okay.

(On Group Buy threads the OP is basically drumming up business, so if someone posts a link to a competing light it can take away sales. I don’t know if it’s an official rule or more a courtesy/respect thing.)

Texas Ace Lumen Tube and JoshK Sphere calibrated with Maukka lights

Click this to go to signature links. I'm still around, just not reading many new threads.

Diabolik
Diabolik's picture
Offline
Last seen: 12 months 4 days ago
Joined: 04/20/2020 - 08:11
Posts: 2
Location: Italy

Hello!

Can anybody help with an apparently malfunctioning S43S?

I have just received my brand new S43S which I loaded with a TrustFire 18350 1200mAh.

The 2 batteries I bought came sealed so they appear to be new but, as I put the torch on charge, I notice that both the switch and the leds start to flash continuously which isn’t normal as far as I know. With the charger disconnected the flashlight looks completely dead. No click sequence works. Needless to say, I inserted the battery with the right polarity.

I even tried to take the battery off and simulate a charging session with no battery in, which resulted in exactly the same problem, flashing leds and switch. Something must be wrong in either the torch or the batteries.

Any suggestion on what the problem could be?

Thanks in advance for any help.

Cheers.

JasonWW
JasonWW's picture
Offline
Last seen: 1 hour 36 min ago
Joined: 10/22/2016 - 11:41
Posts: 12806
Location: Houston Texas

Diabolik wrote:
Hello!

Can anybody help with an apparently malfunctioning S43S?

I have just received my brand new S43S which I loaded with a TrustFire 18350 1200mAh.

The 2 batteries I bought came sealed so they appear to be new but, as I put the torch on charge, I notice that both the switch and the leds start to flash continuously which isn’t normal as far as I know. With the charger disconnected the flashlight looks completely dead. No click sequence works. Needless to say, I inserted the battery with the right polarity.

I even tried to take the battery off and simulate a charging session with no battery in, which resulted in exactly the same problem, flashing leds and switch. Something must be wrong in either the torch or the batteries.

Any suggestion on what the problem could be?

Thanks in advance for any help.

Cheers.


Definitely try a different battery. That trustfire is probably junk. Maybe 300mah real capacity. Dont trust them.

Do you have any 18650 cells to try?

I’ve never heard of the main and switch leds flashing continuously, but see what a different battery does first. Let’s rule that out.

Texas Ace Lumen Tube and JoshK Sphere calibrated with Maukka lights

Click this to go to signature links. I'm still around, just not reading many new threads.

JasonWW
JasonWW's picture
Offline
Last seen: 1 hour 36 min ago
Joined: 10/22/2016 - 11:41
Posts: 12806
Location: Houston Texas

There are no retaining rings on this light, unless they changed the design.

Texas Ace Lumen Tube and JoshK Sphere calibrated with Maukka lights

Click this to go to signature links. I'm still around, just not reading many new threads.

Diabolik
Diabolik's picture
Offline
Last seen: 12 months 4 days ago
Joined: 04/20/2020 - 08:11
Posts: 2
Location: Italy

Hi Jason

Thanks for your reply.

I contacted the vendor who sold me the batteries and he told me that the cells have been tested before shipping and the product is original, not a fake one. He has excellent feedback on ebay so I doubt he’s a crook.
He offered to replace the cells with a different brand same specifications. I read that the S43S can accommodate any kind of 18350 be it with or without pin, unprotected or protected.

I’ll wait for the new cells and see what happens.

Cheers

Couchmaster
Offline
Last seen: 2 days 3 hours ago
Joined: 05/04/2016 - 17:11
Posts: 416
Location: USA

Diabolik wrote:
I contacted the vendor who sold me the batteries and he told me that the cells have been tested before shipping and the product is original, not a fake one. He has excellent feedback on ebay so I doubt he’s a crook. He offered to replace the cells with a different brand same specifications. I read that the S43S can accommodate any kind of 18350 be it with or without pin, unprotected or protected.

I’ll wait for the new cells and see what happens.

Cheers

It’s likely that the flashlight needs more current than the Trustfire battery’s you have on hand can provide. The S43S is a high draw light isn’t it? Check both of those numbers. It could be that your batteries would be fine in a less demanding application. Regardless, getting a name brand battery and try it first is good advice.

JasonWW
JasonWW's picture
Offline
Last seen: 1 hour 36 min ago
Joined: 10/22/2016 - 11:41
Posts: 12806
Location: Houston Texas

Diabolik wrote:
Hi Jason

Thanks for your reply.

I contacted the vendor who sold me the batteries and he told me that the cells have been tested before shipping and the product is original, not a fake one. He has excellent feedback on ebay so I doubt he’s a crook.
He offered to replace the cells with a different brand same specifications. I read that the S43S can accommodate any kind of 18350 be it with or without pin, unprotected or protected.

I’ll wait for the new cells and see what happens.

Cheers


Everyone on BLF knows to avoid Trustfire. Just saying.

Anyway, even if it’s protected, it should still deliver a few amps so it should work normally at lower brightness levels.

I cant remember, but I’m pretty sure all lengths of 18350 do not fit. There is only the spring in the tail cap which limits the length of battery you can use. Protected might be too long for the tail cap to screw closed all the way.

One thing you can try right now is to swap the battery tube around. One end is short and one long. You probably have it correct as i think it only works one direction.

Texas Ace Lumen Tube and JoshK Sphere calibrated with Maukka lights

Click this to go to signature links. I'm still around, just not reading many new threads.

JasonWW
JasonWW's picture
Offline
Last seen: 1 hour 36 min ago
Joined: 10/22/2016 - 11:41
Posts: 12806
Location: Houston Texas

Of course the battery needs to be charged. Do you have a voltmeter to see what its voltage is?

Texas Ace Lumen Tube and JoshK Sphere calibrated with Maukka lights

Click this to go to signature links. I'm still around, just not reading many new threads.

Pages