[♛ FreemeGB] Fireflies PL47 Gen II 4*XP-L/ Nichia/ SST20 Hi CRI 21700 Right Angle Flashlight - ENDED

2229 posts / 0 new
Last post
noboneshotdog
Offline
Last seen: 2 weeks 6 days ago
Joined: 05/12/2012 - 08:47
Posts: 600
Location: Hudson, New Hampshire

Can someone please tell me what size washers to purchase in order to maintain better battery contact?

Thier ain’t no bones in a hot dog. F. York

shirnask
shirnask's picture
Offline
Last seen: 18 min 15 sec ago
Joined: 03/21/2016 - 23:58
Posts: 1341
Location: Louisiana
noboneshotdog wrote:
Can someone please tell me what size washers to purchase in order to maintain better battery contact?

I used these from ebay

noboneshotdog
Offline
Last seen: 2 weeks 6 days ago
Joined: 05/12/2012 - 08:47
Posts: 600
Location: Hudson, New Hampshire
shirnask wrote:
noboneshotdog wrote:
Can someone please tell me what size washers to purchase in order to maintain better battery contact?

I used these from ebay

Super! Thank you.

Thier ain’t no bones in a hot dog. F. York

dmsoule
Offline
Last seen: 2 hours 47 min ago
Joined: 08/27/2016 - 20:14
Posts: 231
Location: MN USA
noboneshotdog wrote:
Can someone please tell me what size washers to purchase in order to maintain better battery contact?

I followed Madmax’s tip of wrapping a small piece of copper wire into a loop to use as a spacer. Works beautifully and didn’t need to purchase anything.

https://youtu.be/3SWNGoHhBfI

noboneshotdog
Offline
Last seen: 2 weeks 6 days ago
Joined: 05/12/2012 - 08:47
Posts: 600
Location: Hudson, New Hampshire
dmsoule wrote:
noboneshotdog wrote:
Can someone please tell me what size washers to purchase in order to maintain better battery contact?

I followed Madmax’s tip of wrapping a small piece of copper wire into a loop to use as a spacer. Works beautifully and didn’t need to purchase anything.

https://youtu.be/3SWNGoHhBfI

Thumbs Up

Thier ain’t no bones in a hot dog. F. York

BlueSwordM
BlueSwordM's picture
Offline
Last seen: 2 days 16 hours ago
Joined: 11/29/2017 - 12:34
Posts: 5552
Location: Canada

1. It can run with an 18650 no problem. Haven’t had any problems with a flat top 30Q.

2. The defects you see are cuts to the optic.

3. Same thing.

4. My magnet can easily hold the light sideways with a 4Ah 21700. Not as powerful as the D4S, but still very nice.

My very own high current Beryllium Copper springs Gen 3:
http://budgetlightforum.com/node/67401
Liitokala Aliexpress Stores Battery Fraud: http://budgetlightforum.com/node/60547

JoeRodge
Offline
Last seen: 4 months 1 week ago
Joined: 01/04/2018 - 23:13
Posts: 116
Location: United States

So, my cuts aren’t where they were broke off they are all over. Like something blunt cut it. Maybe it is the same thing though. Like where they machined the cone shape is where the cuts are. Maybe that’s what you are saying.

My magnet is Nothing like that bluesword.

I guess I should of done more research. This isn’t nearly as polished of build as my D4S.

I am not being lazy/cheap by using an 18650. When I ordered the light I got too excited and forgot to order the battery. The 21700 Samsung should be here any day now.

How does Neal deal with returns? Honestly, I’m not a very picky person and I want this one to work out for me. A magnet isn’t a deal breaker. The little gashes on the reflector, if it doesn’t effect beam, which I will look at when I get the proper battery, won’t be a deal breaker either.

From far away the light is freaking gorgeous. Like I said little things won’t bother me. My zebralights look like they went through a world war. I actually intend to use my lights. So this is gonna be gashed up anyway lol.

Kinda worried I got a unit that was already returned. The anodizing had small donation missing where a head strap may of clipped on.

I appreciate you guys filling me in though.

BlueSwordM
BlueSwordM's picture
Offline
Last seen: 2 days 16 hours ago
Joined: 11/29/2017 - 12:34
Posts: 5552
Location: Canada

Yeah, seems like the magnets put in are either different grades, or have been demagnetized partially by something.

I would just request another tailcap with a stronger magnet from Neals/Fireflies.

The cuts in the optic were annoying at first, but knowing that they did not affect the beam/efficiency, I forgot about it after a while.

Neal is very good with returns.

However, I would rather start the resolution with asking for a replacement tailcap.

Will make things much easier.

My very own high current Beryllium Copper springs Gen 3:
http://budgetlightforum.com/node/67401
Liitokala Aliexpress Stores Battery Fraud: http://budgetlightforum.com/node/60547

Pete33
Offline
Last seen: 1 year 8 months ago
Joined: 01/28/2019 - 19:59
Posts: 9
Location: CA

I tested the hypothesis of commections being damaged by temp, by pressing on the lens/optic (which would in turn press on the aux board and shift its position slightly, my thoughts) and got the aux lights to turn on intermittently now. Kinda weird. They seem to consistently turn back off after running on turbo.

Long sigh. I will wait to hear from FF, but Im thinkinng I may bust it open (break the lens) and inspect the board connections myself.

Edit: Tried to quote but didnt work on my phone.

Edit2: anyone know the diameter of the lens?

JoeRodge
Offline
Last seen: 4 months 1 week ago
Joined: 01/04/2018 - 23:13
Posts: 116
Location: United States

I have one more question: is it normal to only have 2 aux-leds lit on the button, when the flashlight is on?

Tom E
Tom E's picture
Offline
Last seen: 59 min 7 sec ago
Joined: 08/19/2012 - 08:23
Posts: 13807
Location: LI NY

Yes - 2 are direct wired to power, 2 are to the MCU I/O pin, so controlled by the MCU.

ToyKeeper
ToyKeeper's picture
Offline
Last seen: 1 day 15 hours ago
Joined: 01/12/2013 - 14:40
Posts: 10623
Location: (469219) 2016 HO3

The two which turn off are connected the same way as the front-facing aux LEDs. It turns those off to avoid color coming out the front while the main white LEDs are on.

mattadores
mattadores's picture
Offline
Last seen: 10 months 2 weeks ago
Joined: 01/21/2019 - 18:45
Posts: 612
Location: Alberta

Hey everyone,

Just got my PL47 from Neals yesterday and so far so good.
-optic has 3 legs cut-off with only the bottom intact – fine by me
-magnet is more than strong enough to securely hold the light – sounds like I got lucky Big Smile
-optic has some defects like bubbles, cuts and seams in the “reflector” or concave surround of the led – nothin that affects the beam
-I’m using a Samung 40T which fits very well and even when I tighten the tailcap as hard as I can the springs/solder do not dent or damage the battery in anyway

Overall very happy!

Questions regarding thermal regulation:
THIS THING GETS HOT! Man does this thing heat up like nothing I’ve ever had before. That being said, I want to know if there’s a way to change the thermal regulation output setting?
-I know how to use the UI to modify the thermal regulation max temp which I’ve set to 50C
-I ran some tests on Turbo and in 1m30s it appears to reach 50C from 26C

Why I want to change the thermal stepdown setting is this:
with my PL47 set to thermal max 50C the light does indeed stepdown at 50C
however, the setting it drops to is still high enough that the light continues heating up dramatically
hit 50C and stepped down after 1m30s BUT even on step down setting reached 63C within 20-30s afterwards before I turned it off

Couple questions:
what temp would actually damage the light?
if I can’t reduce the step down setting, has anyone determined what’s sustainable?
IE: if I set it to 40C would the light eventually begin to stabilize in temp after step down or is this a run on turbo for 1min then turn completely off and let it cool for 4min kind of light?

JoeRodge
Offline
Last seen: 4 months 1 week ago
Joined: 01/04/2018 - 23:13
Posts: 116
Location: United States

Mine didn’t come with the 18650 kit but Neal said he was sending me it. I tried to contact FireFlies over the bad tailcap magnet and I got an error from the form on their website. Does anyone know of a direct support email for Fireflies?

I’m sad, I haven’t even been able to use the light yet ;(

freeme
freeme's picture
Offline
Last seen: 23 min 21 sec ago
Joined: 11/14/2013 - 22:00
Posts: 9142

Fits fine with my Shilhunt band but definitely a front heavy setup. 

©freemex1thedeals.com

Note: PL47 is not designed to be used as a headlamp by default.

Tally-ho
Tally-ho's picture
Offline
Last seen: 1 week 3 days ago
Joined: 07/23/2011 - 04:15
Posts: 1393
Location: France

freeme wrote:
Fits fine with my Shilhunt band but definitely a front heavy setup.

I’ve tried this with the skilhunt H03 headband and I won’t say that the PL47 fits fine because the PL47’s body is too short to fit well with the space between the 2 rubber rings. The rubber part that sits on the forehead is concave instead of being flat or slightly convex.
It works but it’s not a “perfect” fitting.
lionheart_2281
lionheart_2281's picture
Offline
Last seen: 7 hours 29 min ago
Joined: 10/25/2012 - 18:32
Posts: 3088
Location: Brisbane, Australia
Tally-ho wrote:
freeme wrote:
Fits fine with my Shilhunt band but definitely a front heavy setup.
I’ve tried this with the skilhunt H03 headband and I won’t say that the PL47 fits fine because the PL47’s body is too short to fit well with the space between the 2 rubber rings. The rubber part that sits on the forehead is concave instead of being flat or slightly convex. It works but it’s not a “perfect” fitting.

ZL make a headband that fits perfectly (no bend in the rubber whatsoever)

JoeRodge
Offline
Last seen: 4 months 1 week ago
Joined: 01/04/2018 - 23:13
Posts: 116
Location: United States

Man, I am starting to have so many regrets purchasing this light. I bought it from Neal and he never sent me the batteries I ordered (21700 and an 18650), the light never came with the 18650 tube. I’ve been waiting well over a month with no batteries or response to multiple emails. All ignored. I can’t even use it or it cuts out with little movement of my 18650 battery.

I’ve fittled with it a few times, no more than 5 mins, total. Today I grabbed it and only two of the switch LEDs are lit. None of the aux LEDs are on. I’m worried they are dead. When I follow the instructions, I click the appropriate amount of times to change aux LEDs and it changes it from ramping to smooth and vis versa. I’m following the directions and I also own D4S Did I accidently activate an alternate UI?

I feel like I’m losing my mind. Is this PayPal disputable? What are my options? This has been an awful experience….

Edit: I forgot to mention: From the beginning I felt like this light was already returned. When I opened it and the anodizing looked rubbed off from something rubbing on it. In a circular shape around a side. Like a clip or something was there.

BlueSwordM
BlueSwordM's picture
Offline
Last seen: 2 days 16 hours ago
Joined: 11/29/2017 - 12:34
Posts: 5552
Location: Canada

Well, your options to change the aux LEDs are actually very easy.

Click it 7 times when the main LEDs are not on.

You should see the aux LEDs light up along with the other switch LEDs.

Do it again to get the aux LEDs and switch LEDs with intermittent flashing.

Do it again to only use 2 switch LEDs.

My very own high current Beryllium Copper springs Gen 3:
http://budgetlightforum.com/node/67401
Liitokala Aliexpress Stores Battery Fraud: http://budgetlightforum.com/node/60547

JoeRodge
Offline
Last seen: 4 months 1 week ago
Joined: 01/04/2018 - 23:13
Posts: 116
Location: United States

I did bluesword. I am pretty firmiliar with the UI. Nothing happens at all…

The settings just seem out of place and odd.

BlueSwordM
BlueSwordM's picture
Offline
Last seen: 2 days 16 hours ago
Joined: 11/29/2017 - 12:34
Posts: 5552
Location: Canada

Wait, are you in muggle mode?

Click 6 times to see what happens…

My very own high current Beryllium Copper springs Gen 3:
http://budgetlightforum.com/node/67401
Liitokala Aliexpress Stores Battery Fraud: http://budgetlightforum.com/node/60547

JoeRodge
Offline
Last seen: 4 months 1 week ago
Joined: 01/04/2018 - 23:13
Posts: 116
Location: United States

When I click 6 times it cycling ramping and stepped. It seems to be working now though. Not sure what I did. I left the cap off for a few mins and it seems to be working? Maybe my maddening slapping at the button? lol. What is muggle mode? Dumbed down version?

Btw that 24v power supply you recommended came in today and I works GREAT with the TS100. Now to make a little 18650 battery pack to make it portable :).

JoeRodge
Offline
Last seen: 4 months 1 week ago
Joined: 01/04/2018 - 23:13
Posts: 116
Location: United States

It’s doing it again. What is muggle mode? it doing weird stuff, help?

It’s like a dumbed down light. I can’t get it to work right on ramping either.

BlueSwordM
BlueSwordM's picture
Offline
Last seen: 2 days 16 hours ago
Joined: 11/29/2017 - 12:34
Posts: 5552
Location: Canada

Get back to regular modes.

Click 6 times.

My very own high current Beryllium Copper springs Gen 3:
http://budgetlightforum.com/node/67401
Liitokala Aliexpress Stores Battery Fraud: http://budgetlightforum.com/node/60547

ToyKeeper
ToyKeeper's picture
Offline
Last seen: 1 day 15 hours ago
Joined: 01/12/2013 - 14:40
Posts: 10623
Location: (469219) 2016 HO3

JoeRodge wrote:
It’s doing it again. What is muggle mode?

It’s like a dumbed down light.

I think you answered your own question there. Muggle mode is designed so it’ll be safer and simpler for other people to use.

JoeRodge
Offline
Last seen: 4 months 1 week ago
Joined: 01/04/2018 - 23:13
Posts: 116
Location: United States

How do I leave the mode? I hate this light so much I’m so frustrated. Neal finally got the 21700 to me almost two months later and now the light won’t work. If i put it at max it starts to flicker then turns off, aux lights turn off. Then I gotta really tighten the tailcap real hard for it to start “working” again. But it is all intermittent and eventually turns off.

This has been, by far, the worst light and buying experience I’ve had to date. I wouldn’t recommend this light to anyone.

Edit: I can only get it to turn on with the 30Q and adapter he sent me. I can’t get the Samsung 40T he also sent to work at all.

Even after 6 clicks it isn’t right. Something is wrong. So many things are wrong…

dmsoule
Offline
Last seen: 2 hours 47 min ago
Joined: 08/27/2016 - 20:14
Posts: 231
Location: MN USA

Mine had some issues similar to what you described. I followed Madmax’s tip of wrapping a small piece of copper wire into a loop to use as a spacer. He put it in the head of the E07 but inside the tailcap works better for the PL47. The light has worked beautifully ever since. I suspect there was a poor connection in the tailcap combined with the 40T being slightly too long for the battery tube. https://youtu.be/3SWNGoHhBfI

lionheart_2281
lionheart_2281's picture
Offline
Last seen: 7 hours 29 min ago
Joined: 10/25/2012 - 18:32
Posts: 3088
Location: Brisbane, Australia

Massive QC issues, that’s why it’s not being sold anymore, they are working on v2

(1 of my LEDs has died too, even with just 3 it’s still bright as hell)

G.P.
G.P.'s picture
Offline
Last seen: 3 days 2 hours ago
Joined: 11/11/2018 - 12:49
Posts: 96
Location: Canada

lionheart_2281 wrote:
Massive QC issues, that’s why it’s not being sold anymore, they are working on v2

(1 of my LEDs has died too, even with just 3 it’s still bright as hell)


Still showing in stock and for sale on the FF website.

For the record I’m loving mine. Guess I got lucky. I ordered a cheap headband for it off eBay and it’s been amazing for wrenching and fixing things. So much better than the small hotspot on my Zebralight headlamps because I don’t have to keep adjusting it to where I need to see things. I would like to be able to turn down the aux LEDs, but I haven’t found a way to do that.

I think mine may have a glitch where it actually starts to ramp up from zero, because I can’t see any light at all on the lowest setting. I actually like that though. Much better to be able to pick how low I want it versus have it be too bright in moonlight.

lionheart_2281
lionheart_2281's picture
Offline
Last seen: 7 hours 29 min ago
Joined: 10/25/2012 - 18:32
Posts: 3088
Location: Brisbane, Australia

G.P. wrote:
lionheart_2281 wrote:
Massive QC issues, that’s why it’s not being sold anymore, they are working on v2

(1 of my LEDs has died too, even with just 3 it’s still bright as hell)


Still showing in stock and for sale on the FF website.

For the record I’m loving mine. Guess I got lucky. I ordered a cheap headband for it off eBay and it’s been amazing for wrenching and fixing things. So much better than the small hotspot on my Zebralight headlamps because I don’t have to keep adjusting it to where I need to see things. I would like to be able to turn down the aux LEDs, but I haven’t found a way to do that.

I think mine may have a glitch where it actually starts to ramp up from zero, because I can’t see any light at all on the lowest setting. I actually like that though. Much better to be able to pick how low I want it versus have it be too bright in moonlight.

Copy / paste from my email from Jack, read from the bottom up, it’s from an email conversation between us

Jack:
Thanks for your suggestion
yes, we are aware of that. Next batch of PL47 would be much better for sure.

Me:
That’s good, you have a lot to improve upon, quality control would be a good start

Jack:
no . PL47 not available now.
We will make a new improved batch , but at least need to wait 2-3 months.

Me:
Did you sell the PL47 to any other vendors I can buy from? Banggood? Gearbest? Any of them?

Jack:
The black one can not work good. Only champagne color available
So we offered you full refund.
Please check

Me:
Hi Jack,
Your website says you still have black in stock, I want a black replacement. I very much dislike the champagne color.
And please ensure it’s XPL HI 5000K.
If you can’t do all of this I will have a refund. Paypal is this email address.
Kind regards,
Ben

Jack:
Hi Ben
OK, thank you for the fast reply.
PL47 will be discontinued for a long time. We will find a good design to make it better next batch.
Tracking number will be sent to you soon
Thanks
Jack

Pages