Anduril ... 2?

1034 posts / 0 new
Last post
tocirahl
Offline
Last seen: 2 days 7 hours ago
Joined: 10/18/2016 - 13:00
Posts: 114
Location: Austin, TX

jon_slider wrote:
tocirahl wrote:
# Please allow lower moonlight modes in the tint-ramp firmware even if it means losing resolution (i.e. just having one set of LEDs on).
  1. When doing a 4H to exit lockout mode, it would be really nice if it could start ramping up like when you do a 1H from off.

I think your first wish has been granted
lower modes have been enabled,
you need to be able to flash your own firmware

for the second wish
you can set manual memory to the same floor as 1H from off,

that way 4C unlock will come on at floor, and then you can 1H to ramp

Best I can tell, the lowest level in the tint-ramp config is 2/16383; this appears to be this way to allow both channels to be on at the same time with tint ramping as the channels can be split 1/1. I’d love to have a 1/16383 mode as well as a 0/16383 moon mode.

jon_slider
jon_slider's picture
Offline
Last seen: 3 hours 49 min ago
Joined: 09/08/2015 - 12:20
Posts: 5208
Location: Central North America

youre way ahead of me, I got lost at 2/16383

I hope you find a way to get lower lows in your mixing light.

tocirahl
Offline
Last seen: 2 days 7 hours ago
Joined: 10/18/2016 - 13:00
Posts: 114
Location: Austin, TX

By the way I’m having trouble downloading the Anduril 2 code for some reason? I’m getting a HTTP 500 error when trying to download the tarball directly, and an SSL error when using the Bazaar software on Windows…

Does anyone know how to fix this?

EDIT: Another idea would be to be able to set the button backlight brightness independently of the AUX LEDs. I’m seeing them as two separate pins, so I think this should be possible?

Tom E
Tom E's picture
Offline
Last seen: 1 hour 24 min ago
Joined: 08/19/2012 - 08:23
Posts: 14908
Location: LI NY

I get the same HTTP 500 error trying to dnld the tarball too. Maybe she has to post one there? Dunno how bazaar works.

Funtastic
Funtastic's picture
Offline
Last seen: 18 min 2 sec ago
Joined: 06/26/2014 - 02:14
Posts: 2194
Location: New Zealand

I would love it if Simple UI could be changed so that batt check could be configured to use any strobe. This firmware is getting used on heaps of brands and many of my customers find it a pain in the butt for strobe access. Most want the Simple UI with bike flasher, tactical strobe etc. Set it to whatever is needed in the Simple config menu

This shouldn’t be too hard to add

Texas Ace Lumen Tube calibrated with maukka lights

New Zealand store – https://www.piercingthedarkness.co.nz (NZ customers only)

YouTube channel – https://www.youtube.com/channel/UCIUWi2vYp4CWrRkOJM70t_w/videos (Demos for my customers, and reviews)

tactical_grizzly
tactical_grizzly's picture
Online
Last seen: 2 min 38 sec ago
Joined: 11/08/2020 - 14:54
Posts: 133
Location: North Texas

Funtastic wrote:
I would love it if Simple UI could be changed so that batt check could be configured to use any strobe. This firmware is getting used on heaps of brands and many of my customers find it a pain in the butt for strobe access. Most want the Simple UI with bike flasher, tactical strobe etc. Set it to whatever is needed in the Simple config menu

This shouldn’t be too hard to add

That’s an interesting idea. Perhaps the simple UI could memorize the last-used 3C action in the advanced UI? I don’t imagine Simple UI users would be jumping into advanced very often to configure settings, so the likelihood of it being changed back on accident is extremely low.

hinbli
hinbli's picture
Offline
Last seen: 1 day 9 hours ago
Joined: 05/02/2020 - 14:05
Posts: 40
Location: USA

I am getting the error for the tarball download, too.

Getkong
Offline
Last seen: 53 min 31 sec ago
Joined: 09/01/2020 - 22:50
Posts: 16

I created a basic code change to add a step in tint switching for middle of tint-ramp. I find the smooth a little too slow, but wanted to be able to be in the middle easily.

https://github.com/mkong1/anduril/pull/33

If interested, it’d be easy enough to make it a runtime config to have a number of steps, I think.

Getkong
Offline
Last seen: 53 min 31 sec ago
Joined: 09/01/2020 - 22:50
Posts: 16

Getkong wrote:
I created a basic code change to add a step in tint switching for middle of tint-ramp. I find the smooth a little too slow, but wanted to be able to be in the middle easily.

https://github.com/mkong1/anduril/pull/33

If interested, it’d be easy enough to make it a runtime config to have a number of steps, I think.

Updated to instead use 4H instead. Allows using it in smooth ramp, as well as bypassing it in tint switching for lights where it makes less sense (like throw/flood instead of tint).

https://github.com/mkong1/anduril/pull/34

tactical_grizzly
tactical_grizzly's picture
Online
Last seen: 2 min 38 sec ago
Joined: 11/08/2020 - 14:54
Posts: 133
Location: North Texas

Getkong wrote:
Getkong wrote:
I created a basic code change to add a step in tint switching for middle of tint-ramp. I find the smooth a little too slow, but wanted to be able to be in the middle easily.

https://github.com/mkong1/anduril/pull/33

If interested, it’d be easy enough to make it a runtime config to have a number of steps, I think.

Updated to instead use 4H instead. Allows using it in smooth ramp, as well as bypassing it in tint switching for lights where it makes less sense (like throw/flood instead of tint).

https://github.com/mkong1/anduril/pull/34

Does that mean that in your version, 3H does instant-switching and 4H does smooth tint ramping? If so, that is a fantastic idea.

Getkong
Offline
Last seen: 53 min 31 sec ago
Joined: 09/01/2020 - 22:50
Posts: 16

No, 4h just goes to the middle of the tint ramp, whether you’re in smooth or switching mode.

trakcon
trakcon's picture
Offline
Last seen: 22 min 28 sec ago
Joined: 01/23/2019 - 15:50
Posts: 452
Getkong wrote:
No, 4h just goes to the middle of the tint ramp, whether you’re in smooth or switching mode.

I like this a lot.

ftumch33
Online
Last seen: 45 sec ago
Joined: 01/28/2020 - 22:07
Posts: 90
Location: Whitestone, NY

Maybe it`s just me but every light I have (Emisar) that has anduril or anduril 2 is different. Some the secondaries are brighter, some of the color combinations of the secondaries are different (I`ve never been able to get yellow out of any of them).
One of them has the ramp up of secondaries as 2 different settings.
Would I be able to flash my Emisars from a Mac with the flashing cable?

Pages