Anduril ... 2?

1308 posts / 0 new
Last post
Nachtfeuerzeug
Nachtfeuerzeug's picture
Offline
Last seen: 18 hours 29 min ago
Joined: 08/31/2013 - 16:10
Posts: 876

Is there a en Español UI guide out there for Anduril 2?

Lumaine Moore
Lumaine Moore's picture
Offline
Last seen: 9 hours 14 min ago
Joined: 08/28/2022 - 11:50
Posts: 79
Location: Dhaka

Does lighted switches (sc21 pro, sc31 pro) on Anduril lights turn red on low voltage?

jon_slider
jon_slider's picture
Offline
Last seen: 1 hour 11 min ago
Joined: 09/08/2015 - 12:20
Posts: 6887
Location: Central North America

Lumaine Moore wrote:
Does lighted switches (sc21 pro, sc31 pro) on Anduril lights turn red on low voltage?
No.

The lights will step down, and ultimately will turn off completely due to LVP built into Anduril. But I do not recommend waiting for the LVP to turn the light off.

I make a habit of checking voltage w 3C from off, and I recharge any time the battery goes below 3.6V.

bobvoeh
bobvoeh's picture
Offline
Last seen: 12 hours 48 min ago
Joined: 09/21/2021 - 23:29
Posts: 540
Location: Florida, United States
KevinZA1988 wrote:
SammysHP wrote:
Before you update your flashlight, make a backup of the original firmware. Also what does version check (15C) say?

According to this source upgrading from Anduril doesn’t require a version check. You just need to flash the correct firmware for the type of driver: https://ivanthinking.net/thoughts/emisar-d4v2-anduril2-hex-file-selection/

And that’s my main concern. Is the Anduril 2 firmware on TK’s site compatible with FET+1 drivers?

Upgrading to Anduril 2 does not “require” a version check, but since you are asking for which HEX file to download and update to your light, doing a version check and posting your results here would tell us exactly what you currently have installed so you can get the right answer of what to download. Savy?

Lumaine Moore
Lumaine Moore's picture
Offline
Last seen: 9 hours 14 min ago
Joined: 08/28/2022 - 11:50
Posts: 79
Location: Dhaka

jon_slider wrote:
Lumaine Moore wrote:
Does lighted switches (sc21 pro, sc31 pro) on Anduril lights turn red on low voltage?
No.

The lights will step down, and ultimately will turn off completely due to LVP built into Anduril. But I do not recommend waiting for the LVP to turn the light off.

I make a habit of checking voltage w 3C from off, and I recharge any time the battery goes below 3.6V.

Thanks for letting me know. For some weird reason, I was under the impression that the light would go red before LVP cutoff. But it just stepped down like you mentioned.

The red light warning would be a nice feature to have, as the red LED already exists. I guess it is hard wired only to the charging circuit.

jasontheguitarist
Offline
Last seen: 17 hours 14 min ago
Joined: 02/25/2019 - 11:45
Posts: 530
Location: South Carolina
Quadrupel wrote:
If Nichia so flash Nichia.

The special 219 version limits turbo so the emitters don’t fry, but the newer Nichia 519A should be fine to handle the normal firmware.

Quadrupel
Quadrupel's picture
Offline
Last seen: 2 hours 44 min ago
Joined: 12/03/2017 - 10:40
Posts: 1206
Location: Lithuania
jasontheguitarist wrote:
Quadrupel wrote:
If Nichia so flash Nichia.

The special 219 version limits turbo so the emitters don’t fry, but the newer Nichia 519A should be fine to handle the normal firmware.

Found it written on the wall? ;)) And 519 and 219 have the same 2.4A Pulse Forward Current.

stephenk
stephenk's picture
Offline
Last seen: 1 hour 47 min ago
Joined: 01/30/2016 - 05:09
Posts: 2405
Location: Australia

This might be a silly question, but which version of Anduril 2 does the KR4 W2 with Boost driver use?

thefreeman
thefreeman's picture
Online
Last seen: 6 min 29 sec ago
Joined: 01/06/2020 - 09:56
Posts: 1810
Location: France

noctigon-kr4-12v I suppose.

Limsup
Limsup's picture
Offline
Last seen: 5 hours 3 min ago
Joined: 02/23/2020 - 23:57
Posts: 158

I installed “anduril.2022-10-21.noctigon-kr4-nofet.hex” on my KR4 with Nichia E21A leds and I noticed something weird when RGB aux leds are configured to display voltage.

The issue is that RGB leds change colors or turns off every 8 seconds on both high or low output mode. (If I set the output to blink, then it does not have the problem.)
Case 1. on 3.9V cell, the light displays blue and 8 seconds later it turns off. Another 8s later, it displays blue. It continues.
Case 2. on 4.1V cell, it displays pink, 8s later blue, 8s later off, 8s later back to pink and goes on.
Case 3. on 3.8V cell, it display cyan. It does not change colors. The leds are constantly on.
Case 4. on 3.1V cell, it displays red. Same thing as Case 3.

I had similar issue with D1v2 on RGB switch leds changing colors every 8 seconds in some voltage levels. On my D1v2 with 4.1V battery, the RGB switch leds display pink and green every 8 seconds.

Is this a bug? Does 8 seconds mean something? Is this done intentionally perhaps to save battery? Do RGB leds switch colors only for high voltage range above 3.9V?

If I configure the RGB leds to display a single color then it does not turn off or change colors. So, I think it has to do with how voltage is displayed.

My D4V2 with “anduril.2021-12-13.emisar-d4v2-219.hex” does not have this problem.

thefreeman
thefreeman's picture
Online
Last seen: 6 min 29 sec ago
Joined: 01/06/2020 - 09:56
Posts: 1810
Location: France

This problem as been reported a few times yeah, at first I thought it was a T1616 specific issue since it’s very common on my drivers and I didn’t see other reports, but since then there are reports of this issue on other drivers so I guess it’s because this bug appeared in a somewhat recent revision

Limsup
Limsup's picture
Offline
Last seen: 5 hours 3 min ago
Joined: 02/23/2020 - 23:57
Posts: 158

Thank you for confirming the issue. I did additional tests with my KR4 and it seems that switching colors only happens when voltage is above 3.8V. I will see if using last year’s firmware helps.

thefreeman
thefreeman's picture
Online
Last seen: 6 min 29 sec ago
Joined: 01/06/2020 - 09:56
Posts: 1810
Location: France
Limsup wrote:
I did additional tests with my KR4 and it seems that switching colors only happens when voltage is above 3.8V

It varies between drivers, like switching between orange and white (RGB all ON), red and off, constant red after display the right color… etc, it’s quite random.

stephenk
stephenk's picture
Offline
Last seen: 1 hour 47 min ago
Joined: 01/30/2016 - 05:09
Posts: 2405
Location: Australia

thefreeman wrote:
noctigon-kr4-12v I suppose.

Ah, yes, that would make sense. Thanks!
jasontheguitarist
Offline
Last seen: 17 hours 14 min ago
Joined: 02/25/2019 - 11:45
Posts: 530
Location: South Carolina
Quadrupel wrote:
jasontheguitarist wrote:
Quadrupel wrote:
If Nichia so flash Nichia.

The special 219 version limits turbo so the emitters don’t fry, but the newer Nichia 519A should be fine to handle the normal firmware.

Found it written on the wall? ;)) And 519 and 219 have the same 2.4A Pulse Forward Current.

I admit I don’t have the level of understanding some of you guys do. I just know from the tests I’ve seen here that the 519A can handle 6 amps. So it seems 3 or 4 of them could be FET driven in parallel without too much worry. I guess a really high drain cell could be too much, but I was thinking a 10A or 15A cell.

I see the light in question was the D4SV2, for some reason I guess I was thinking of the normal D4V2 with an 18650 rather than the 26650.

Limsup
Limsup's picture
Offline
Last seen: 5 hours 3 min ago
Joined: 02/23/2020 - 23:57
Posts: 158

I reflashed using “anduril.2021-12-13.noctigon-kr4-nofet.hex”, but the problem of “switching RGB aux leds in voltage mode” is still there. However, I noticed an interesting behavior during the process.

The RGB leds begins to switch when I set hybrid memory. Using automatic memory (10H>Item1>click) or manual memory (10H>Item2>No click) will not make the rgb leds to switch every 8 seconds.

Tulpenzeit
Tulpenzeit's picture
Online
Last seen: 3 min 6 sec ago
Joined: 11/08/2022 - 02:44
Posts: 6
Location: Germany

I have the same aux LED blinking phenomenon with a Noctigon K1. Aux LEDs keep switching on and off about every 7.5 seconds ongoingly – only when the flashlight is OFF, and only when aux LEDs are in “constantly on” mode (not when blinking) – and only when aux LEDs are in voltage mode. I have this blinking only if manual memory is active. In automatic memory mode the blinking does not occur. Did not check Hybrid memory mode.

EDIT – the light is new, I have had it for a few days only. Hank shipped it in January 2023, with a 2021 hex. I updated it to anduril.2022-10-21.noctigon-k1-sbt90.hex. Not sure whether the effect happened with the older hex as well. Could check that as I saved the original hex file.

Pages