[Review] NOCTIGON K9.3 by Hank Wang

74 posts / 0 new
Last post

Pages

The_Flashaholic
The_Flashaholic's picture
Offline
Last seen: 6 hours 22 min ago
Joined: 04/05/2017 - 12:46
Posts: 1217
Location: Wakefield
[Review] NOCTIGON K9.3 by Hank Wang

I was fearing ANDURIL II would be ghastly but this version was really good. Mode memory and thermal calibration is now a bit harder to master but an epic Sunset mode and momentary turbo make up for that.

My 4K Lumen Whore Reviews (MS18, X70, MS12, DX80, X80-GT, X45vn etc) - http://www.youtube.com/c/FLASHAHOLIC_TV

zoulas
zoulas's picture
Offline
Last seen: 7 hours 5 min ago
Joined: 06/01/2020 - 08:35
Posts: 1951

Very Cool, thank you

lazerEagle
lazerEagle's picture
Offline
Last seen: 29 min 44 sec ago
Joined: 05/20/2020 - 21:11
Posts: 229
Location: Australia

Good review. Looks like a real performer! Didn’t catch what button colour you went with was that warm white or amber?

- the best way to predict the future is to create it -

MoreLumens
MoreLumens's picture
Offline
Last seen: 8 hours 58 min ago
Joined: 10/25/2019 - 07:08
Posts: 1657
Location: Finland

Nice review. I somehow thought that K9.3 was much bigger than that, but its actually quite compact. Really loving how flashlights keep evolving.

WindyCity
WindyCity's picture
Offline
Last seen: 5 months 1 week ago
Joined: 02/15/2020 - 16:37
Posts: 55
Location: Windy City

Such a cool review and such a nice light! Going to be a tough choice to get the right LED choice. Thanks for yet another enjoy-full review

The_Flashaholic
The_Flashaholic's picture
Offline
Last seen: 6 hours 22 min ago
Joined: 04/05/2017 - 12:46
Posts: 1217
Location: Wakefield
lazerEagle wrote:
Good review. Looks like a real performer! Didn’t catch what button colour you went with was that warm white or amber?

Amber! I like how the yellow RGB colour is more amber too

My 4K Lumen Whore Reviews (MS18, X70, MS12, DX80, X80-GT, X45vn etc) - http://www.youtube.com/c/FLASHAHOLIC_TV

The_Flashaholic
The_Flashaholic's picture
Offline
Last seen: 6 hours 22 min ago
Joined: 04/05/2017 - 12:46
Posts: 1217
Location: Wakefield
WindyCity wrote:
Such a cool review and such a nice light! Going to be a tough choice to get the right LED choice. Thanks for yet another enjoy-full review

Took me a week to decide lol

My 4K Lumen Whore Reviews (MS18, X70, MS12, DX80, X80-GT, X45vn etc) - http://www.youtube.com/c/FLASHAHOLIC_TV

Boro
Offline
Last seen: 15 hours 25 sec ago
Joined: 02/03/2012 - 15:52
Posts: 724

A wonderfully well done and informative review;
thank you for the hard work!

Pavlo
Offline
Last seen: 11 hours 44 min ago
Joined: 12/13/2015 - 10:37
Posts: 955
Location: Canada

I love how much more saturated nature becomes with the SST20. Thanks for the review.

Lux-Perpetua
Lux-Perpetua's picture
Offline
Last seen: 9 hours 51 min ago
Joined: 03/01/2018 - 04:39
Posts: 3196

Flashoholic, can you please check if your K9.3 has the same software bug that mine has?

https://budgetlightforum.com/comment/1736594#comment-1736594

 

In order to test, please do the following:

1. From OFF, 4C to lock the light

2. In Lockout mode, 7C until you get to the Blink/Beacon AUX mode 

3. Select any from the fixed colors (red or yellow or green...) via 7H 

 

Expected behavior:

Beacon keeps blinking indefinitely until stopped by 4C. 1C or 1H should only temporarily activate Moon/Low mode until you release the button.

Actual behaviour:

Beacon blinks in a random duration (sometimes only 3x, sometimes more) and then stops. When it stopped blinking the Lockout mode is left and the flashlight will be turned on via 1C.

 

I made a video of the faulty AUX mode:

Thank you for testing! 

 

The_Flashaholic
The_Flashaholic's picture
Offline
Last seen: 6 hours 22 min ago
Joined: 04/05/2017 - 12:46
Posts: 1217
Location: Wakefield
Lux-Perpetua wrote:

Flashoholic, can you please check if your K9.3 has the same software bug that mine has?


https://budgetlightforum.com/comment/1736594#comment-1736594


 


In order to test, please do the following:


1. From OFF, 4C to lock the light


2. In Lockout mode, 7C until you get to the Blink/Beacon AUX mode 


3. Select any from the fixed colors (red or yellow or green…) via 7H 


 


Expected behavior:


Beacon keeps blinking indefinitely until stopped by 4C. 1C or 1H should only temporarily activate Moon/Low mode until you release the button.


Actual behaviour:


Beacon blinks in a random duration (sometimes only 3x, sometimes more) and then stops. When it stopped blinking the Lockout mode is left and the flashlight will be turned on via 1C.


 


I made a video of the faulty AUX mode:



Thank you for testing! 


 

Yes mine has the bug too Sad

My 4K Lumen Whore Reviews (MS18, X70, MS12, DX80, X80-GT, X45vn etc) - http://www.youtube.com/c/FLASHAHOLIC_TV

Lux-Perpetua
Lux-Perpetua's picture
Offline
Last seen: 9 hours 51 min ago
Joined: 03/01/2018 - 04:39
Posts: 3196

I guess this bug will eventually be fixed with the next update for Andúril 2, so you can flash a new hex file onto the driver. I hope your K9.3 has less imperfections than mine. I am somehow disappointed with the quality control, which is rather unusual for lights from Hank.

Marc E
Offline
Last seen: 1 week 8 hours ago
Joined: 05/18/2013 - 08:14
Posts: 533
Location: South West UK

Hey, this wasn’t a review by Hank Wang, this was a review by you! I want my money back… Big Smile

Excellent review as always, even with the sound down in an impatient mood i end up watching your vids all the way through. Good delivery!

And just to show i pay attention (and nothing to do with an uneccessarily over-developed need to get as many ducks in a row as possible), at 4:31 you list the measured throw for channel 1, and at 5:22 the throw for channel 2, and they’re the same! I’m assuming that’s not the case?

And also (sorry), at Vanhalla the FW21 pro (test at 10:23) is of similar brightness to the other lights as is easy to see in the comparison photo at 11:20 but in the midrange test that follows at the school
the FW21 Pro (test at 11:50) is noticebly dimmer as evidenced in the comparison photo at 12:48. Was that just a high/turbo mode mix-up?

The_Flashaholic
The_Flashaholic's picture
Offline
Last seen: 6 hours 22 min ago
Joined: 04/05/2017 - 12:46
Posts: 1217
Location: Wakefield

Marc E wrote:
Hey, this wasn’t a review by Hank Wang, this was a review by you! I want my money back… Big Smile

Excellent review as always, even with the sound down in an impatient mood i end up watching your vids all the way through. Good delivery!

And just to show i pay attention (and nothing to do with an uneccessarily over-developed need to get as many ducks in a row as possible), at 4:31 you list the measured throw for channel 1, and at 5:22 the throw for channel 2, and they’re the same! I’m assuming that’s not the case?

And also (sorry), at Vanhalla the FW21 pro (test at 10:23) is of similar brightness to the other lights as is easy to see in the comparison photo at 11:20 but in the midrange test that follows at the school
the FW21 Pro (test at 11:50) is noticebly dimmer as evidenced in the comparison photo at 12:48. Was that just a high/turbo mode mix-up?

Throw for CH2 was around 180m and the switch plays up on all my FW lights.

My 4K Lumen Whore Reviews (MS18, X70, MS12, DX80, X80-GT, X45vn etc) - http://www.youtube.com/c/FLASHAHOLIC_TV

will34
will34's picture
Offline
Last seen: 1 hour 36 min ago
Joined: 12/18/2012 - 00:12
Posts: 4091

Nice review, it is surprisingly throwy!

puglife2
puglife2's picture
Offline
Last seen: 3 hours 41 min ago
Joined: 10/07/2017 - 17:56
Posts: 401

My K9.3 is still not delivered Crying Flat Stare

jp9mm
Offline
Last seen: 4 months 3 weeks ago
Joined: 03/30/2020 - 12:14
Posts: 518
Lux-Perpetua wrote:

I guess this bug will eventually be fixed with the next update for Andúril 2, so you can flash a new hex file onto the driver. I hope your K9.3 has less imperfections than mine. I am somehow disappointed with the quality control, which is rather unusual for lights from Hank.

Damn, would of thought someone would test aux led functionality before shipping these.

For most of you guys with flashing devices probably not a big deal but this is an expensive light to have to buy something to fix it.

Lux-Perpetua
Lux-Perpetua's picture
Offline
Last seen: 9 hours 51 min ago
Joined: 03/01/2018 - 04:39
Posts: 3196

puglife2 wrote:
My K9.3 is still not delivered Crying :|

 

While my first K9.3 arrived in a blink of an eye, the second one seems to be going back and forth in Shanghai for two days now. Facepalm I wonder what’s going on over there. FedEx still expects it to be delivered in Germany on January 21...yeah, sure.  Party 

2021-01-21 05:27, SHANGHAI CN, In transit
2021-01-21 04:40, SHANGHAI CN, In transit
2021-01-21 04:03, SHANGHAI CN, In transit
2021-01-21 04:02, SHANGHAI CN, International shipment release - Export
2021-01-20 23:00, SHANGHAI CN, At local FedEx facility
2021-01-20 23:00, SHANGHAI CN, In transit
2021-01-20 04:06, SHANGHAI CN, At local FedEx facility
2021-01-20 04:06, SHANGHAI CN, In transit
2021-01-19 23:00, SHANGHAI CN, At local FedEx facility
2021-01-19 23:00, SHANGHAI CN, In transit
2021-01-19 03:31, SHANGHAI CN, At local FedEx facility
2021-01-19 03:31, SHANGHAI CN, In transit
2021-01-19 00:58, SHANGHAI CN, International shipment release - Export
2021-01-18 20:55, SHANGHAI CN, Left FedEx origin facility
2021-01-18 15:36, SHANGHAI CN, Picked up
2021-01-18 00:30, Shipment information sent to FedEx

 

jp9mm wrote:
Damn, would of thought someone would test aux led functionality before shipping these. For most of you guys with flashing devices probably not a big deal but this is an expensive light to have to buy something to fix it.

Well, I agree it’s a bit annoying to deal with software bugs. At least these can be fixed by using a flashing kit and an Android smartphone. Maybe Hank can offer his flashing kit for a reduced price to those who purchased the first batch of K9.3 (like he did with the more dangerous muggle mode software bug in the first batch of D4v2).

I am more disappointed by the mediocre workmanship (notches, scratches) of my K9.3. I did not expect this to happen with a $ 145 light.

Frostcream
Offline
Last seen: 2 weeks 37 min ago
Joined: 05/26/2020 - 16:26
Posts: 126

Lux-Perpetua wrote:
I am more disappointed by the mediocre workmanship (notches, scratches) of my K9.3. I did not expect this to happen with a $ 145 light.
Not an excuse, but I think Hank’s company is exhausted and overtaxed. It’s difficult to be as careful and ensure top quality when your working frantically to meet demand.

I hope they get a handle on it soon, or the business will dry up as quickly as it came.

The_Flashaholic
The_Flashaholic's picture
Offline
Last seen: 6 hours 22 min ago
Joined: 04/05/2017 - 12:46
Posts: 1217
Location: Wakefield

I must admit the anodisation is to the usual flaky Noctigon standard lol

My 4K Lumen Whore Reviews (MS18, X70, MS12, DX80, X80-GT, X45vn etc) - http://www.youtube.com/c/FLASHAHOLIC_TV

zoulas
zoulas's picture
Offline
Last seen: 7 hours 5 min ago
Joined: 06/01/2020 - 08:35
Posts: 1951

Wow,interesting

Mark M
Mark M's picture
Offline
Last seen: 13 hours 44 min ago
Joined: 06/28/2018 - 04:55
Posts: 499

Frostcream wrote:
Lux-Perpetua wrote:
I am more disappointed by the mediocre workmanship (notches, scratches) of my K9.3. I did not expect this to happen with a $ 145 light.
Not an excuse, but I think Hank’s company is exhausted and overtaxed. It’s difficult to be as careful and ensure top quality when your working frantically to meet demand.

I hope they get a handle on it soon, or the business will dry up as quickly as it came.

I have a feeling he is in this weird growth spot where he really needs more labor, but you have to train your unskilled workforce and it means quality missteps and takes time, but I have no doubt Hank will regain tight QC.
Frostcream
Offline
Last seen: 2 weeks 37 min ago
Joined: 05/26/2020 - 16:26
Posts: 126

Yeah, that’s my impression too. That’s why I’ll look the other way for now.

Also, I did just receive another immaculately flawless D18 yesterday, so it’s not all doom and gloom.

Mark M
Mark M's picture
Offline
Last seen: 13 hours 44 min ago
Joined: 06/28/2018 - 04:55
Posts: 499

Frostcream wrote:
Yeah, that’s my impression too. That’s why I’ll look the other way for now.

Also, I did just receive another immaculately flawless D18 yesterday, so it’s not all doom and gloom.

No noticeable flaws on the 5-6 lights I have bought recently, except maybe a switch boot that is deformed, but I have extras.

Frostcream
Offline
Last seen: 2 weeks 37 min ago
Joined: 05/26/2020 - 16:26
Posts: 126

Wow, per order numbers, Hank’s current workload is an average of about 70 orders a day. Presumably most of them are lights, not parts. That’s quite the workload.

Mark M
Mark M's picture
Offline
Last seen: 13 hours 44 min ago
Joined: 06/28/2018 - 04:55
Posts: 499
Frostcream wrote:
Wow, per order numbers, Hank’s current workload is an average of about 70 orders a day. Presumably most of them are lights, not parts. That’s quite the workload.

Pretty impressive, that is a ton of revenue generation.

ToyKeeper
ToyKeeper's picture
Offline
Last seen: 1 hour 35 min ago
Joined: 01/12/2013 - 14:40
Posts: 10761
Location: (469219) 2016 HO3

Lux-Perpetua wrote:
can you please check if your K9.3 has the same software bug that mine has?

In order to test, please do the following:
1. From OFF, 4C to lock the light
2. In Lockout mode, 7C until you get to the Blink/Beacon AUX mode
3. Select any from the fixed colors (red or yellow or green…) via 7H

Expected behavior:
Beacon keeps blinking indefinitely until stopped by 4C. 1C or 1H should only temporarily activate Moon/Low mode until you release the button.

Actual behaviour:
Beacon blinks in a random duration (sometimes only 3x, sometimes more) and then stops. When it stopped blinking the Lockout mode is left and the flashlight will be turned on via 1C.

Hank sent me a message about this, so I investigated and fixed it. Weirdest bug I’ve seen in Anduril so far. Still not sure what exactly causes it, but it acts like a compiler bug or something. If I simply add some extra no-op instructions in the affected code path, the issue goes away.

It’s weird because it only affects the K9.3, even though the lockout and aux LED code is exactly the same on a bunch of other lights. Also weird because it goes directly from lockout to “off”, and there is no code path which does that any more. So that would suggest it’s rebooting, but it doesn’t do the boot-up blink. Also weird because a steady color works fine in the low or high modes, and every pattern (including blinking) works fine in disco / rainbow / voltage modes, but a single color blinking fails.

Updated builds:

I doubt it’s a compiler bug, since those are very rare in practice. I probably did something wrong… but I haven’t been able to figure out what. So I hope to give it a more proper fix if I can confirm what’s causing it. Would be helpful to build it pre-fix on other platforms, to check if the compiler version is relevant. The buggy version was built with gcc-avr 1:5.4.0+Atmel3.6.1-2 from Debian.

Also, code for the K9.3 is now available in the anduril2 branch.

just
Offline
Last seen: 2 months 3 days ago
Joined: 10/30/2019 - 08:26
Posts: 13

am i right that the 2020-12-13 firmware version is affected by the “aux led single color blinking lockout bug”?

ToyKeeper
ToyKeeper's picture
Offline
Last seen: 1 hour 35 min ago
Joined: 01/12/2013 - 14:40
Posts: 10761
Location: (469219) 2016 HO3
just wrote:
am i right that the 2020-12-13 firmware version is affected by the “aux led single color blinking lockout bug”?

Yes, the issue wasn’t known or fixed until 2021-01.

ftumch33
Offline
Last seen: 4 hours 15 min ago
Joined: 01/28/2020 - 22:07
Posts: 72
Location: Whitestone, NY

I dunno, I received the Fireflies E12R a few days ago and I have nothing but troubles with the UI.
For some reason it seems to keep reverting back to the simple UI, switches back to stepped ramping, and the secondaries (even on low) are dimmer than the Emisar D4V2 I have (not sure if that`s because of the light or the UI though).
I wish there was a way to lock in the advanced UI to stop it from switching back to the Simple UI.
Gonna give it a few days just in case it`s my sausage fingers that`s causing the problem.

ToyKeeper
ToyKeeper's picture
Offline
Last seen: 1 hour 35 min ago
Joined: 01/12/2013 - 14:40
Posts: 10761
Location: (469219) 2016 HO3
ftumch33 wrote:
I received the Fireflies E12R a few days ago and I have nothing but trouble …

Fireflies has a new light? Interesting. I don’t know what they did with the code, since it doesn’t appear to be available. I suppose I’ll have to bug them about license compliance again. Sad

Pages