Help Lexel driver stuck in DD

11 posts / 0 new
Last post
pinkpanda3310
pinkpanda3310's picture
Offline
Last seen: 4 hours 3 min ago
Joined: 12/28/2013 - 08:45
Posts: 2827
Location: Perth
Help Lexel driver stuck in DD

Before testing the driver i had a couple goes at soldering on a bleeder for a lighted tail. I then discovered the single mode issue. I couldn’t enter config mode. I tried removing the bleeder, powering the driver without the lighted tail, powering the driver outside the pill all to no avail. Stuck in DD. Any suggestions on what might be wrong?

 

MascaratumB
MascaratumB's picture
Offline
Last seen: 38 min 23 sec ago
Joined: 10/29/2016 - 12:12
Posts: 6356
Location: Portugal

I’ve damaged some drivers (early versions of these, double sided) due to the solder connections too.
I am not sure if it is it, in this case, but could it be that solder connection between the outer ring and the big chip legs (at 9h48 direction)?
I’m no expert on this, so ignore if not useful or wrong Big Smile Facepalm

pinkpanda3310
pinkpanda3310's picture
Offline
Last seen: 4 hours 3 min ago
Joined: 12/28/2013 - 08:45
Posts: 2827
Location: Perth

Thanks MascaratumB. I should mention the driver pictured is a spare so everyone knows what driver I’m talking about.

So it’s not that big of a deal if I can’t fix it but 1 I don’t like breaking brand new things and 2 I want to prevent breaking the next one.

 

MascaratumB
MascaratumB's picture
Offline
Last seen: 38 min 23 sec ago
Joined: 10/29/2016 - 12:12
Posts: 6356
Location: Portugal

pinkpanda3310 wrote:
Thanks MascaratumB. I should mention the driver pictured is a spare so everyone knows what driver I’m talking about.

So it’s not that big of a deal if I can’t fix it but 1 I don’t like breaking brand new things and 2 I want to prevent breaking the next one.

Oh…in that case, I assume that “connection” is, let’s say, stock Big Smile
I only got one of those drivers, installed, so I can’t check anything else to give an hint…

When you say you’re stuck in DD, you mean like you only have 1 mode equivalent to Turbo/highest?
Could it be something that heated up and got damaged internally when you soldered the bleeder?

Oops

pinkpanda3310
pinkpanda3310's picture
Offline
Last seen: 4 hours 3 min ago
Joined: 12/28/2013 - 08:45
Posts: 2827
Location: Perth

Highly possible given my skills with a Soldering iron Facepalm

Hooking up the electronics is easily the most hated part of making a new light Sick

 

thefreeman
thefreeman's picture
Offline
Last seen: 34 min 43 sec ago
Joined: 01/06/2020 - 09:56
Posts: 502
Location: France

It’s difficult to see due to the low resolution but R4 seems to be connected to the gate to the mosfet and to the + hole.

On lexel pictures R4 looks to be the gate resistor, connected between the gate and the MCU. If it’s connected to + the mosfet will be always on.

pinkpanda3310
pinkpanda3310's picture
Offline
Last seen: 4 hours 3 min ago
Joined: 12/28/2013 - 08:45
Posts: 2827
Location: Perth

Well I swapped out the driver for the spare. That one also give me the run abouts acting strange. After numerous attempts I got it working and came to the conclusion that the driver space was too tight and it was shorting out somehow. I guess that’s what happened to the first driver Facepalm

 

MascaratumB
MascaratumB's picture
Offline
Last seen: 38 min 23 sec ago
Joined: 10/29/2016 - 12:12
Posts: 6356
Location: Portugal

pinkpanda3310 wrote:
Well I swapped out the driver for the spare. That one also give me the run abouts acting strange. After numerous attempts I got it working and came to the conclusion that the driver space was too tight and it was shorting out somehow. I guess that’s what happened to the first driver Facepalm

But did you make it/them work correctly now? Hope so Wink Damaging drivers is always a PITA Tired
pinkpanda3310
pinkpanda3310's picture
Offline
Last seen: 4 hours 3 min ago
Joined: 12/28/2013 - 08:45
Posts: 2827
Location: Perth

Yes I got the light engine too function properly in the host with the lighted tail Innocent

 

MascaratumB
MascaratumB's picture
Offline
Last seen: 38 min 23 sec ago
Joined: 10/29/2016 - 12:12
Posts: 6356
Location: Portugal

Sweet Wink Glad you made it Cool

pinkpanda3310
pinkpanda3310's picture
Offline
Last seen: 4 hours 3 min ago
Joined: 12/28/2013 - 08:45
Posts: 2827
Location: Perth

Still got some stuff to do over the weekend to finish the build but here’s a teaser