New flashlight selecting modes randomly

4 posts / 0 new
Last post
Berkua
Offline
Last seen: 2 months 4 weeks ago
Joined: 10/10/2021 - 21:11
Posts: 24
New flashlight selecting modes randomly

Hello, I just built my first flashlight. It is a Convoy S2+ with the QLITE REV.A 7135*8 3.04A LED driver- flashed with guppydrv and Samsung LH351D 4000K 90+ CRI.

My soldering isn’t great, but the flashlight is working as expected and I am pleased with my first go at this.

However, occasionally … and I’m talking one out of every (maybe) 20 times I turn the flashlight on, it will turn on at a higher mode. I have the flashlight driver set to no memory with 5 steps of brightness, starting with ML. Most times, the flashlight will turn on at ML mode, which is correct. Sometimes, the flashlight will turn on and it’ll be on level 3 or even the highest level. I don’t know if it is a problem with the tail switch or the driver, or even my soldering.

One thought I had was that when I switch the light on, it is registering multiple simultaneous half clicks or something weird like that.

Also, sometimes when I am half clicking to switch modes, it’ll do like two or three really fast.

Please let me know if this is just the way these reverse clicky tail switches are, or if there’s a defect or something I should look into.

I am happy to answer any questions.

Thanks!

jasontheguitarist
Offline
Last seen: 8 hours 33 min ago
Joined: 02/25/2019 - 11:45
Posts: 421
Location: South Carolina

Check that the retaining ring holding the switch in place in the tail cap is tightened all the way. It’s reverse threaded, so turn it the opposite way than usual to tighten it. It’s the easiest first step to try.

Since you used a 7135×8 driver I assume you soldered it to the pill, so there’s no ring to tighten there.

Berkua
Offline
Last seen: 2 months 4 weeks ago
Joined: 10/10/2021 - 21:11
Posts: 24

jasontheguitarist wrote:
Check that the retaining ring holding the switch in place in the tail cap is tightened all the way. It’s reverse threaded, so turn it the opposite way than usual to tighten it. It’s the easiest first step to try.

Since you used a 7135×8 driver I assume you soldered it to the pill, so there’s no ring to tighten there.

I can’t make the retaining ring in the tail cap budge one way or the other. It almost seems jammed.

Berkua
Offline
Last seen: 2 months 4 weeks ago
Joined: 10/10/2021 - 21:11
Posts: 24

So, I was just playing around with the flashlight a bit … I actually just thing the tail switch is ULTRA sensitive and is possibly registering multiple half clicks right after I turn it on. Kind of annoying, but might not be an actual glitch.

Let me know if anyone else is having the same experiences.

Thanks!