Convoy S2+ CSLNM1.TG mod

4 posts / 0 new
Last post
SMOKEU
Offline
Last seen: 9 hours 43 min ago
Joined: 03/29/2022 - 04:19
Posts: 28
Location: New Zealand
Convoy S2+ CSLNM1.TG mod

I bought a stock S2+ with an SST20 and want to mod it to a CSLNM1. The problem I keep having is there is a gap between the glass and inner bezel. If I shake the light even gently it is quite apparent. The gap appears to be around 1mm. I have tried using 2 orings between the bezel and the glass but then got some strange artifacting in the beam. I have a few different parts laying around that I can hopefully make it work but not sure what to do.

https://drive.google.com/drive/folders/1wYZ3dw61kZsgpFfPrrikV1SCTkRbMF2c...

chops728
Online
Last seen: 8 min 25 sec ago
Joined: 08/30/2014 - 16:00
Posts: 1884
Location: Swampland,La

That’s weird the pill doesn’t just tighten to the lens —- try putting 2 lens (glass)

Firelight2
Firelight2's picture
Offline
Last seen: 48 min 10 sec ago
Joined: 04/08/2011 - 15:17
Posts: 4978
Location: California

Are you using a different star for the Oslon emitter? and if so is it thinner than the original?

Try to see if you can screw the pill in further. If so that should fix the problem. However, if the pill was already screwed in the maximum possible, any of the following three fixes should do it:

  • Replace bezel o-ring with a thicker one; or
  • Cut a piece of sheet copper into a disk with some tin snips. Place the disk between the star and the pill. This lifts the star up slightly and should fix the problem. Make sure the disk is completely flat before installation and apply thermal compound on both sides of the disk; or
  • Desolder and remove the star, then use a handfile to file off the top few mm of the threads on the pill. It is those threads hitting the unthreaded area of the head that prevent the pill from screwing in enough to tighten against the lens. If you file off the topmost threads the pill should be able to screw in further, solving the problem.
SMOKEU
Offline
Last seen: 9 hours 43 min ago
Joined: 03/29/2022 - 04:19
Posts: 28
Location: New Zealand

Thanks for the advice everyone, I solved the problem by filing down the top of the pill so now it screws in fully. It now looks great.

I bought the emitter already soldered onto the MCPCB directly from Simon.