[Review] -Wurkkos TS21 219C 5000k- By Argo

35 posts / 0 new
Last post
pennzy
pennzy's picture
Offline
Last seen: 5 hours 33 min ago
Joined: 12/10/2017 - 19:45
Posts: 4496
Location: United States , Pa.

KnotSoMuch wrote:

pennzy wrote:
My two both have issues other than parasitic drain. I have posted about it months ago and have yet to see any fixes. Never formally complained but enough people have posted and no fixes have been offered voluntarily.

Such as…? 

The switch button LED turning Blue without a confirmed reason from Wurkkos as to why it does that…sure, I concede. In fact, since I may have been one of the very first to receive the TS21 after its launch, as I recall, I was the first to ask about the Blue LED oddity. Regardless, it remains a non-issue. 

Anything else worthy of characterizing the TS21 as a defective product? 


I don’t really care about the switch light either. The main issue I have with both of my early batch lights is the battery check feature while in simple mode. The readings are just all over the place. Even in advanced mode the first reading is useless but after that is ok. That and sometimes while charging the switch light goes nuts. I agree the light has some nice attributes but it seems the later models are still being produced with the same bugs.
CRC2
Offline
Last seen: 3 weeks 4 days ago
Joined: 03/27/2022 - 17:32
Posts: 310
Location: Canada
pennzy wrote:
The main issue I have with both of my early batch lights is the battery check feature while in simple mode. The readings are just all over the place. Even in advanced mode the first reading is useless but after that is ok.

Do you mean that the first read out is inaccurate and you have to wait for it to flash again for it to be the correct reading?
I think that is what mine seems to be doing sometimes.

SammysHP
SammysHP's picture
Offline
Last seen: 1 hour 23 min ago
Joined: 06/25/2019 - 14:35
Posts: 1558
Location: Germany

The bright flash after the second click (ceiling) might cause a voltage drop so that the first readout is about 0.1 V too low.

pennzy
pennzy's picture
Offline
Last seen: 5 hours 33 min ago
Joined: 12/10/2017 - 19:45
Posts: 4496
Location: United States , Pa.
CRC2 wrote:
pennzy wrote:
The main issue I have with both of my early batch lights is the battery check feature while in simple mode. The readings are just all over the place. Even in advanced mode the first reading is useless but after that is ok.

Do you mean that the first read out is inaccurate and you have to wait for it to flash again for it to be the correct reading?
I think that is what mine seems to be doing sometimes.


Yeah, that’s it, and because there is only one read out in simple mode it never is correct. I’m talking much more difference than 1 or 2 tenths of a volt deviation.

Pages