BLF Q8 won’t turn on

I am usually very careful with my lights…I am not sure what happened. I took my batteries out to charge. After a few hours of charging, I placed the batteries back in and screwed the head back on. I didn’t get any indication that the light was on. The light didn’t flash and the button wasn’t green. I tried a different set of batteries with the same result. I didn’t touch the light in between charging. Does anybody have any ideas? Thank you.

Try without the O-ring to see if that matters…

sometimes it bunches up and prevents contact…

That worked! I figured it would be an easy fix since I was sure nothing had happened to it. Thank you!

OK, that is the third thread about it.

Something changed about the BLF Q8’s O-Rings.

Ita not the Orings, its the milling area were the oring is, i had one Q8 that the oring kept poping out of the head, me and my buddy looked it over, and we saw that the bad one the grove were the oring sits wasint milled out fully.

Yeah, I gotta be really careful with my Q8s, screw it on sloooowly, see if a little “tongue” of O-ring is sticking out, then back off, try to tuck it in with my fingernail, and keep repeating ’til it works.

I actually get to wishing for usb charging, even at a trickle.