Charging 18650s with unknown capacity?

I have a bunch of "Ultrafire 5000mAh" 18650 batteries, I think some of the 5400mAh ones too.

And some really old(15 years?) used laptop pack finds.

I know that 18650s don't have a capcity of 5000mAh and that the labeling on the battery is probably wrong.

and the old 18650s, I know the original capacity of, but they are nowhere near that now.

How would I charge one of these "5000mAh" and "5400mAh" batteries on a hobby charger that asks for a capacity?

And how would I charge a very old used 18650 that I know the capacity of in it's "new" state?

I don't want to blow anything up or start a fire!

Does your hobby charger have a discharge capacity test? Charge on a dumb charger that shuts off at a full-capacity voltage range, then complete a discharge test cycle to verify the actual cell capacity? Discard those old/cheap cells and get some fresh pulls from a laptop pack?

It does have a discharge, but they reach 3.0v almost instantly and it says I have a like 12mAh battery.

(I am inexperienced, so I might be doing something wrong.)

I have good ones for my lights, but want to test the junk ones and keep them as backups to my backups.

I don't have a Hobby Charger so I can't help you much with that. I think some chargers let you select a discharge rate so if you could select a lower rate, it might help. Or maybe your cells really are 12mAh...

do you know the discharge current you are applying? It seems like you are using a very high one, and those very old cells may have a very high sag under a big load.
try to find out the amperage you are using to discharge, and use some realistic value (1 amp, i.e.)
EDIT: if the batteries are that old, they may be damaged too

at 1amp, they read like 1mAh, at 0.5amp they read like 12amp. I tried 0.1amp but the voltage didnt seem to move in like 2 hours.

Guess I should try 0.2-0.4amp. Charger will do 0.1-2c amp.

Well, what charger? Some have to be set to LiPo to terminate at 4.2V (those terminate at 4.1V in LiIon setting). Hard to give you an advice without knowing what kind of device you have.

Dont you have a dedicated LiIon charger?

If a cell doesnt give you a decent capacity at a discharge rate of 3A, its junk.

Sorry, I should have mentioned that.
My charger

I have 2 chinese simple chargers. at 3.7v and a 4.2v.

And which simple chargers do you have? ;)


First of all, you have a very good hobby charger. I just found a manual for it online. Before I continue, do you have a DMM? If you do, measure the voltage of the Samsung cells. If one is below 3V, be careful. If one is over 4.3V, be careful, too.

Set it to LiPo setting and 3000mAh capacity for the Samsung cells (multiply the value if you charge in parallel). Its a safety function. If the battery is not full after the charger has tried to fill in a certain mAh value, it will stop. You have Samsung 30B, those are rated at 3000mAh, but you can only charge to 4.2V, so you lose about 200mAh. Normally, you should enter a mAh value of 105% the rated capacity because charging is not 100% efficient. But since you cant charge them completely (unless you can set the charger to 4.3V), the math is 2800mAh * 105% = 2940.

After you have charged all the cells, let them rest for about an hour and measure voltage. If the voltage has fallen too much (about 4.1V) those cells are probably not safe to use. Then run a discharge at 3A. If they dont return at least 2000mAh, they are not really good anymore.

As for your Ultrafire cells and those chargers: all crap, dispose them the proper way and stick with the Samsung cells. You could open the chargers and remove all the crap inside and use them as charging cradles.

IF you really (and I strongly advise you not to do so) want to charge and test the Ultrafire batteries, charge them outside in your cheap chargers and then run a discharge test at 1A.

If you did a correct discharge test at 1amp and got 12mah, just properly toss those suckers.

Might as well not even waste your time. Get some good Panasonic / Samsung / Sanyo cells and call it a day.

You’re going to need at LEAST 1amp to use it for a flashlight on high.

Stalker! You found my samsungs! Haha!

I have an option on the charger for "Max Charge Capcity" then can be changed in incriments of 10%; so 100%, 110%, etc.
Should that be set to 110%? and the capacity 3000mAh?

I guess I'm not fully understanding that.

I just topped off one of the samsungs and, while resting, the charger is reporting 4.059v. Peak while charging was 4.21.

EDIT: I have gotta be doing something wrong with the charger. Just tried a 3Amp discharge of my fully charged Samsung 30B and it took 2seconds to reach 3v.


100% would be 3000mAh. From what I understood, only one of those settings should be available.

Set charging to LiPo at a 1A rate? Let it finish? It should have to finish settings, one after the current has dropped to 100mA (you can remove the cells at this point) and complete stop when the current has dropped to 30mA.

If it took 3 seconds to reach 3V, something definitely was wrong. Maybe you have insanely high resistance in your leads? Some pictures would be nice, also check the voltage while charge and discharge with a DMM. The fact that the charger showed 4.2V and the cell rests at 4.06V implies that either the resistance in the leads is extremely high or that the cells are beyond dead.

These are my settings, charge complete, discharge complete, and resting data view.

I am using a computer power supply and 1 12v rail. Maybe I need to add another 12v rail?

Shouldn't be a problem if your supply can deliver about 13A. I still think your charging leads might be a problem. What are they like? Have you checked voltage with a MDM?

As harsh as it may sound, I agree. If they will not hold there voltage under a 1 amp discharge for any length of time, toss them, you are far better off and safer for doing so.
Will the ultrafire’s hold there voltage under a 1 amp discharge?

They are Samsung ICR18650-30B that I pulled from a new Dell laptop battery pack.

They shouldn't be bad.

I don't have a multimeter.

The charging leads are alligator clips attached to metal strips from a laptop pack, held down by strong magnets.

The cables might be part of the problem. You should have a DMM, a cheap one for ~10$ is fine. How can someone spend that much money on a hobby charger and not have a DMM.

Your wires might also be a problem.. try to run a discharge at 300mA or so, that should work. A DMM would be useful because you could measure the voltage during charge/discharge and see if there is any discrepancy between the voltage displayed by the DMM and the one displayed by the hobby charger.

Should a fully charged battery drop to 3.1v within the first few seconds while discharging at 1amp?

The voltage was 4.19v before I started the discharge.
600seconds into the discharge and it's at 3.021v.
The charger defaults to 2.8v discharge cut off for a Li-Po, so that's what I am using.

Just discharged for 1000seconds got 300mAh and was at 2.9v. I stopped the discharge and checked the voltage and it's at 4.2v now.

Is that also normal?