Convoy S2+ new firmware (biscotti) memory mode jammed

I’ve been happily using one of my S2+ without memory mode. It contains the new firmware which I believe is called Biscotti.

The other night I decided to activate the memory (hit switch fast ten times, wait for the second ‘buzz’ then hit switch again) - Memory mode turned on but the problem now is that I cannot turn memory mode off - the driver simply fails to acknowledge the change and now the light seems to be permanently stuck with memory mode on.

All other light modes work perfectly.

I assume the driver memory has failed, (which is a bit disappointing as I had another biscotti driver completely die on me while in the middle of changing modes). I know Convoy says not to leave the torch in the mode configuration for long periods as it could “wear” out the memory, but I never do this, it was the first time I went to activate the memory.

Has anyone seen this or have any idea on how to fix it? If not I may have to get in touch with Simon as the light is not very old. I have seven S2+ with biscotti drivers, and two of them have failed in some way already. I know it is a budget light but this failure rate is pretty bad :((

Hum, now that you have the memory mode ON, what happens exactly when you try to enter the configuration?
Also, how many 7135 chips does your light have?

I have 7135 x8 driver

The configuration behaves normal. Hit switch fast 10 times and then it has the two buzz. First buzz to set mode and second buzz to set memory. I suspect mine is a later model biscotti as the flash rate of the buzz and mode is much slower frequency than early biscotti.

It functions just like the flow chart on Convoy aliexpress website - the problem I am having is that no matter how many times I hit the second buzz, it will not turn memory mode back off.

I don’t know much about microchips but I assume there is some sort of flash memory inside the driver and perhaps the location responsible for storing this memory on/off value (0/1) has died.

I guess in future I will just leave alone the memory feature as I don’t want another driver to get ‘locked’

Now I don’t know if this will help but, back in the stone age and the beginning of surface mount components, if we ever had a problem with a circuit we would remove all power from said circuit and short our dc + and our dc - together for a few minutes, again, without power applied. Then we would power the circuit back up and start from the beginning. So maybe take a wire and short between the + spring and the tube for a few and power everything back up. Just a suggestion. Don’t hold me responsible for anything please. :slight_smile:

i never know that using the configuration will wear out the memory of the driver, only happened when using biscotti driver or apply to another driver too?

I understand, tried shorting the DC input last night but this didn’t work. Thanks for the tip though

I have changed mode options on it many times without issue, it was only when I changed the memory that the memory got stuck. I even changed the modes to other ones to see if it would help with the memory but no matter what it stuck on.

I have same problem with my Convoy C8 Clear w/ Biscotti.

Today I required to change the mode, but accidentally pushed on the second ‘buzz’ and therefore toggled memory to on. I don’t want this, so subsequently tried to toggle it off but it is impossible. Mode memory is stuck on no matter what I do.

It is about 15-16 months old, I didn’t use it much, in fact it spent most time in storage. I have used the mode change just a few times (under 10 surely); I cannot recall if I ever attempted to toggle memory.

Anyone find a solution for this?

Did you follow the UI?

Yes. I can change modes fine, but I can’t change mode memory no matter if I do short, long, etc during the 2nd buzz

Unfortunately not. I might try to reflash the firmware but currently I don’t have the equipment.

In Banggood reviews I see this:

So that is you, me, eggmang and at least one other guy. The problem may not be widespread but it is not unique, maybe some bad batch of drivers or a component which is failing prematurely.

It is definitely not a problem with what I am doing. I have several Convoy with Biscotti and I can successfully toggle mode memory on all but one. One simply doesn’t change. It changed from OFF to ON at least once, now it refuses to change back.

That’s the craziest thing. I have re-flashed! It behaves with memory mode straight out of the programmer!

If there is a part on the driver, capacitor or something else, for memory, maybe it is no good.

That’s what I thought, but mode changing works fine. I’ve ordered a few replacement drivers that come pre-flashed, so I’m going to dump the ROM and compare to see if the code is different. I’m also thinking about manually compiling biscotti without mode memory support. Lol.

That sounds like a dead memory cell to me. The EEPROM cell storing the setting has failed, so the MCU always sees a one or a zero despite all efforts to set it to the other value. In this type of failure, other EEPROM cells - like the one storing the mode setting - can still be perfectly fine.

If you know what you’re doing with the firmware code (I don’t), you might be able to move the storage location to a different EEPROM cell. Alternatively, you could just hard-code the setting you want and render the EEPROM irrelevant.

My next to last s2+ failed but when it happened it went to only single mode. It would not enter into the mode selection at all. Had to make a video for Simon and he sent me out a new driver. That light was only 3 or so months old and I only keep it in mode 2. Pulled it out of my pocket one day and it only had 100%.

I also have a C8 that is stuck in “always on” mode, but I fried that one myself while swapping parts. I need to probe it with my scope, but I’m going on vacation next week and have to pack more than just my flashlights :slight_smile:

I am wondering if it might be a fried diode or something, as I didn’t do too much to it, and I inspected it under a magnifying glass.

PWMing 7135s :facepalm: in a practically unregulated driver (when high frequency switching 7135s, they lose most regulation voltage margin and efficiency). Screw it!

Believe as you wish and undergo its consecuences, period.

Cheers ^:)

So exactly how does one disable next move memory? I recently received a light with biscotti and the mode memory was off, but now it is one and I can’t figure out how to disable it.

I have tried no click and a short click during the second buzz, has not seemed to change the behavior. My first light with biscotti in it, have only had it a couple days.

Edit: I guess what I am finding is if I leave the light off long enough (have not figured how long) it will go back to the first mode. Guessing that is just a characteristic of biscotti. If I turn the light off, then back on even 10 seconds later, it starts at the next higher mode. Maybe 2 minutes off and it’s reset. Guessing the timeout is somewhere in between. Actually, what I am finding is the mode set also reset to number 2 mode set also. Hmmm . . . . I had moved it to mode 10 when I found I could not reset the mode memory.

- memset(0) manually if needed

- port(:)=0 manually if needed

  • change the backdoored compiler

For me: the looped counter ?D? because above