Emisar D4V2 Flash Kit Instructions (Official How To)

I would be happy to help. Terry Oregon’s instructions on that part are pretty thorough, but if you need some extra pointers or specific help feel free to send me a PM.

The truly “tricky” part is resourcing the files, flasher and flashing hardware on your own by reading a bunch of scattered posts that discuss different and hard to reach chips with fidgety wires and disassembling flashlight heads.

This will be really easy. You are given/bought all the correct hardware that is precisely compatible with the chip in the light, and all the software/links for this specific light are also provided.

Access to the chip to flash is a mere touch of the pins to the easy to reach pads/vias. No “tech” work at all.

Does anyone know the minimum version of Avrdude that is needed to flash the t1634 chip in the D4V2? The reason for asking is that I may have a simpler installation for Mac OSX than that shown in Reply #34. It is also a much smaller download. But my method only installs version 6.0.1 not version 6.3 as that method does.

Both the OP and Reply #5 suggest that Avrdude version 6.0.1 is sufficient, but I’m unsure if this is actually tested on the D4V2.

I was able to flash the latest Anduril to a BLF Q8 and to a D4S yesterday, with the only hassle being the fiddly wires and the cheap clip I was using.

My pogo pin adapter from Hank is somewhere in transit, but should be here in a week or two. I can check the D4V2 compatibility then.

Assuming my installation works for the D4V2, I’m happy to do it for anyone for the cost of the postage both ways. (Probably only feasible from within Australia.)

My setup: MacBook Pro, early 2013, OSX 10.13.6. (Yeah, I know, all ancient. But it was a retirement gift from my former employer and, unlike me, it is still working.)

You could try executing “avrdude -p t1634 -c usbasp -n” on 6.0.1 to check if it indeed supports t1634. I went with avrdudess as it was a smaller zip extract instead of the file supplied by Hank.

Thanks. Good point about the check. It confirms that Avrdude 6.0.1 does recognise the t1634. What’s more, if I specify something meaningless (like t1635 for instance) Avrdude responds with a list of the devices that are supported, which includes the t1634.

I’ll write some notes on my simpler (and smaller) Mac OSX installation.

And my offer to help with flashing of a faulty D4V2 stands (when I get my pogo adapter).

Here is an alternative to Reply #34 for installing and using Avrdude on a Mac with OSX (See below for my setup. YMMV.)

This method may be simpler for some users, because it is closer to a regular Mac installation. It is certainly quicker, because the download is 42.7MB instead of the 6.1GB or so of the other package (that is less than 1% of the download).

1. Log in as administrator.
2. Go to this page and follow the instructions down to the paragraph Option 1. AvrMacPack. Ignore the rest of the page from the heading Option 2. OSX-AVR to the end of the page (that is most of the page you will ignore). Hint: You can also find the Terminal app using the Launchpad (where it may be in a folder called Utilities or Other).
3. Do as instructed in Option 1, which tells you to go to this page.
4. Download the latest version of the .dmg file at the top of the list (it is from 2103). That gives you a disk image containing a regular Mac installer. Double click the downloaded disk image file and follow the usual Mac installation.
5. Download the appropriate hex file with Anduril as described in the OP paragraph Downloading Flash Files.
6. You need to relocate this hex file to where the Avrdude program can find it. I found it easiest to put it in my ‘home’ directory. It has a path like “Macintosh HD\Users\yourname”, where “yourname” is your login name. It is the folder that contains folders like Documents and Downloads that are put there by the Mac system.
7. Follow the rest of the OP instructions from Testing The AVRDUDE Installation to the end.

My setup: MacBook Pro early 2013 with OSX 10.13.6.

Just leaving some feedback. Flashed four d4v2 on a mac OS without any issues with the instructions from f0xx. didn’t see this comment from brewster until now.

Everything worked perfectly.


I just flashed my 2 D4v2s using my Note8. My only trouble was finding the correct placement of the pogo pins with my 76 year old eyes. I kept getting error messages until I put on a binocular jewelers magnifier. If I can do it, probably anybody else can, too, thanks to Hank and ZozzV6.

Received my flash kit. Soldering on the pins is very clean. Reflashed one of my D4V2 (no problems). Macro photography lighting courtesy of my D4V2.

Thanks, great thread! Super easy following the instructions, especially using an android phone.

I used the AVRDUDE method, only problem I had was I selected the wrong MCU from dropdown.

just waiting on my kit to fix my bugged D4V2! i dont use muggle mode, but damn its a great idea!

Got my flash kit today. Flashed 8/5/2019 hex in a few seconds using the Android phone app. Works great and the phone app really made it easier than using AVRdude (which isn’t that hard anyway). Thanks for the Android method! I hope any future Emisar lights use the same pad/via configuration for updating firmware.

My kit arrived today. USB recognized but avrdude wouldn’t communicate with light. Inspection of pogo pin soldering revealed that there were some sections with solder bridging the traces.
Simply dragging a thin X-acto between the pins along the board surface a couple times cleared it out. Flashed and good to go!

I received my flashing kit. Using the posts above, I was able to easily get everything working on MacOS, and now my D4V2 is updated. Thanks for taking the time to create these easy to follow posts!

hey all… im currently updating the firmware on my d4v2, im getting a mismatch on byte, anyone have an idea why this is the case? heres the output

Try a couple more times, making sure you're holding the pins steady. I ran into this problem as well. What I did - was flashed the other hex file (non Nichia version), and it worked. Then I went back and flashed the correct hex file for my light (Nichea version), and it also worked. Not sure what causes this error.

okay will continue trying, do you recall if you got the same error as below?

I posted an example of the "verification error" on the instructions. It was slightly different.

hmm yeah, i went to the older version and i get the same error… thinking…hmmmm