Flashlight Firmware Repository

Thanks, but i dont know how to do it, im not a coder.

Yes, and in an ideal world the ADC post-processing (averaging and decimation) would be separate from the rest of the code.

Edit: An obvious change would be to oversample the ADC readings instead of skipping three out of four ticks

Sensor lag time test results (all lights were programmed to shut off at 50 °C):

I managed to record the temperature reading of the internal sensor, this will help a lot for the further development of the ADC conversion code:

I think the aux leds do not need many amps. It can run on months with fresh batteries. So it would lasts a long time till the batterie is dead.
Many Aux-LEDs will turn off on low battery. This is implemented in some Aux-Boards from Lexel, such as MF01S or MF01 Mini or some Fireflies Flashlights.
Whithout this behaviour the LEDs will turn off because of the too low Voltage. This means they will use much less amps than with full battery.

But as Agro, it can be implemented to be on the safe side.
Otherwise the Low Battery-Indication on a MF01S or MF01 may not work as implemented, if the driver switches the aux-board off.

Fantastic! Via debugWIRE? I wonder how you managed to get the cables to the outside. Through the hole of the switch?

I insert short blips with a duration of the current temperature value and capture them with my luxmeter:

Awesome setup!

Indeed :slight_smile:

Not the red ones

Code is ready for review: ~pakutrai/flashlight-firmware/fsm : revision 465

Link to the pull request: Merge into fsm : fsm : Code : Flashlight Firmware Repository


I have the same problem, that I cannot clone the repository.
I use the Bazaar Explorer.

What do I have to enter in “open url”:
this does not work for me: lp:~toykeeper/flashlight-firmware/fsm
I get the same errors as shown by Lexel’ screenshot.

Did you click the button with the green arrow on the left? The one that says “Quelldateien des Projektes von einem anderen Ort beziehen”? The buttons with the blue icons are probably meant to open local and not remote projects.

“lp:~toykeeper/flashlight-firmware/fsm” is the correct URL.

This does not work either. I use Windows 10 Pro.
Do I have to be registred at launchpad? And do I need that ssh key file?
see: Bug #1807226 “bzr: ERROR: httplib.IncompleteRead: IncompleteRead...” : Bugs : Bazaar

Run command: bzr branch lp:~toykeeper/flashlight-firmware/fsm “O:/Neuer Ordner (2)/trunk” —use-existing-dir
Qt: Untested Windows version 6.2 detected!
You have not informed bzr of your Launchpad ID, and you must do this to
write to Launchpad or access private data. See “bzr help launchpad-login”.

bzr: ERROR: httplib.IncompleteRead: IncompleteRead(34 bytes read)

Traceback (most recent call last):
File “bzrlib\commands.pyo”, line 930, in exception_to_return_code
File “bzrlib\commands.pyo”, line 1141, in run_bzr
File “bzrlib\commands.pyo”, line 673, in run_argv_aliases
File “bzrlib\commands.pyo”, line 697, in run
File “bzrlib\cleanup.pyo”, line 136, in run_simple
File “bzrlib\cleanup.pyo”, line 166, in _do_with_cleanups
File “C:/Program Files (x86)/Bazaar/plugins\qbzr\lib\commands.py”, line 826, in run
File “C:/Program Files (x86)/Bazaar/plugins\qbzr\lib\subprocess.py”, line 1011, in run_subprocess_command
File “bzrlib\commands.pyo”, line 1141, in run_bzr
File “bzrlib\commands.pyo”, line 673, in run_argv_aliases
File “bzrlib\commands.pyo”, line 697, in run
File “bzrlib\cleanup.pyo”, line 136, in run_simple
File “bzrlib\cleanup.pyo”, line 166, in _do_with_cleanups
File “bzrlib\builtins.pyo”, line 1434, in run
File “bzrlib\controldir.pyo”, line 780, in open_tree_or_branch
File “bzrlib\controldir.pyo”, line 689, in open
File “bzrlib\controldir.pyo”, line 718, in open_from_transport
File “bzrlib\transport\init.pyo”, line 1719, in do_catching_redirections
File “bzrlib\controldir.pyo”, line 706, in find_format
File “bzrlib\controldir.pyo”, line 1151, in find_format
File “C:/Program Files (x86)/Bazaar/plugins\git\init.py”, line 235, in probe_transport
File “C:/Program Files (x86)/Bazaar/plugins\git\init.py”, line 182, in probe_http_transport
File “socket.pyo”, line 348, in read
File “httplib.pyo”, line 522, in read
File “httplib.pyo”, line 565, in _read_chunked
IncompleteRead: IncompleteRead(34 bytes read)
bzr 2.6b1 on python 2.6.6 (Windows-post2008Server-6.2.9200)
arguments: [‘C:\Program Files (x86)\Bazaar\bzr.exe’, ‘qsubprocess’, ‘—
bencode’, ‘l6:branch37:lp:~toykeeper/flashlight-firmware/fsm25:O:/Neuer
Ordner (2)/trunk18:—use-existing-dire’]
plugins: bzrtools[2.5.0], changelog_merge[2.6b1], colo[0.4.0],
explorer[1.3.0dev], fastimport[0.14.0dev], git[0.6.8dev],
launchpad[2.6b1], loom[2.3.0dev], netrc_credential_store[2.6b1],
news_merge[2.6b1], pipeline[1.4.0], qbzr[0.23.0dev], rewrite[0.6.4dev],
svn[1.2.2dev], upload[1.2.0dev], xmloutput[0.8.8]
encoding: ‘cp1252’, fsenc: ‘mbcs’, lang: None

* Bazaar has encountered an internal error. This probably indicates a
bug in Bazaar. You can help us fix it by filing a bug report at
including this traceback and a description of the problem.

Do I have to be registred at launchpad? And do I need that ssh key file?[/QUOTE]No and no.

This does not work either.[/QUOTE]Maybe give TortoiseBzr a try? Or use the command line directly.

[quote=0-8-15 User]

Do I have to be registred at launchpad? And do I need that ssh key file?[/QUOTE]No and no.

Hello 0-8-15 User

I have to give it up. I tried over 5 hours to simply copy the repository.
Would you please be so kind to send me a zip-Copy of the current repository? That would be really great :slight_smile:

I woul send you a pm with my email-address.


[quote=0-8-15 User]

Just go to one of the revisions you are interested in, for example:


Then at the top choose “download tarball” and work with the files manually

I see a lot of issues with bazaar. It seems that git is much more common (and my personal preference as well). @ToyKeeper, it’s 2020 now – what do you think about moving the repo to GitHub or some other git hosting site? I use this command to migrate and update the repo:

$ cd git-repo
$ bzr fast-export --marks=../marks.bzr -b git-branch ../bzr-branch-directory | git fast-import --import-marks=../marks.git --export-marks=../marks.git

@ contactor: :laughing:
That was easy…
a few minutes ago I thought about setting up a virtual linux machine.
Yesterday I tried WinXP and Win7 virtual machine.
I think, this bazaar programm is buggy…

I think, is would be much easier for us to use git. This worked fine for me.
Editing and improving your great code librarys is hard work only because of setting up the linux development softwares.
Especially setting up a linux machine with 25 different programms to compile the sources is very annoing.
Maybe we can set up AVR studio projects together for the codes library. That would only be one zip for a project, which people can download and they only have one project file. And if they compile it with avr studio, it simply compiles and works. So they can take their time to improve the code and set up new features.

By the way to setup development enviorement under Linux is far so easy compared to Atmel Studio. Yesterday I setup Linux Mint and install bazaar very easy. Also I download the whole repository with just one command stroke. Also Toykeeper is provide to us in readme how to install avr gcc compiler. Also there are bash script which compile all anduril versions in ones. When I tried to used Atmel Studio for first time I have troubels with installation of additional components. Atmel Studio is better if you want to debug the code but if you want just to compile code the Linix is the easiest in that case.

Has the latest firmware for a D4V2 made the Aux LED cycle rate way slower. I just got a brass D4V2 and the cycle rate is way slow and not consistent. The rate changes between about 1.5 seconds and 5 seconds. I also have had a very hard time accessing advanced functions. Battery check and changing between ramped and stepped modes are good examples. Seems like I’m not clicking fast enough? I have 2 other Emisar’s a D4V2 and a D4SV2 and have no such problem. No problem on the other dozen or so Anduril powered lights I own.

Thanks for your time