FW3A mod thread. Post yours!

I have one already. I was actually interested in the attachment to it, not the ring itself.

Just did the o-ring mod also using a generic keyboard keycap sized o-ring and did a very [un]scientific method of measuring switch force: used a kitchen scale and watched how much weight in grams was needed to actuate the switch.

Three candidates: Gen1 grey FW3A without switch retaining ring, blue FW3A with switch retaining ring but similar switch feel with the o-ring mod, and a purple FW3A with switch retaining ring and a much stiffer stock switch which must be an improved switch design.

Actuation force, approximated:

Grey FW3A with light switch: ~300g

Purple FW3A with stiffer switch: ~600g

Blue FW3A with light switch and o-ring mod: ~700g

One thing of note is the purple FW3A’s stock stiff switch is much more satisfying to click than the modded blue one, there’s a bit of dead travel in the o-ring switch without the nubbin’ leading to an initially mushy feel like others have said, but it’s definitely an improvement.

This is an easy hardware fix instead of modifying the firmware to make a software solution.

The firmware “fix” I did was to replace the lockout second click’s default value of using the second ramp’s floor for momentary, with the value used for manual memory which I use on all my Anduril lights. So 2H gave me a momentary function for the level of light set to manual memory while locked out, useful if light was only needed for a couple seconds.

I swapped the leds to SST20 3500K, really nice tint. But I am getting short somewhere, there is only turbo. I was checking the both sides of driver under stereomicroscope and didn ´t find anything. First I tested leds with a power supply on low miliamps and everything worked as expected. I really have to figure this out :D. Maybe some driver components are touching a flashlight body, don´t know.

Only turbo?

This happened to me on my polished FW3T after I tried swapping in the optics and the new optic pressed too firmly against the emitter.

The problem wasn’t the driver. Rather it was a bad solder job under one of the LEDs. There was a short between the negative contact pad of one LED and the center ground pad. You can test for this as follows:

  • remove the star from the light
  • connect one probe from your DMM to the negative driver wire pad on the top of the star.
  • connect the other probe from your DMM to the side or bottom of the star.

If you get a connection, then you have a short. This short causes the light to bypass the driver completely. The only output you get is max turbo and the switch does nothing. It will turn on in max turbo the instant the battery tube is halfway screwed in.

If you have the same problem, the solution is to reflow the LEDs and check the solder under each one. I did that on mine and it completely fixed the problem.

I love the look of the hammered copper this guy did

When you assemble the light, is it instantly turbo or does it ramp up first? Mine did the second after I dis- and re-assembled the switch, and I had to take it all apart and re-assemble carefully according to… There’s instructions somewhere, let me re-find them… The FW3A useful information thread

If it’s instantly on turbo and the switch does nothing the driver is probably being bypassed.

If it actually ramps up then the problem is probably a short in the battery compartment between the inner tube and the outer casing.

Dang. That’s some artwork.

Also, couldn’t help but notice how nice the non-tapered battery tube looks… (sorry in advance)

Firelight2, you were right, I resoldered the leds and problem was solved. I should check if leds are grounded sooner with a power supply :person_facepalming: :smiley: . Thanks for help, as always nice advices here.

That’ the first thing I noticed lol, really like the look of it.

Happy to help! :+1: :sunglasses:

My o-rings arrived for the FW3A.

Very quick mod. Disassemble the switch, pull out the nubbin, install the o-ring. Reassemble.

The difference is absolutely amazing! The switch still has a nice distinct click, but now requires much more pressure to activate. This is the way it should have shipped out of the box! :heart_eyes:

Glad to hear it worked out for you. Which size did you use?

I bought these o-rings from Amazon. The link was from someone else earlier in this thread. They work great!

I didn’t like those 3D printed diffusers made for the FW3A, so I looked around and found a 25.4mm one by Nitecore that fits perfectly. A good snug fit that is nicely secure.

Installed the aqua GITD optic insert. It’s an attractive color, but unfortunately doesn’t radiate as long as the green one. The saturation below is a bit washed out in the photo, but in person it’s richer. The stainless steel bezel is nicely finished, worth the $4 USD.

I was thinking of ordering this from Amazon but will try to find some local store. Even though it does not costs much, I hate to waste the remaining 99 and them taking space in my already overflowing drawer!

With the o ring my still accidentally turned on. I wish the o ring would give was just a tiny bit more firmness

Think of it this way:

When you trip and spill 99 of them on the floor, you won’t have to bend down, because there will still be one in the bag! :disappointed:

Did you remove the nubbin? Adding the o-ring without removing the nubbin doesn’t help.

Still… even with the o-ring mod there is still a risk of accidental activation. If you want to reduce the risk further you might want to try gluing a washer on the end of the light in addition to the o-ring mod.

Ah yes that explains it, it feels totally different now. When you say washer do you mean externally? I don’t want to add to it’s bulk, any other easy mod inside to help this?