Help! My Balder SE-1 XM-L doesn't working

I just received my Balder SE-1. First I tried it with Trustfire flame 14500 and didn't worked. Second, with NiMh didn't worked. Third with Alkaline and again didn't worked. I tried to demount the torch to understand possible problems but, it was difficult. Anyway i did. I check tailcap, driver etc. There is a sticky paper on the driver to stick driver to thepil. Driver is not soldered to the pil. Does it be problem? Any help please...

Did you remove that "paper"? It's just there for reverse polarity protection and I'm sure the driver is soldered under it. Have you tested it without the tailcap on to rule out the switch? It's the first thing you should do.

When i removed the paper driver comes out from the pil, its not soldered to pil. Should i solder driver to the pil?

I made a test by using a wire from bottom of the battery to the side wall of pil and touching + side of battery to the driver. Didn't worked. Is it correct way?

I don’t have this light but I think a driver should make contact with the pill it is in. If you know about positive and negative terminals try using a wire to the negative terminal of the driver this time (not the pill). Careful not to short anything.

Hopefully somebody with this light will respond and let you know if it's normal for the driver in this light to not be soldered to the pill. I would think it should be but since I don't own one I can't say for sure. You should contact the seller and get a replacement.

Hi Leelou,

if you mean outer metalic ring on the back side of the driver as negative terminal, i tried it also but didn't worked.