need help with solarforce l2i host. (not 18650 fitting problem)

I have ordered a MF xml p60 and solarforce l2i host. when i connected the drop-in to the battery directly, the drop-in works. but when i put it in the l2i host, it doesn't work. i guess this is a contact problem, but i couldn't find out where.

i have tried cleaning all the treads and the battery tube. i have used the leads from the multimeter to connect -ve battery to tail treads to eliminate the tailcap as the problem. i still couldn't find out where the problem is. anyone have this problem b4? any help is appreciated.

So many possible variables ..

My guess is , since its a L2i , you may be crush fitting the battery that then may be stressing the Driver .. Try it with 3xAAA ..

With the limited info , my best guess = crush fit = preasure on driver , and something dont like it ...

Are you using the plastice tube [ battery spacer ] ? to take out the slop with a 18650 ?

i am using unprotected 18650. and yes, i have also tried 3xAAA, still doesn't work. no, i am not using battery spacer. would that help? i have also tried putting the 18650 in from the head to make sure that the battery is not caught on the lip inside the battery tube. i have also tried it without the head screw on as i also suspect too much pressure on the driver or spring might cause a problem, still nothing. the only way i can get the drop in to work so far is by connecting the drop in directly to the battery. i have also tried putting different 18650 and AAA into the host, nothing. oh, i just tried connecting the drop in directly to the battery but this time i pressed really hard on the +ve spring, the drop in still works. this is driving me crazy!! i just receive the drop in today, but i can't use it......... help!!

Try checking the Soldering , is it making contact - Driver to pill on the negative ..

I would freshen up the solder , neg driver contact to pill ..

Also try loosening up the reflector just a little [ just in case there is a short ]

Try wrapping the reflector with aluminum foil so that it lifts the drop-in up slightly from the bottom where it seats. It may not solve the problem but my Surefire 6P will not work unless the drop-in is lifted up from the base.

The L2i is absolutely awesome with that XM-L/18650 set-up.


i tried Foy's Al foil method, no luck. i haven't tried to freshen up the solder like old4570 suggested. but i did get the light to work. i put in a piece of Al foil into the battey tube to connect the treads from the tail to the treads on the head, and now it works. so it's like the current cannot go through the battery tube or something. very weird.

Weird... maybe the threads are dirty or coated or something?

I think yall are onto the problem, you can see where looking down the L2i battey tube its threaded to another piece that the head screws onto. it must be brolen contact between those 2 pieces. My L2R unscrewed there once and it had some kind of grey locking stuff on the threads so maybe yours its just too much there insulating the 2 pieces.

Ohhh . . . so there may have been some anno on the tail threads? Whatever, at least it works. Another weird thing about my L2i; while screwing down the tail cap with an 18650 the o-ring strangely rolls out of its uhhh . . . seat, home, indentation (what's the word I'm looking for - wishIwasanexpert) about half the time. It never did it using the 3 x AAA holder.

Anyway, it's been a fun light to mess around with.


I like my L2i too, its the perfect length to put it in a coat pocket. I cut down the strike bezel all the way soon as I got it, and with Old's switch mod and a plastic spacer inside the battery tube, it fits 18650s perfect like it came from the factory. I actually kind of like the forward clicky. I am debating going to an XML dropin or just getting a C8 light with the bigger reflector eventually.

i think Frugal is right. it is the only way that can explains why current is not passing through. too bad i can't unscrew the two pieces. well, i just email solarforcesales and let them know about the problem. i hope they are gonna replace it. if they are not, i guess i will just have to solder a piece of wire inside the battery tube to make the connection.

I bet they will send you a new tube. You could probably clamp it in a vice with rags around it and get it loose but its probabaly going to get scratched up. Maybe try it after you get a new one.

You could try taking the oring off and warm it up in an oven or with a torch would probably break down the locking stuff they use too.

thanks Frugal, i will try that after i get a reply from solatforcesales.

update: solarforcesales has sent me a new tube. Thanks Jo, quick reply, good service. the new tube is working properly. measured 2.8A at tailcap. as for the old tube, i don't have a torch to try what Frugal suggested. but i did try using a soldering iron to heat up the tube and see if i can separate the two pieces. no luck. still glue together. well, i am not gonna mess with it too much. at least the new tube works. Thanks everyone for your help.

Would torch wreck the anodizing?

Yes direct flame could discolor it. Just gently let the heat, not flame pass by it quickly, aluminium will heat up and disperse the heat quickly. Heat a little and try to break loose and just keep repeating. Eventually the locking compound should just break down. A heat gun would be best over a torch really though.

I have a L2i problem too.

I coocked my own drop-in featuring 101-AK driver and XP-G R4 emitter. I think I'll start a new thread on that. When using 18650, no problem. But when using 3xAAA on high it goes on for about 15 seconds before starting to blink at low mode. Every time. Why's that? 101-AK should be good up to 6 volts. Amp draw on high with 3AAA (fresh alkalines @ 4,52V) starts from 0,72 and quickly sags to about 0,60 amp before going to low blink mode.

Hi HID45, i am no expert but have u tried nimh instead of alkaline? the problem might not be the voltage, could be current. nimh can provide more current than alkaline, i think....

I was plannin on gifting this to a non-flashaholic, so Nimh recharchables are not really an option. I think I'll keep this one to myself and use it with 18650 and get some lower-amped drivers to use with 3AAA. Or, when my Soic8 clip arrives I might try to limit the current draw via some programming magic.

Anyway, I thought that even alkalines could do continuous 1A with ease. Seems that they can't

Or you could also include NiMHs and charger in the gift if budget permits. I'm planning on doing that. In fact the batteries might be even more useful, albeit less impressive.