Received first real light

Like the title says, my UltraFire WF 501B came today. Unfortunately is does not work. Ugh. I charged the batteries and tried to turn it on, nothing. Been reading on here so I removed the tail cap and used my MM to test the current draw, 2.4 - 2.5 amps but with no light. It will flicker a bit sometimes. Dissasembled the whole thing and tried using the MM leads directly from the battery, same thing, a few flickers real bright for a few seconds then nothing. Put the whole thing back together and tried again, now it’s bright but flickers, lasts maybe 5 seconds before it totally shuts off. This is definitely frustrating. It acts like a lose connection but the leads directly from the battery should work? Ugh, time for a beer, mess with it tomorow. Any ideas wheee I should start tomorrow. I’m a noob so simple is good.

Try different batteries, tighten head or pill, clean threads, look at pill to check for loose connection on driver...

Good luck. It's frustrating I know!

Thanks for the response. I tried two dif batteries, tried tightening/losening all of the various parts. Connected the leads directly from the battery to the positive spring and the outside of the of the pill. Still nothing but some flickers. Put it away, having another beer…

There is a short either in the driver or between the driver and the LED. There are often machining chips and burrs left on these budget lights and they can cause what you are seeing.

The current is flowing somewhere in the dropin, now the hunt is to find out where.

Do you have a soldering pen and some solder wick to be able to remove the driver from the pill to check?

I have a soldering iron and solder wire but not sure what a “wick” is? Definitely do appreciate the help though, would like to get this thing to work. I will look for burrs and chips, how do you remove the driver from the pill.

defiantly a short IMO - make the sender replace it so they dont say you damaged it

solder wick is a braid made of fine copper wires. You place it on top of a soldered connection and then press your solder pen tip onto it to apply heat. The solder is 'wicked' into the braid and off of the circuit. The best way to remove solder.

Below is a picture of a P60 pill (what is in your light) seen from the battery side. The outer spring has been removed in this picture. Look at the solder blobs connecting the circuit board to the brass pill. This is both the negative connection to the driver and the mechanical means of holding the driver board in the pill. Remove this solder and you should be able to pry the driver board off. Be gentle and careful, the leads from the driver to the LED are not always very long. Good luck!

Thank you, appreciate the help. I"ll see if I can get some wick tomorrow.

You are welcome. Good luck

Have you tried tightening the switch in the tailcap? I have had multiple lights with flickering problems but it ended up the switch was just loose in the tailcap and needed to be screwed in tight :) Before you start desoldering things :)

Good luck! If you get it all sorted out, it will be an awesomely bright light!

As he is measuring a large current draw without any light being emitted the switch is not the issue.

BAH! Sorry, I misread that part. my bad. Good luck! keep us posted!

Lol no prob. I brain fart upon occasion as well.

I've fixed several 510bs that flickered by doing one of two things :

1) Tightening down the pill. Give that a go before you start soldering.

2) Loosen the tailcap a turn or two. Sometimes there is too much pressure on the springs and that somehow causes it to short out. If that solves the problem, you can fix the issue by just cutting a coil or two off of the spring.

Good thought, have you tried applying voltage to the dropin, outside of the body?
Inner spring is positive, outer spring is negative.
I would also check continuity between the two springs with the pill out.

The reflector could be shorting the LED too. Is there an isolator disk (usually paper with a hole for the LED dome) between the reflector and LED? You can try connecting the battery to the pill outside of the light without the reflector and see if that works. Positive end of the battery can touch the little spring, then you'll need a wire from the negative end of the battery to the pill. Oh, and squint.

Good idea, a missing/damaged insulator disk would cause these symptoms as well.

Yeah that's where i was gonna go ..try it after taking the reflector off .. it just unscrews .Sometimes they are squashed down onto both solder blobs on either side of the emitter ..the isolation disc is just a plastic peice with a hole in it for the emitter's just to stop that short from happening ...

Cool, glad to see I was on the right track. Those are the tests I tried last night. I’m a decent shade tree mechanic but electronics have always been an achilies heel. This is why I don’t want to send it back, would be much cooler if I could fix it.
The isolation disc is there, it does seem to get squashed pretty hard when the reflector is screwed down though. I peeled it back a bit to look for metal particulate and it says XML on it (does this mean it will be bright…). Have to work today, Saturday is estimate day, but when I get done I plan on messing around with this thing. It’s gotta be a short, every so often it stays on for a few seconds. So far I have learned not to look at the emitter while messing with it, holy crap you can’t see anything for a few moments!
Thanks again for all of the ideas!