slot #2 error on "Upgraded Miboxer C4-12" (got replacement unit..)

According to it has padded LX that can be pretty hard to replace it without proper tools.

Anyway still waiting for seller proposal.
AliEx proposed 1/4 of the price, currently can’t repair this for that amount so still negotiating.

Any other news, mine shows an error on slot 4 today after using it three or four times?

Hi yes,

I got refund for my broken c4-12 upgrade so now there is time and budget to open it.
After some measurements that I’m capable to do it looks like @tantien11 has right in my case.
Drain (LX) of second slot ME3118A gives full 12V and that gives overall error on this slot.
Attached picture that expose names of particular parts, not especially pretty but you should get part name.
I’m talking about 4 sop8 ICs placed on top - in my case it is second from left.

Thanks, I was offered 1/4 refund since three slots still worked. I said no , so they are sending me a new one. Might try to open the faulty one up. No experience with this lol

That was my first dispute on AliEx but there was no chance for full refund they first offered 1/4 of price and after that weirdly offered 55% without returning device.
Anyway it seems to me this IC is simply faulty and with my knowledge of several internet parts shop not found any decent repacement so ordered 5 pieces from ebay.
Whole crash probably happened when my protected 18650 was in #2 slot, that was my first attempt of loading of anything to this charger.
Only saw screen get reset and after that only error was displayed on #2 slot no mater what was putted there.
I have friend here who has hot air station and is capable to replace this IC - like said before it can be tricky to replace it only with soldering iron because of LX drain PFET pad that is placed under sop8 package. I don’t want to risk doing this myself :slight_smile:

You described how the error happened — I was also charging several 18650s on the C4-12 (I was near the charger since I was still observing this new charger), then the screen reset, and slot #2 showed Error.

If you’re able to open it, can I ask to take a picture of what parts are needed to be replaced? Thanks!
I don’t have the skill or knowledge to replace, but in case I can find someone who may be able to do it…

I’m talking about IC in SOP-8 package placed on top of my picture from previous post. There are 4 of them each for different slot.
It is named ME3118A.


Can confirm now - replacing ME3118A gives live to broken slot.

5pcs of ME3118A from ebay was about 5$, my colleague said 1$ for work but I gave him 5$ too :slight_smile:

Very nice, thank you for the update! I have the same problem with slot #2 (got a 50% refund on banggood) so I’m gonna order the part and try to fix it too

I bought a second miboxer c4-12 and swear to not buying anything from Miboxer anymore.

Their customer support is non existant, their reply contact the seller for a refund, we dont care that we made a faulty device and not going to do anything about it.

My first “upgraded c4-12” (the same one with two buttons) does not charge the batteries properly, stopping way too early and has display artifacts errors (basically the numbers get out of bounds and it displays gibberish and that would explain why it terminates too soon).
This was a V2 model.
I reported this to Miboxer customer support and got the usual response contact the seller for a refund we dont care attitude.
Contacted the seller and got a full refund and got to keep it but unless someone would know how to fix it its useless.

A few months have passed and I thought that they would have a new version of this model and I really like the features of it so I ordered a new one.
Got it and its V2.2 so I was excited to use it.

Put it a bunch of old cells that I have and quickly realized that this charger also doesnt work.
First it starts charging at 300mA and not 100mA like the older one.
Thats fine but a few minutes in it crashes completely (it looks like it gets stuck in some sort of loop because it just keeps switching thru the slots) and stops charging.
It also doesnt display FULL when its finished (I assume its finished because it says 100% and the current is 0)

Again I reported this to miboxer with video and got the same response as the previous one.
Contacted the seller to get a refund but this time I have to return the unit.

Heres a video of the issue : Miboxer C4-12 V2.2 defective - YouTube

Miboxer, Never again.

Hi, it is obviously huge bad luck, with some help from miboxer. I agree they have customers that buying their stuff on place where light does not come :slight_smile: They only honor their official shop.

Miboxer has so long history of several models repeating with same problems described on forums, that it appears likie some risk is involved in buying one.

Don’t know what my charger version is, where can I find is it v2 or v2.2? Second thought - did you tried to use manual charge or use different slot ? Is the same effect there ?

It could be really bad battery and charger start to be stupid trying to revive it. Some combination of parameters that programmer never predicted - looks like bug that should never happen.

Its still their product and they should show more concern that theres problems with it.
The only way to tell what version it is as far I know is by looking at the manual.

This happened in all the slots with all sorts of batteries. It only worked fine with fresh new batteries or with low internal resistance.
Anyway its going back.

This would be one of those times that a protected cell would be a good idea so that it can trip if the charging voltage is too high.

Mine manual is branded with V2 in the lower right corner so i thing we are talking about it.
Since you are returning it, you cant relay look inside to spot differences but according to your issue with it, it is going worse.
When opened mine for repairs - there is no any sign of quality check or something like that, maybe this is their weakness.

I didnt open mine so I dont know what it looks like inside.

Miboxer told me that the fact that it didnt show the word ‘FULL’ when the cell was charged that it was faulty and to return it.
Have you noticed that with your V2 especially with NIMH that it doesnt really charge up to 1.50V? On my V2 it usually stops at around 1.38V.
Also it gets messed up with the IR numbers and just shows gibberish instead of numbers.

Have you wiped the contacts of the charger and your cells with alcohol?

Looked especially for low voltage finish since several people here said it could be a problem, but no, mine (including slot #2 with reworked IC) charges same on all slots for example four new eneloops finish at 1.52V 0.75A 0.51-0.55mohm.When measured right after eject with multimeter it shows 1.49V. No garbage readings.

Without surprise,
forced to replace second chip, this time on #1 slot same symptoms, same resolution, fortunately i have still 3 spare parts.
Anyway, beside this charger work great when not broken, I’m not recommending miboxer c4-12 upgrade to any end user not familiar with hot air smd montage.

Sorry to revive an old thread but yesterday my MiBoxer C4-12 slot #1 died.

Bought it some 18 months ago; way past any warranty. tantien11 replaced ME3118A (edit: post #15).

eBay listing doesn’t ship Canada. However, AE has Link at ~10 $ shipping.

I’ll try my hand in replacing but what is the underlying failure of the regulator? Is it too weak or another component that overdrives the chip?

Bad phone camera but a picture of the innards. Which is the regulator? Yellow or Red? (I’d have to re-open the unit to check).

Did not get notification for this so it is one year old - @Sidney Stratton did you tried replacement ?
I think you already now that ME 3118A are located horizontally (almost inline) with hugest capacitor on board.