slot #2 error on "Upgraded Miboxer C4-12" (got replacement unit..)

I’m talking about IC in SOP-8 package placed on top of my picture from previous post. There are 4 of them each for different slot.
It is named ME3118A.


Can confirm now - replacing ME3118A gives live to broken slot.

5pcs of ME3118A from ebay was about 5$, my colleague said 1$ for work but I gave him 5$ too :slight_smile:

Very nice, thank you for the update! I have the same problem with slot #2 (got a 50% refund on banggood) so I’m gonna order the part and try to fix it too

I bought a second miboxer c4-12 and swear to not buying anything from Miboxer anymore.

Their customer support is non existant, their reply contact the seller for a refund, we dont care that we made a faulty device and not going to do anything about it.

My first “upgraded c4-12” (the same one with two buttons) does not charge the batteries properly, stopping way too early and has display artifacts errors (basically the numbers get out of bounds and it displays gibberish and that would explain why it terminates too soon).
This was a V2 model.
I reported this to Miboxer customer support and got the usual response contact the seller for a refund we dont care attitude.
Contacted the seller and got a full refund and got to keep it but unless someone would know how to fix it its useless.

A few months have passed and I thought that they would have a new version of this model and I really like the features of it so I ordered a new one.
Got it and its V2.2 so I was excited to use it.

Put it a bunch of old cells that I have and quickly realized that this charger also doesnt work.
First it starts charging at 300mA and not 100mA like the older one.
Thats fine but a few minutes in it crashes completely (it looks like it gets stuck in some sort of loop because it just keeps switching thru the slots) and stops charging.
It also doesnt display FULL when its finished (I assume its finished because it says 100% and the current is 0)

Again I reported this to miboxer with video and got the same response as the previous one.
Contacted the seller to get a refund but this time I have to return the unit.

Heres a video of the issue : Miboxer C4-12 V2.2 defective - YouTube

Miboxer, Never again.

Hi, it is obviously huge bad luck, with some help from miboxer. I agree they have customers that buying their stuff on place where light does not come :slight_smile: They only honor their official shop.

Miboxer has so long history of several models repeating with same problems described on forums, that it appears likie some risk is involved in buying one.

Don’t know what my charger version is, where can I find is it v2 or v2.2? Second thought - did you tried to use manual charge or use different slot ? Is the same effect there ?

It could be really bad battery and charger start to be stupid trying to revive it. Some combination of parameters that programmer never predicted - looks like bug that should never happen.

Its still their product and they should show more concern that theres problems with it.
The only way to tell what version it is as far I know is by looking at the manual.

This happened in all the slots with all sorts of batteries. It only worked fine with fresh new batteries or with low internal resistance.
Anyway its going back.

This would be one of those times that a protected cell would be a good idea so that it can trip if the charging voltage is too high.

Mine manual is branded with V2 in the lower right corner so i thing we are talking about it.
Since you are returning it, you cant relay look inside to spot differences but according to your issue with it, it is going worse.
When opened mine for repairs - there is no any sign of quality check or something like that, maybe this is their weakness.

I didnt open mine so I dont know what it looks like inside.

Miboxer told me that the fact that it didnt show the word ‘FULL’ when the cell was charged that it was faulty and to return it.
Have you noticed that with your V2 especially with NIMH that it doesnt really charge up to 1.50V? On my V2 it usually stops at around 1.38V.
Also it gets messed up with the IR numbers and just shows gibberish instead of numbers.

Have you wiped the contacts of the charger and your cells with alcohol?

Looked especially for low voltage finish since several people here said it could be a problem, but no, mine (including slot #2 with reworked IC) charges same on all slots for example four new eneloops finish at 1.52V 0.75A 0.51-0.55mohm.When measured right after eject with multimeter it shows 1.49V. No garbage readings.

Without surprise,
forced to replace second chip, this time on #1 slot same symptoms, same resolution, fortunately i have still 3 spare parts.
Anyway, beside this charger work great when not broken, I’m not recommending miboxer c4-12 upgrade to any end user not familiar with hot air smd montage.

Sorry to revive an old thread but yesterday my MiBoxer C4-12 slot #1 died.

Bought it some 18 months ago; way past any warranty. tantien11 replaced ME3118A (edit: post #15).

eBay listing doesn’t ship Canada. However, AE has Link at ~10 $ shipping.

I’ll try my hand in replacing but what is the underlying failure of the regulator? Is it too weak or another component that overdrives the chip?

Bad phone camera but a picture of the innards. Which is the regulator? Yellow or Red? (I’d have to re-open the unit to check).

Did not get notification for this so it is one year old - @Sidney Stratton did you tried replacement ?
I think you already now that ME 3118A are located horizontally (almost inline) with hugest capacitor on board.

Oh, this was some time ago. Trying to refresh my memory; edited my last post to reference tantien11 post #. (Originally posted Jan. 27th ’21)

I did get the regulators (5x) from AE and did a replacement of the ME3118A. Had some problems as these are solder sinked on the underside. There is no sign of such and being new with my heat gun, I tore off some of the traces. Out of my league for a newbie in SMD, I passed it to a friend which did all the work. It seems there was a capacitor that also failed and some resistors. The fellow re-built it all and is now working. He is very patient and so was I – 40 days in his shop.

This was August ’21. All-in-all this adventure took 7 months to be resolved.

Meanwhile, I ordered a Vapcell S4 Plus as I didn’t have much hope in reviving the charger. This one is much better in display crispness and has a discharge/charge capacity test – although I hadn’t used it.

I still use the MiBoxer on the occasional day, but I suspect it may die out again on some other channel. The root of the problem wasn’t found, and it seems this affected only a few unfortunate people. I don’t know what to make of the reliability of the product. It would seem they no longer make chargers. Perhaps too many faulty units? They had made upgrades and it wasn’t clear which version you got. And to add to the confusion, their naming scheme; C4, C4, C4-12, C4-12 (or something of that order, can’t recall the details).

So hopefully the Vapcell will outlive the MiBoxer. Much thanks for researching and pointing out the defective regulator. People like you are great at enlightening us newbies and are an encouragement in our endeavours.

And thanks for responding to my dilemma, although late but better than never.

Indeed - it was some time ago - returned here to find some information about new flashlight and spotted year old notification. Don’t know why never found it in my mailbox.
Anyway I like things finalized so thanks for whole comment you gave.
Also looking to Miboxer page looks like they simply cutoff old story and go with Mi-light brand now (in my opinion mi light is comparable faulty as Miboxer chargers :-)).
Mine Miboxer get several faults from last year , but having spare parts , specialized in hot air montage so in 10 minutes it is back alive.Problem is that one ME3118A left and I I’m not planning to buy new 5 pieces because they are now incredible expensive so better to buy new charger :) Also have old UltraFire charger that still kicks and never fail :)

There seem to be 2 “Miboxer” websites now.

The Miboxer website ( doesn’t seem to list chargers.

But the Miboxer-charger website ( lists their charger models, although there has not been any new models for some time now.


With regards to the issues experienced (chip burning out?), maybe this can be due to higher charging current (and maybe some component are not durable enough to last the higher charging current?).

I notice that an updated Miboxer C4-12 v2 (2-button version), now has a few changes with the Miboxer C4-12 v2.2 (2-button version). No noticeable physical difference between the C4-12 v2 and C4-12 v2.2. (“v2.2” is indicated in the manual, not on the charger)

The C4-12 v2 can auto select a very high charging current of 3.0 Amps when the detected IR is very low (regardless if it’s a smaller or bigger size/capacity battery)

The new change is that the “auto-charge-current” appears to be limited to 2.0 Amp charge rate, even when the IR is very low (ie. the charger will not auto-select 2.5Amp or 3.0Amp charge current (unlike in the v2). Max auto-charge current now limited to 2.0 Amps.

Another change is that with the v2.2, when cycling the “charge current, on the v2, can go from 0.1A to 3.0A to ”A” (Automatic charge current). Whereas on the v2.2, there is not “A” (automatic charge current) when cycling through the charge current selection.

Could these changes be related to preventing too high charge current? (ie. 2.5Amp and 3.0Amp charge current can only occur when manually selecting charge current; unlike before where very high charge currents can be auto-selected if the IR is low enough.

Seems you are correct, i have no other than protected cells now so can’t confirm with that. But any protected cell discharged enough blow chip. Also, when you put cell to charger and immediately go to manual - it is already blow off (tested twice).
Guess it is no way to change v2 behavior to act like v2.2 ? Looks like programmed behavior, for reverse engeniering - chip in mine has no name.

About their web page - miboxercharger - looks like an empty shell, not finished portfolio. Tried contact with them several times by main site and this one you get 404 error or no response at all.
Summarizing, better to go forward, i will replace the rest of ME3118A as they die until i have them. Will try buy better charger next time :slight_smile:

(Sorry to necro an old thread)

Well crap, I have two of these and they’ve been reliable so far, but failing to 5v does NOT sit well with me. I haven’t been able to find anything else that offers all of the capabilities of this charger elsewhere…… =/

Did you look at Vapcell S4 Plus, looks like functionally better than c12.
Also it is old enough to reveal already all cons but not seen any.

Automatic mode is selected ‘manually’ :slight_smile: