slot #2 error on "Upgraded Miboxer C4-12" (got replacement unit..)

Mine work fine on all slots…no err shown…
But I cannot be 100% sure, haven’t had a test…but will check later on… :open_mouth:

New Miboxer C4-12, use 2 weeks - all excellent.

Any news from Miboxer? Did they repair your device?

Probably punctured the power output transistor.

Sent video to Banggood, who has shipped out a replacement unit. Not sure if it’s the whole unit or just the charger… still in shipping status.

can it source any current through the cell in the error state?
if it is trying to charge at 12v this could get ugly.

Please, write on the result.

Received replacement unit. Will need to try charging batteries to see if any errors still occur.

The unit that developed slot #2 error was originally functioning normally (I was trying testing different batteries, and they seem to charge properly), but the slot 2 error suddenly occurred. At first I thought I inserted battery incorrectly (reversed polarity will also show the same “C2 err” display), but when I double-checked, the battery was inserted properly, and the slot #2 suddenly developed that error, under normal usage scenario (only a few days test charging several batteries)…

Anyway, will still observe the replacement unit to see how it goes… Appreciate all the responses.

I wonder if there’s a way to fix the “C2 Err” on the original unit…

its probably just an infant mortality failure.
as for a repair open it up and you should see 4 identical stages one at each position.
you are likely looking for a shorted mosfet.
and you have 3 good stages to look at and compare readings.

I have same issue, It looks like in c4-12 upgrade #2 slot is now faulty. I can buy bunch of mosfet-s and replace them again and again if this is the problem. But it looks like it is deeper since no one report other port than #2 as faulty.
Submitted a complaint to the seller with refund request.

Could you show how to change the Mosfet (a picture of which part of the Miboxer C4-12 would be great) and what model/type of Mosfet replacement would be suitable for the slot #2 error? I’m not skilled nor knowledgeable enough to do such repairs, but if I can find someone to help do the “repair/soldering” to fix the slot #2… Thanks in advance.

Not opened it yet, waiting for seller information, I don’t want to broke warranty.
If dispute will be closed without luck I will try repair and send you some instructions if successfully.

I tried replacing ME3118A and it works

According to it has padded LX that can be pretty hard to replace it without proper tools.

Anyway still waiting for seller proposal.
AliEx proposed 1/4 of the price, currently can’t repair this for that amount so still negotiating.

Any other news, mine shows an error on slot 4 today after using it three or four times?

Hi yes,

I got refund for my broken c4-12 upgrade so now there is time and budget to open it.
After some measurements that I’m capable to do it looks like @tantien11 has right in my case.
Drain (LX) of second slot ME3118A gives full 12V and that gives overall error on this slot.
Attached picture that expose names of particular parts, not especially pretty but you should get part name.
I’m talking about 4 sop8 ICs placed on top - in my case it is second from left.

Thanks, I was offered 1/4 refund since three slots still worked. I said no , so they are sending me a new one. Might try to open the faulty one up. No experience with this lol

That was my first dispute on AliEx but there was no chance for full refund they first offered 1/4 of price and after that weirdly offered 55% without returning device.
Anyway it seems to me this IC is simply faulty and with my knowledge of several internet parts shop not found any decent repacement so ordered 5 pieces from ebay.
Whole crash probably happened when my protected 18650 was in #2 slot, that was my first attempt of loading of anything to this charger.
Only saw screen get reset and after that only error was displayed on #2 slot no mater what was putted there.
I have friend here who has hot air station and is capable to replace this IC - like said before it can be tricky to replace it only with soldering iron because of LX drain PFET pad that is placed under sop8 package. I don’t want to risk doing this myself :slight_smile:

You described how the error happened — I was also charging several 18650s on the C4-12 (I was near the charger since I was still observing this new charger), then the screen reset, and slot #2 showed Error.

If you’re able to open it, can I ask to take a picture of what parts are needed to be replaced? Thanks!
I don’t have the skill or knowledge to replace, but in case I can find someone who may be able to do it…

I’m talking about IC in SOP-8 package placed on top of my picture from previous post. There are 4 of them each for different slot.
It is named ME3118A.