Unique looking SS 1xAA light - anyone have it and pics of it?


I found this light on Ebay while browsing:


Does anyone have this light, and do you have any pics of it, esp. broken down?


Another one on my “To Buy” list. :slight_smile:

I suppose you wouldn’t have to worry about that light rolling off your desk!

Yeah, definitely. It kind of looks like one of the Xeno lights, doesn’t it (even though I don’t have a Xeno)?

And somewhat in a similar style to an MBI HF kinda-sort-of…

Maybe inspired by the Xeno cube?

From the pics, it looks like you get to the emitter (and probably the pill) by unscrewing that brass ring inside the front? The whole head and body looks like one piece?

Found it on U.K. ebay £9.99 free P&P.

I’ve got a couple of Nitecore 750mAh 14500’s as well, roll on payday. Unless anyone has had a bad experience with one?

lul @ 1000 lumens from a Q5

1000……100…….10 lumens. They’re just zeros. What’s a few zeros between friends? :smiley:

Mine shipped already :)!

Mine looks like it should get delivered tomorrow, so it’s like 7 days to arrive!

Has anyone else gotten theirs yet?

I think it’s similar to this, but different price.


There are some differences (I haven’t gotten mine yet - so just from pics):

- The tailcaps are different (Ebay one has a knurled screw-in one with rubber boot; CNQ is recessed metal button)

- The sides are different (Ebay one is smooth; CNQ has recesses)

  • The bezel rings may be different (Ebay one looks like brass; CNQ looks like aluminum or SS)

Of course, I don’t know if the one I will be receiving will look like the Ebay one :)…

It needs a BLACK boot. Then it would be perfect.

If the one from Ebay comes the way it’s pictured, that shouldn’t be difficult, since the tailcap unscrews from that one.

Maybe add an o-ring on top side of boot to give it a little recess … it looks partially recessed already.


Here’s some pics of the one I got:

Packaging (as such):


Front of light:

Tailcap end:

Lettering on side (says “AA/14500”):

Powered on (TF 14500):

Front bezel ring removed (lens feels like glass, reflector is alu, I think, but hard to tell). There’s also a clear plastic ring for the emitter insulation that I didn’t see when I took this pic):


The light is pretty heavy. Unfortunately, while I was playing around with it, the clicky switch stopped clicking/working, and left the light on. I’ve emailed the seller about that.

I haven’t been able to figure out if there’s a pill. I can see the emitter (pic above) and the driver (no spring) from the battery end of the tube, but that’s about it.

The whole head/body/tail seems to be one solid piece. I tried turning from the emitter end using the holes for the leads and a pair of tweezers, but it wouldn’t budge.

Anyway, that’s about it…


P.S. The printing (or screening) on the head says “Aleto”.

EDIT: Modes are L - H - Strobe

Measure tailcap current (TF 14500) - High = .824 amps

EDIT 2: Seller responded that they’d send a replacement tailcap!

Since that’s the case, I’ll try again to disassemble the tailcap I have. I had tried before, but the switch is held in by a white plastic disc, and I couldn’t get that to budge, so I’ll try more methods now.

Also, anyone have any ideas about getting the “pill” out?

EDIT 3: Since I should be getting a replacement switch, I figured that I’d autopsy the bad switch.

Original tailcap. That white disc is holding the switch in place, and it’s tough to get out:

Here it is apart:

What use to be the “white disc” with the inside of the tailcap after removing the disc. That white disc is now pretty much destroyed, but note that it has 2 small “prongs” that fit into the other plastic switch holder:

And here’s the culprit, I think. It looks like the switch came apart, and the cover kind of opened up. If I push it back into place, the switch still works, so I’m going to try to glue it back and then somehow put the tailcap together again:

EDIT 4: Got the switch “fixed”, but it’s a real hack. I pushed the cover that was popped up back, and then use AA on both sides of the switch. I then put the switch back into the tailcap, but didn’t work. That metal tab that’s on the side is suppose to provide contact to the body, but it’s very weak metal, and keeps bending so it’s not touch when the switch is shoved back into the white plastic holder that’s stuck inside the base. So what I did was shove the switch back into the base, then soldered the tab to the inside of the tailcap. I’m not sure how long it’ll last, but hopefully the Ebay seller will be good to their word and send a new tailcap. Also, I sent them a message via Eba with a pic of the switch with the cover popped up.

Has anyone gotten this light yet? Also, has anyone figured out how to get the pill out of the light?

Mine is still working with the cobbled-together tailcap switch. The replacement switch is suppose to be on its way.


EDIT: By accident, figured it out!! I was knocking the front end to get the small plastic disc out, and lo and behold, the pill just fell out. It turns out that there’s also a spring “behind” the pill, to push it and the reflector against the front lens. Pretty clever.

Here’s a shot of the disassembled pieces:


  • the body, then
  • the spring, then
  • the pill, then
  • the plastic insulation disc, then
  • the reflector, then
  • the lens, then
  • the brass retaining ring…

Now, what can I mod it with :slight_smile:

thanks Jim. Thru this thread I’m going to try and fix a switch that stopped working on my Quark X AA2. Can’t hurt to try :8)