Xeno e03 bezel won't sit flush [RESOLVED]

I'm almost done modding this thing with a penny in the pill, Qlite Rev.A driver configured for firefly, and 90+ CRI XM-L2. My first mod.


I can't get the bezel all the way on. I'm putting a lot of force on it, but it's not budging. I'm putting the oring under the lens and on top of the reflector, but I tried it between the lens and bezel too. Maybe the latter is right because the oring doesn't seem to be getting enough light on it to glow.

Ideas? I'm going to take it apart again to see if I can screw the pill in more. I've already tried it, but I don't see what else it can be. It's frustrating to be so close.

Thicker MCPCB than the original MCPCB?

I fried the dielectric layer off the original, so I can't measure it, but the MCPCB I'm using is pretty thin.

I got the pill to screw in a little further, but bent up my finest tweezers. I filed another set of tweezers and got it to turn a few more degrees. The bezel goes down further, but it needs to go further.

Inside of the flashlight there's a machined area about where the oring would go. It'd seem like the oring would get pushed outwards into that area so the lens makes contact with the reflector. Unfortunately I can't get the reflector low enough to expose that area. It's almost there.

There's markings that indicate the reflector is sitting on the MCPCB like it should.

I don't think it'd make a difference here, but I'll mention that I put Arctic Silver 5 on the threads of the pill.

I'm tempted to give up and use another oring to hide the gap.

i have a broken xeno e03, that only works if i apply force around the pill. but i just cant get the bezel off! how did you guys remove it?

ok, didn’t think of that, have just tried using pliers