gyrfalcon all 44 issue

3 posts / 0 new
Last post
wolfey
Offline
Last seen: 1 week 2 days ago
Joined: 05/24/2017 - 08:11
Posts: 4
gyrfalcon all 44 issue

I’m having some issue with my gyrfalcon all 44 charger. Sometimes the voltage readings stall and when I wiggle the cells some the readings jump up to the correct reading. I’ve had it where it will stall at say 4.15 and I’ll wiggle the cell and it’ll then read 4.20 and the red light that indicates termination will come on. I’ve also had it do the same but after wiggling the cell it will read 4.25 which is overcharged.
I have to constantly monitor the cells while they charge and it gets annoying when charging a lot of cells. I’m just wondering if anyone else has had any issues with the gyrfalcon chargers and I’m holding off on buying the all-88 if this is a known problem or just my one charger is faulty.

Edited by: wolfey on 06/09/2018 - 22:20
klrman
klrman's picture
Offline
Last seen: 1 hour 19 min ago
Joined: 11/07/2016 - 22:44
Posts: 1056
Location: Canada

I don't get a 4.25V reading on any of my chargers, but otherwise what you described is common to all chargers very often.  What has worked for me is that before you insert any batteries, clean the terminals of the charger and also the the terminals of the battery and then insert them to reduce resistance.  I just use a microfibre cloth to do that and some use 91% alcohol if I remember correctly. Still sometimes I need to wiggle the batteries a little now and then.

wolfey
Offline
Last seen: 1 week 2 days ago
Joined: 05/24/2017 - 08:11
Posts: 4

Thanks. I’ll clean the contacts and batteries and see how that goes.